ISPConfig3 - Umleitung falsch gesetzt, keine Verbindung zu ISPC3 und web.

#1
Hallo, ich habe aus versehen bei umleitung zwar den pfad gelöscht aber nicht den type.

Somit habe ich jetzt den zustand:
Redirect Type: L
Redirect Path: ist leer

Das hat zur folge das ich kein zugriff mehr auf das web sowie auf ispconfig3 und webmail habe.

Was kann ich tun um das problem zu lösen um ispc3 sowie das web wieder sichtbar/funktionsfähig zu machen.

Danke im vorraus.

.
 
Zuletzt bearbeitet:
#3
Danke für die Information.

In welcher vHost Datei (Debian 5) wäre das, bin momentan am Verzweifeln trotz Linux Server Buch.

Und wie finde ich dann in der Datei Redirect Type: L, also wie deaktiviere ich ihn dann?
Also auf "no redirect" schalten.

Vielen Dank
 
#5
Ja danke, das habe ich mir schon fast gedacht und schon vorher ein blick hinein geworfen.

Nun bin ich aber noch nicht so erfahren das ich so etwas auf den ersten blick sehe, erkenne und weiß, was heißen soll: was genau müsste ich ändern bzw. Darauf achten was mit der umleitung zu tun hat?

Vielen dank
 
#7
.

Dies ist die Datei MEINE_DOMAIN.de.vhost in /etc/apache2/sites-enabled/


<Directory /var/www/MEINE_DOMAIN.de>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost xx.xx.xx.xx:80>
DocumentRoot /var/www/MEINE_DOMAIN.de/web

ServerName MEINE_DOMAIN.de
ServerAlias www.[B]MEINE_DOMAIN.de[/B]
ServerAdmin webmaster@[B]MEINE_DOMAIN.de[/B]

ErrorLog /var/log/ispconfig/httpd/MEINE_DOMAIN.de/error.log


ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/MEINE_DOMAIN.de/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web1/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>


# cgi enabled
<Directory /var/www/clients/client1/web1/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/www/clients/client1/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web1 client1
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# php as fast-cgi enabled
<IfModule mod_fcgid.c>

# SocketPath /tmp/fcgid_sock/

# IdleTimeout n (3600 seconds)
# An idle fastcgi application will be terminated after IdleTimeout seconds.
IdleTimeout 3600

# ProcessLifeTime n (7200 seconds)
# A fastcgi application will be terminated if lifetime expired, even no error is detected.
ProcessLifeTime 7200

# MaxProcessCount n (1000)
# The max count of total fastcgi process count.
# MaxProcessCount 1000

# DefaultMinClassProcessCount n (3)
# The minimum number of fastcgi application instances for any one fastcgi application.
# Idle fastcgi will not be killed if their count is less than n
# Set this to 0, and tweak IdleTimeout
DefaultMinClassProcessCount 0

# DefaultMaxClassProcessCount n (100)
# The maximum number of fastcgi application instances allowed to run for
# particular one fastcgi application.
DefaultMaxClassProcessCount 100

# IPCConnectTimeout n (3 seconds)
# The connect timeout to a fastcgi application.
IPCConnectTimeout 8

# IPCCommTimeout n (20 seconds)
# The communication timeout to a fastcgi application. Please increase this
# value if your CGI have a slow initialization or slow respond.
IPCCommTimeout 360

# BusyTimeout n (300 seconds)
# A fastcgi application will be terminated if handing a single request
# longer than busy timeout.
BusyTimeout 300

</IfModule>
<Directory /var/www/MEINE_DOMAIN.de/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web1/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>

RewriteEngine on
RewriteCond %{HTTP_HOST} ^MEINE_DOMAIN.de [NC]
RewriteRule ^/(.*)$ /$1 [L]
RewriteCond %{HTTP_HOST} ^www.[B]MEINE_DOMAIN.de[/B] [NC]
RewriteRule ^/(.*)$ /$1 [L]

# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web1 client1
</IfModule>

<IfModule mod_dav_fs.c>
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>

display_errors = off

</VirtualHost>

Ich hoffe du kannst mir weiterhelfen.

Danke soweit. ^^


.
 
#8
Den Teil einfach auskommentieren (# davor):
RewriteEngine on
RewriteCond %{HTTP_HOST} ^MEINE_DOMAIN.de [NC]
RewriteRule ^/(.*)$ /$1 [L]
RewriteCond %{HTTP_HOST} ^www.MEINE_DOMAIN.de [NC]
RewriteRule ^/(.*)$ /$1 [L]
sollte dann so aussehen:
#RewriteEngine on
#RewriteCond %{HTTP_HOST} ^MEINE_DOMAIN.de [NC]
#RewriteRule ^/(.*)$ /$1 [L]
#RewriteCond %{HTTP_HOST} ^www.MEINE_DOMAIN.de [NC]
#RewriteRule ^/(.*)$ /$1 [L]
dann die Änderungen aktivieren:

/etc/init.d/apache2 reload
 
#9
Also auskommentieren.

#RewriteEngine on
#RewriteCond %{HTTP_HOST} ^MEINE_DOMAIN.de [NC]
#RewriteRule ^/(.*)$ /$1 [L]
#RewriteCond %{HTTP_HOST} ^www.MEINE_DOMAIN.de [NC]
#RewriteRule ^/(.*)$ /$1 [L]

Habe aber nun Fehlermeldung:

/etc/init.d/apache2 reload

Syntax error on line 131 of /etc/apache2/sites-enabled/MEINE_DOMAIN.de.vhost:

Invalid command 'display_errors', perhaps misspelled or defined by a module not included in the server configuration

failed!

.
 
Zuletzt bearbeitet:
#13
.

Weder noch.


Hier die Daten...

apache2ctl -S
[Mon Jan 31 20:06:36 2011] [warn] NameVirtualHost xx.xx.xx.xx:443 has no VirtualHosts
VirtualHost configuration:
xx.xx.xx.xx:80 is a NameVirtualHost
default server MEINE_DOMAIN.de (/etc/apache2/sites-enabled/MEINE_DOMAIN.de.vhost:8)
port 80 namevhost MEINE_DOMAIN.de (/etc/apache2/sites-enabled/MEINE_DOMAIN.de.vhost:8)
wildcard NameVirtualHosts and _default_ servers:
_default_:8081 vserverXXXX.vserver-on.de (/etc/apache2/sites-enabled/000-apps.vhost:10)
*:8080 is a NameVirtualHost
default server vserverXXXX.vserver-on.de (/etc/apache2/sites-enabled/000-ispconfig.vhost:10)
port 8080 namevhost vserverXXXX.vserver-on.de (/etc/apache2/sites-enabled/000-ispconfig.vhost:10)
*:80 is a NameVirtualHost
default server vserverXXXX.vserver-on.de (/etc/apache2/sites-enabled/000-default:1)
port 80 namevhost vserverXXXX.vserver-on.de (/etc/apache2/sites-enabled/000-default:1)
Syntax OK
.
 
Zuletzt bearbeitet:
#14
Soweit ich die Meldung verstehe, soll kein Host da sein, aber wo ist dann der Fehler.

Wie schon gesagt müsste es die Weiterleitung sein?



EDIT:
Ein Neustart des Rechners hat geholfen und es geht wieder alles bisher.

1.) Nur woran lag der Fehler, welcher Dienst war defekt bzw. abgeschaltet.

2.) Wenn ich die display_errors wieder deauskomitiere also aktiviere dann kommt die Fehlermeldung wie oben wieder.

3.) Jetzt geht die Seite wieder nicht nach ein paar Minuten?
Habe aber mal /etc/init.d/apache2 start ausgeführt und es geht dann wieder, aber mit der Fehlermeldung:
Starting web server: apache2[Tue Feb 01 20:25:04 2011] [warn] NameVirtualHost xx.xx.xx.xx:443 has no VirtualHosts



Aber wo liegt hier der Fehler?



THX


.
 
Zuletzt bearbeitet:
#15
Danke für deine Antwort und Hilfe.

Ich habe herausgefunden, muss aber sagen das ich mir noch nicht zu 100% sicher bin, das wo ich den Redirect Typ "L" auf "no Redirect" geschallten habe, in ISPConfig 3, das dann wieder das Web weg war.

Nun habe ich dann einfach "/etc/init.d/apache2 start" ausgeführt und das Web war wieder da, frag mich bloß warum dieser Effekt.
Also hat /etc/init.d/apache2 sich abgeschaltet/abgestürzt.


Ich glaube aber das ich das Problem gefunden habe weil ich noch etwas entdeckt habe:


Ich habe unter ISPC3 - Web Domain unter Optionen unter
+ Custom php.ini settings: display_errors = off
+ Apache Direktiven: display_errors = off

gesetzt gehabt, daher sollte der Fehler gekommen sein. ??


Allerdings habe ich diese Werte in beiden Feldern gesetzt weil:
erst wenn ich bei beiden diesen Befehl eingefügt habe, hat dann auch erst display_errors = off reagiert.

Das heißt, selbst wenn ich im Web die php.ini mit dem Inhalt display_errors = off gesetzt habe und unter ISPC3 / Custom php.ini settings: display_errors = off gesetzt habe, hat es nicht reagiert/funktioniert.

Es blieb dennoch on/an.


Ich schau mal weiter ob das Problem weiterhin besteht.

Frage:
Wie setzte ich denn sonst die php.ini und Custom php.ini settings:, das nun display_errors = off in der php.ini greift??

Und nun kann ich mich schon wieder nicht mit Webmail verbinden obwohl diesmal die Umleitung wieder auf Standard steht, das verstehe ich nun wirklich nicht.

Der es liegt eine Softverknüpfung webmail unter /var/www sonst konnte ich die erreichen, jetzt nicht mehr.
Ich denke das ich nun alles wieder auf Standard zurück versetzt habe, daher auch die Frag.


.
 
Zuletzt bearbeitet:

Till

Administrator
#16
display_errors = off ist eine php.ini Direktive und keine des apache Webserevres. Du kannst sie also nur im php.ini Feld setzen, denn wenn Du sieim apache Direktiven Feld setzt erzeugt dass eine ungültige apache Konfigurationsdatei und die Apacke Konfiguration wird dann nicht geschrieben, da apche sonst nicht mehr starten würde.
 
#17
Vielen dank für deine Hilfe, das musste ich auch erfahren und es war auch der Fehler.


Aber ich stehe im Augenblick noch vor zwei drei Problemen und hoffe auf weitere Hilfe.

Zum einen möchte ich fragen was es nun schon wieder mit Webmail (Squirrelmail) nun auf sich hat das dies schon wieder nicht erreichbar ist.

Diesmal habe ich ja wieder keinen Weiterleitungspfad woran es liegen könnte und das gerade noch vorhandenen Problem ist ja nun gelöst.

Zum zweiten muss ich ClamAV upgraden/updaten finde aber da keine Lösung für Anfänger und in Deutsch.

Zum dritten habe ich immer noch die Fehlermeldung, in der Console, NameVirtualHost xx.xx.xx.xx:443 has no VirtualHosts

Woran kann dies liegen?


Hier nochmals der Auszug bei dem Befehl: apache2ctl -S
[Wed Feb 02 12:38:56 2011] [warn] NameVirtualHost xx.xx.xx.xx:443 has no VirtualHosts

VirtualHost configuration:
xx.xx.xx.xx:80 is a NameVirtualHost

default server MEINE_DOMAIN.de (/etc/apache2/sites-enabled/MEINE_DOMAIN.de.vhost:7)
port 80 namevhost MEINE_DOMAIN.de (/etc/apache2/sites-enabled/MEINE_DOMAIN.de.vhost:7)

wildcard NameVirtualHosts and _default_ servers:

_default_:8081 vserverxxxx.vserver-on.de (/etc/apache2/sites-enabled/000-apps.vhost:10)
*:8080 is a NameVirtualHost

default server vserverxxxx.vserver-on.de (/etc/apache2/sites-enabled/000-ispconfig.vhost:10)
port 8080 namevhost vserverxxxx.vserver-on.de (/etc/apache2/sites-enabled/000-ispconfig.vhost:10)
*:80 is a NameVirtualHost

default server vserverxxxx.vserver-on.de (/etc/apache2/sites-enabled/000-default:1)
port 80 namevhost vserverxxxxx.vserver-on.de (/etc/apache2/sites-enabled/000-default:1)
Syntax OK
.
 
Zuletzt bearbeitet:
#19
Über Private Massage:
Aber dennoch habe ich nach Eingabe des Befehls (siehe Beitrag die letzten Beiträge) noch eine Fehlermeldung das der vHost kein vHost ist, was mich aber wundert.

1.) Wie sieht deine Konfiguration des Webs im ISPc3 aus?
Hast du bei IP-Adresse das '*' drin oder eine IP-Adresse?

2.) Hast du ggfs. ein Backup deiner Mails und Webs?

3.) Evtl. wäre ein update von ISPc3 und damit neu schreiben der Configs am Besten, dann hättest du eine "neue" saubere Ausgangslage. An sich gehen auch keine Daten verloren.
1.) Ist meine IP schon drin

2.) Leider nein, bzw. zu aktuell.

3.) Update habe ich gemacht von 3.0.3.1 auf 3.0.3.2, aber keine Änderung.
Komischerweise habe ich dies eigentlich schon mal gemacht da eine Stunde nach der Install von ISPC3 3.0.3.1 das Update auf ...2 draußen war, trotzdem war die Versionsnummer nach dem Neustart des BS wieder die alte ??!??


@Till

Danke für den Link:
Weist du ob du mir den Link auch auf Deutsch geben kannst?

Debian 5 mit apt-get update und apt-get upgrade aktuell.
Habe aber Fehlermeldung.


Hier ein Auszug:

DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
daily.cld is up to date (version: 12620, sigs: 35178, f-level: 58, builder: ccordes)
--------------------------------------
Received signal: wake up
ClamAV update process started at Thu Feb 3 16:17:42 2011
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.96.5
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
daily.cld is up to date (version: 12620, sigs: 35178, f-level: 58, builder: ccordes)
--------------------------------------
Received signal: wake up
ClamAV update process started at Thu Feb 3 17:17:42 2011
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.96.5
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
daily.cld is up to date (version: 12620, sigs: 35178, f-level: 58, builder: ccordes)
--------------------------------------
Received signal: wake up
ClamAV update process started at Thu Feb 3 18:17:42 2011
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.96.5
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
Ignoring mirror 188.40.42.237 (due to previous errors)
Ignoring mirror 212.1.60.18 (due to previous errors)
Ignoring mirror 212.18.5.140 (due to previous errors)
Ignoring mirror 213.174.32.130 (due to previous errors)
Ignoring mirror 62.27.56.14 (due to previous errors)
Ignoring mirror 85.10.242.82 (due to previous errors)
Ignoring mirror 85.214.44.186 (due to previous errors)
Ignoring mirror 85.214.115.224 (due to previous errors)
Trying host db.local.clamav.net (89.149.194.18)...
nonblock_connect: connect timing out (30 secs)
Can't connect to port 80 of host db.local.clamav.net (IP: 89.149.194.18)
Trying host db.local.clamav.net (193.27.50.222)...
WARNING: getfile: Unknown response from remote server (IP: 193.27.50.222)
WARNING: getpatch: Can't download daily-12621.cdiff from db.local.clamav.net
Ignoring mirror 212.18.5.140 (due to previous errors)
Ignoring mirror 213.174.32.130 (due to previous errors)
Ignoring mirror 62.27.56.14 (due to previous errors)
Ignoring mirror 85.10.242.82 (due to previous errors)
Ignoring mirror 85.214.44.186 (due to previous errors)
Ignoring mirror 85.214.115.224 (due to previous errors)
Trying host db.local.clamav.net (89.149.194.18)...
nonblock_connect: connect timing out (30 secs)
Can't connect to port 80 of host db.local.clamav.net (IP: 89.149.194.18)
Trying host db.local.clamav.net (212.227.138.145)...
Downloading daily-12621.cdiff [100%]
daily.cld updated (version: 12621, sigs: 35183, f-level: 58, builder: neo)
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Current functionality level = 38, recommended = 58
DON'T PANIC! Read http://www.clamav.net/support/faq
Database updated (881397 signatures) from db.local.clamav.net (IP: 212.227.138.145)
WARNING: Clamd was NOT notified: Can't connect to clamd through /var/run/clamav/clamd.ctl
--------------------------------------
Received signal: wake up
ClamAV update process started at Thu Feb 3 19:18:43 2011
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.2 Recommended version: 0.96.5
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
daily.cld is up to date (version: 12621, sigs: 35183, f-level: 58, builder: neo)
.



Kann man hier irgend wie mal die Einstellungen Posten oder muss ich das aufwendig einzeln Aufschreiben?


.
 
Zuletzt bearbeitet:

Till

Administrator
#20
Debian 5 mit apt-get update und apt-get upgrade aktuell.
Habe aber Fehlermeldung.
Dann ist ja alles bestens. Das ist auch keine Fehlermeldung, liss Dir doch mal den Text durch, der hinter dem No Panic Link ist.

Die einzig relevanten Meldungen sind:

main.cvd is up to date (version: 53, sigs: 846214, f-level: 53, builder: sven)
daily.cld is up to date (version: 12620, sigs: 35178, f-level: 58, builder: ccordes)

was bedeutet dass der Clamav aktuell ist.

3.) Update habe ich gemacht von 3.0.3.1 auf 3.0.3.2, aber keine Änderung.
Komischerweise habe ich dies eigentlich schon mal gemacht da eine Stunde nach der Install von ISPC3 3.0.3.1 das Update auf ...2 draußen war, trotzdem war die Versionsnummer nach dem Neustart des BS wieder die alte ??!??
Das ist ok. Dann ist Deine Installation aktuell, wir hatten für ca. 1-2 Stunden nach dem Release noch die alte Versionsnummer im code drin. Es ist also die 3.0.3.2 die Du installiert hast wenn Du die 3.0.3.2 Datei heruntergeladen hattest, auch wenn sie die alte Versionsnummer anzeigt.

Das Tutorial gibt es leider nur auf englisch.
 

Werbung