[ISPConfig3] User keine Schreibrechte per FTP

#1
Hallo,

nun bin ich verwirrt. Ich habe meine Domain umgeschaltet, liegt nun da und freut sich. Ich habe Ruby installiert und will test weise was hochladen.
Tja pustekuchen. Denn nichts passiert bzw. es passiert viel, aber nicht das was ich will :)
Code:
Befehl:	STOR index.rb
Antwort:	553-Can't open that file: Permission denied
Antwort:	553 Rename/move failure: No such file or directory
Fehler:	Kritischer Fehler
DAs kam bei Filezilla. Tja und nun bin ich irgendwie ganz weg. Ich blicke da auch nicht mehr durch.

Also ich habe mit meinem Admin einmal mich angelegt. Habe dadrinne dann eine Site angelegt und bin in einem Ordner clients gelandet. Machen konnte ich nichts. Dachte ich mir, okay, ich muss das so machen, dass ich wieder einen Kunden anlege. Dann war ich bei clients/web4 (nach einigen Testversuchen) Aber auch da konnte ich nichts machen.

Ich bitte mal um aufklärung. Wie läuft das ganze nun? Ich bin wirklich verwirrt. Arbeitet das System immer nun mit /var/www/client/client1/ ? und wenn ja, wie spiele ich da was drauf, denn Zugang habe ich keinen und mit dem FTP komme ich ja auch nicht wirklich so weit, dass ich mit client ansehen könnte.

Vielen Dank

AndréS
 
#2
Komisch genau das selbe hatte ich gestern auch, als ich einen Server auch mit ISPConfig 3 aufsetzte. Habe dann einfach nochmal installiert und genauer drauf geachtet was ich da mache, und zumindestens jetzt läuft alles :)
 
#3
Na ja, aber nochmal??? Das wäre das vierte Mal.

Und um ehrlich zu sein, ich habe alles genaustens verfolgt und so gemacht wie es im Tut steht. Muss doch auch ne andere Lösung geben!?

AndréS
 

Till

Administrator
#5
Also erstmal vorweg, nicht immer neu installieren sondern lieber mal den Fehler analysieren. Damit spart Ihr Euch eine Menge Zeit.

Du kannst also nichts hochladen, weil die Rechte nicht stimmen. Dann schaut man sich also immer erstmal die Rechte and und vor allem wo Du es hochladen willst. Hochladen kannst Du z.B. immer nur in das Unterverzeichnis "web". Poste also mal die Ausgabe von:

ls -la

wenn Du im Web Verzeichnis dieser Seite bist.
 
#6
Nabend,

nee wollte auch nicht nochmal installieren.

Upa, nachdem ich das nun auch sehe, das es doch noch web gibt, bin ich erschrocken. Wenn ich mit filezilla raufgehe bekomme ich nichts weiter angezeigt.
Wirklich nichts.
Laut ISPConfig bin ich hier: /var/www/clients/client4/web4

Wenn ich per SSH reingehe ist alles super, da sehe ich sogar auch noch dann web etc.
da ich unter ubuntu scheinbar nicht kopieren kann aus Putty heraus, erstmal soweit ich sehe diese Ordner gar nicht im FTP und die Schreibrechte schauen echt gut aus wenn ich im web drinne bin.

Danke

AndréS

*edit*
Noch was, wenn ich meine Webseite aufrufe bekomme ich nur den Fehler 403 nicht aber die standartseite die eigentlich in dem web Ordner liegt. Ich glaube da funktioniert was nicht mit der Weiterleitung.

AndréS
 
Zuletzt bearbeitet:

Till

Administrator
#7
Also irgend was stimmt da wirklich nicht mit der Seite. Lösch doch einfach mal den ftp user und dann die seite und dann leg sie neu an. Vielleicht hast Du die irgendwie zwischen Kunden verschoben, da war in einem Release noch ein Bug der im SVN behoben wurde.
 
#8
Hatte leider keinen Erfolg.

Sag mal ne doofe Frage, kann es sein, dass ich als ftp user das nicht darf weil das jemanden "anders" gehört? Kann es an den Owner liegen oder so?

AndréS
 
#10
Okay hier dann mal die Schreibrechte

Code:
Debian-50-lenny-64-LAMP:/var/www/clients/client5# ls -la
total 12K
drwxr-xr-x 3 root root 4.0K 2009-07-12 14:38 .
drwxr-xr-x 5 root root 4.0K 2009-07-12 14:38 ..
drwx--x--x 6 root root 4.0K 2009-07-12 14:38 web5
lrwxrwxrwx 1 root root   30 2009-07-12 14:38 webby24.de -> /var/www/clients/client5/web5/
Code:
Debian-50-lenny-64-LAMP:/var/www/clients/client5/web5# ls -la
total 24K
drwx--x--x 6 root root    4.0K 2009-07-12 14:38 .
drwxr-xr-x 3 root root    4.0K 2009-07-12 14:38 ..
drwx--x--x 2 web5 client5 4.0K 2009-07-12 14:38 cgi-bin
lrwxrwxrwx 1 web5 client5   35 2009-07-12 14:38 log -> /var/log/ispconfig/httpd/webby24.de
drwx--x--x 2 web5 client5 4.0K 2009-07-12 14:38 ssl
drwx--x--x 2 web5 client5 4.0K 2009-07-12 14:38 tmp
drwx--x--- 4 web5 client5 4.0K 2009-07-12 14:38 web
Code:
Debian-50-lenny-64-LAMP:/var/www/clients/client5/web5/web# ls -la
total 28K
drwx--x--- 4 web5 client5 4.0K 2009-07-12 14:38 .
drwx--x--x 6 root root    4.0K 2009-07-12 14:38 ..
drwxr-xr-x 2 web5 client5 4.0K 2009-07-12 14:38 error
-rwxr-xr-- 1 web5 client5 1.4K 2009-07-12 14:38 favicon.ico
-rwxr-xr-- 1 web5 client5    0 2009-07-12 14:38 .htaccess
-rwxr-xr-- 1 web5 client5 1.9K 2009-07-12 14:38 index.html
-rwxr-xr-- 1 web5 client5   34 2009-07-12 14:38 robots.txt
drwxr-xr-x 2 root root    4.0K 2009-07-13 00:30 stats
wenn ich die Seite aufrufe www.webby24.de dann bekomme ich eine Rechtfehlermeldung.

Und FTP kennst du ja schon :)

AndréS
 
#11
Habe jetzt mal die Recht auf www-data gesetzt und ich bekomme sofort meine index

hier mal das ls -la
Code:
Debian-50-lenny-64-LAMP:/var/www/clients/client5/web5# chown www-data web
Debian-50-lenny-64-LAMP:/var/www/clients/client5/web5# ls -la
total 24K
drwx--x--x 6 root     root    4.0K 2009-07-12 14:38 .
drwxr-xr-x 3 root     root    4.0K 2009-07-12 14:38 ..
drwx--x--x 2 web5     client5 4.0K 2009-07-12 14:38 cgi-bin
lrwxrwxrwx 1 web5     client5   35 2009-07-12 14:38 log -> /var/log/ispconfig/httpd/webby24.de
drwx--x--x 2 web5     client5 4.0K 2009-07-12 14:38 ssl
drwx--x--x 2 web5     client5 4.0K 2009-07-12 14:38 tmp
drwx--x--- 4 www-data client5 4.0K 2009-07-12 14:38 web
Jetzt ist nur die Frage, wie mache ich das, dass ich das nicht immer wieder und wieder von hand machen muss????

Danke dir

André
 

Till

Administrator
#12
Das setzen auf ww-data war falsch, die dürfen nicht www-data gehören sondern Sie müssen dem user web5 und der Gruppe client5 gehören. Dein Problem liegt woanders, Du hast die Dateien mit den falschen Rechten hochgeladen, die Dateien müssen nämlich worl readable sein. Du hast also enteweder die Rechte in Deinem FTP Client falsch gesetzt oder Du musst die umask Einstellung in der pureftpd Konfigurationsdatei ändern.
 
#13
okay, das ändere ich dann nochmal.

Ich habe ja noch gar nichts hoch geladen. Hatte ja kein Recht darauf zuzugreifen. Wie ändere ich das denn im pureftp???

Danke dir.

AndréS
 
#14
Also chmod manuell setzen funktioniert so, dass ich das sehen kann im Webbrowser. Also keinen 403 bekomme.
ABER mit FTP klappt da gar nichts, da sehe ich genau so wenig wie vorher.

habe mir auch mal das unmask angesehen, habe da nun 644 und 755 eingeben. gebracht hat es leider nichts. habe das hier auch irgendwo im Forum gefunden wie man das eingibt, aber weiß nicht ob das richtig war.

Wie mache ich das also richtig :)

Vielen Dank

AndréS
 
#16
Also gebe ich den Befehl keine Ahnung mehr wie der war ein und sage 022 133 oder wie? Weil muss ja oktal sein und da bei 0 alles anfängt wäre das nun das richtige Ergebnis.

Hast du gerade den Befehl im Kopf?

Muss ich dann auch noch mal den User löschen oder riecht es wenn ich die Site lösche???

André
 
#18
Genau das meinte ich ja auch. Aber dies lässt sich ja mit sicherheit mit einem Befehl ala echo '' > in die Datei
tun oder?

Weil gegenwärtig weiß ich nicht WIE ich den einstellen soll. Daher fragte ich so.

Danke dir

AndréS
 
#20
Hi AndréS

ich hatte ein ähnliches Problem
(siehe http://www.howtoforge.de/forum/showthread.php?t=2121)

Der Lösungsansatz kam von Till

Das gleiche Problem scheinst du wie ich zu haben

Code:
drwx--x--x 6 root root 4.0K 2009-07-12 14:38 web5
Der Ordner ist nur von root les/schreib/ausführbar, aber alle anderen haben keinen zugriff

Der Lösungsansatz von Till

system > server config auf dem web tab die securityEinstellung von high auf mdium
Danach den Ordner manuell umstellen auf 755
Code:
# chmod 755 web5
ab dann kann der ftp-user zugreifen auf den ordner

ich hoffe es hilft
 

Werbung

Top