ISPconfig3 Websites vhosts

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von udolinski, 4. Sep. 2009.

  1. udolinski

    udolinski New Member

    Hallo,

    auf einen 'frischen' SuSe11.1 hab ich ISPconfig3 ohne Probleme installiert.
    Nach Installation hab ich auch gleich SSL für Adminseiten, wie in den FAQ gechrieben, eingerichet. Klappt alles wunderbar.

    So, nachdem ich nun 3 Sites angelegt hatte, restart des apache kam die berühmte Fehlermeldung mit dem _DEFAULT_Host, der hier schon beschrieben wurde.. also hab ich dann die Directiven in den einzelnen vhost Dateien entsprechend angepasst und anstatt dem *:80 dann auch die IP:80 erfasst...
    ... nun startet der apache auch ohne warnings.. nur was logisch ist, wenn ich nun irgendwas im admin an der site verändere, dann wird die vhosts neu geschrieben und das Spielchen fängt von vorne an.
    Er schreibt mir immer *:80 neu rein.
    Gibt es dafür schon ne Lösung ?

    und: Irgendwas hab ich noch falsch konfiguriert. Wenn ich z.B. in der admin-sektion E-Mailboxen bei einem E-Mailaccount ganz rechts auf webmail drücke, dann ruft er zwar eine seite auf, aber mit einer falschen URI.
    Mein config: der host hat den namen server.meinserver.de
    die laufende Domain ist: www.meinechtserver.de
    admin dann https://www.menechtserver.de:8080
    so.. als Server hab ich naturlich den host eingetragen:server.meinserver.de

    wenn ich dann auf den besagten webmail-link will hat der als adresse:
    http://server.meinserver.de/webmail anstatt https://www.meinechtserver.de:8080/webmail
    Kann ich das noch irgendwie anpassen ?
     
  2. Till

    Till Administrator

    Ja, ändere niemals eine vhost Datei manuell. Die sind nicht zum editieren gemacht. Stattdessen wählst Du einfach in den vhost settings die IP statt * aus. Ist die Ip da nicht gelistet, dann füge sie vorher unter system hinzu.

    was gibt denn der Befehl:

    hostname -f

    auf der Shell zurück?
     
  3. udolinski

    udolinski New Member

    Servus Till,

    @vhost-Problem:
    Jaaaa. jetzt fällt es mir wie Schuppen von den Haaren... das war der entscheidende Tip.
    Der Server selber hatte keine IP unter den Settings.. folglich hatte die Dropdown in den vhosts setting auch nur den * drinne.
    Hab das geändert.. und dann die IP in den vhost erfasst ..
    Klasse funktioniert alles :) Super.
    Gelöst

    @server-meinserver Problem.
    klar hostname -f gibt server.meinserver.de zurück..

    d.h. im Klartext.. ich ändere einfach den Servernamen in der linuxkonfig.. ok.
    Aber wie bekomme ich dann den port 8080 hin ?
     
    Zuletzt bearbeitet: 5. Sep. 2009
  4. Till

    Till Administrator

    Sollte an sich reichen, wenn Du den apache neu startest.
     
  5. udolinski

    udolinski New Member

    oki.. werde ich heute abend testen..:)
     

Diese Seite empfehlen