ISPConfig3 - Ziel einer eingetragenen Domain ?!?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Rush, 14. Juli 2009.

  1. Rush

    Rush New Member

    Hi,

    ich habe mir auf meinem Server (Debian) ISPConfig installiert, was soweit auch problemlos geklappt hat.

    Das Problem liegt dabei, dass alle Domains, die ich im ISPConfig eintrage nicht im eigenen Ordner (/var/www/clients/client1/web1/) "landen" sondern alle auf /var/www/ zeigen.

    anstatt dass die domain nen eigenen "ordner" hat, wird somit immer die apache-default seite angezeigt... das ist eigentlich ja nciht der sinn der sache.

    wie schaffe ich es, dass die domains ihre eigenen verzeichnesse bekommen? Also die Verzeichnisse für die Domains existieren schon, aber die domains an sich nutzen diese aus irgend einem Grund nicht... :(

    ich hab noch ein weiteres problem. ich hab im isp-config zwar einen ftp-account erstellt, aber wenn ich mich mitm ftp-client verbinden will, kommt immer nur "login failed".

    ich schätze ich habe irgendwas in der config falsch gemacht.


    Danke im Voraus,

    Gruß
    Rush
     
    Zuletzt bearbeitet: 5. Sep. 2009
  2. Till

    Till Administrator

    Schau mal in den monitor von ispconfig, ob da irgendwelche Fehler drin stehen und überprüfe mal, ob die queue auch leer ist und somit Deine Config Änderungen auch ausgeführt wurden.
     
  3. Rush

    Rush New Member

    Hi,

    Monitor zeigt keine Fehler an (Nur, dass ich nen dhcp-kram upgraden soll, mittlerweile erledigt)

    [​IMG]

    ansonsten ist due queue leer. Wie gesagt, die betreffenden links wurden im /var/www/ ordner von ispconfig bereits angelegt, aber die domains verweisen halt immernoch direkt auf /var/www/...

    [​IMG]

    Irgend ne Idee?


    Gruß
    Rush
     
    Zuletzt bearbeitet: 15. Juli 2009
  4. Till

    Till Administrator

    Ok, dann kann es eigentlich ju sein dass der apache sich bei der Zuordnung der hosts vertut. In dem Fall musst Du ihm da etwas auf die Sprünge helfen indem Du die IP Adresse(n) in ISPConfig in den Server Einstellungen anlegst und sie dann explizit in den Webseiteneinstellungen anstatt des * auswählst.
     
  5. Rush

    Rush New Member

    Hallo Till,

    danke schonmal für deine Antwort(en).

    Ich hab in der Config die IP eingerichtet und sie bei den Sites eingetragen... soweit so gut. Scheint einiges gebracht zu haben.

    Ob die Domains jetzt richtig umleiten weiß ich nicht. jedenfalls bekomme ich beim Aufrufen der domains im Browser jetzt nurnoch ein "403" anstatt der Apache-Default-Page... :( scheint jetzt noch ein Rechte-Problem zu sein...

    Soweit scheine ich ja bereits viele (oder einige) Probleme aus dem Weg geräumt zu haben. Weißt du, wie ich das "403" Problem lösen könnte?

    Ach ja, wenn ich den Apache manuell neu starten will, kommt ne kleine Warn-Meldung...(IP hab ich hier mal zensiert):
    Code:
    Forcing reload of web server (apache2)...[Thu Jul 16 23:29:06 2009] [warn] NameVirtualHost 84.***.***.***:443 has no VirtualHosts
     waiting [Thu Jul 16 23:29:08 2009] [warn] NameVirtualHost 84.***.***.***:443 has no VirtualHosts
    Weiß nicht ob das zusammen hängt, jedenfalls kann ich die rechte ändern, wie ich will, ich bekomme stets ein "403 Forbidden" angezeigt, wenn ich eine der domains aufrufe, die ich in ISP-Config eingetragen habe...

    Gruß
    Rush
     
    Zuletzt bearbeitet: 17. Juli 2009
  6. Till

    Till Administrator

    Die Warning Meldung ist ok.

    Zu Deinem 403 Fehler. Scahu mal ind ie apache error logs der Webseite.
     
  7. Rush

    Rush New Member

    Hi,

    hab mir ma die Error-Log angeschaut. scheint irgendwas mit der .htaccess file nicht in ordnung zu sein...

    Code:
    [Fri Jul 17 09:12:50 2009] [crit] [client **.***.***.**] (13)Permission denied: /var/www/*******.com/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
    die rechte sind, wie folgt:
    Code:
    drwx--x--- 4 web2 client1 4096 Jul 17 09:16 .
    drwx--x--x 6 root root    4096 Jul 17 09:11 ..
    -rwxr-xr-- 1 web2 client1    0 Jul 14 14:07 .htaccess
    drwxr-xr-x 2 web2 client1 4096 Jul 14 14:07 error
    -rwxr-xr-- 1 web2 client1 1406 Jul 14 14:07 favicon.ico
    -rwxr-xr-x 1 web2 client1 1915 Jul 14 14:07 index.html
    -rwxr-xr-- 1 web2 client1   34 Jul 14 14:07 robots.txt
    drwxr-xr-x 2 root root    4096 Jul 17 00:30 stats
    weiß nich, was daran jetz nicht readable sein soll. alle r rechte sind doch gegeben ?!?


    Gruß
    Rush
     
    Zuletzt bearbeitet: 5. Sep. 2009
  8. Till

    Till Administrator

    Die .htaccess datei schein leer zu sein. Zumindest hat sie eine Größe von 0. Wenn sie leer ist, dann kannst Du sie ja auch löschen.
     
  9. Rush

    Rush New Member

    Hi, hab die .htacces ma geloescht. immernoch selbes Problem... wenn ich mir den fehler so anschaue, dann scheints als ob www-data nicht auf diese datei zugreifen darf... oder auf den ordner, der die datei beinhaltet... aber die rechte sind alle gesetzt... Gruss Rush
     
  10. Till

    Till Administrator

    Schau mal nach ob Du eine .htaccess Datei in
    /var/www/xxxxxxxxxxx.info oder /var/www liegen hast.
     
  11. Rush

    Rush New Member

    weder im einen, noch im anderen ordner... Bin gerade auf arbeit und kann hier kein ssh benutzen um locate auszufuehren. wenn ich es morgen zeitlich schaffe, schau ich ma nach, wo die datei sonst noch so rumliegt...
     
  12. Rush

    Rush New Member

    Hi,

    so, das hier sind die Pfade, in denen eine .htaccess Datei liegt, wobei man die phpmyadmin Ordner schonmal ausschliessen kann...

    [​IMG]

    Gruss
    Rush
     
  13. edvzillertal

    edvzillertal New Member

    Gleiches Problem

    Hallo!

    Ich habe seit der Installation das gleiche Problem und habe auch schon versucht die ipadresse zu ändern bzw habe auch datenvergleiche gemacht zu alten scripten!

    Wäre schön wenn jemand dieses Problem so schnell wie möglich behebt!
     
  14. Till

    Till Administrator

    Bei den vielen Infos die Du postest ist das auch ganz einfach ;)

    Wenn etwas für tausende User geht und bei 2 Usern nicht, dann kann ich erstmal davon ausgehen dass es sich eben nicht um ein Problem in der Software sondern um ein poblem auf dem System des users handelt. Um also dieses Konfigurationsproblem auf Deinem Server zu lösen, musst Du schon ein paar mehr Infos über Deinen Server geben:

    1) Welche Linux Distribution.
    2) Exakte Fehlermeldungen aus den Logs.
    3) Welche ISPConfig version und hast Du das tar.gz installiert oder vom svn?
     
  15. Rush

    Rush New Member

    Hi, so, ich hab jetzt nochmal n paar stunden daran rumgefummelt, is nix draus geworden... keine Ahnung, warum das nicht geht. fuer mich sieht es so aus, als ob die domains nach wie vor nicht richtig umleiten bzw. auf den richtigen ordner verweisen... ich blick da nicht durch... waere es sinnvoll einfach ISPConfig v2 zu installieren? Damit scheint es ja nicht so viele Probleme zu geben...? Welche groben Vorteile gibt es bei der v3 im Vergleich zur v2 ? Gruss Rush
     
  16. Till

    Till Administrator

    Wenn man Dir fragen stellt und Dein Problem zu lösen und Du diese nicht beantwortest, dann kann Dir auch keiner helfen.

    Die Unterscheide zwischen ISPConfig 2 und 3 wurden hier schon häufiger behandelt, Du findest dazu in den diversen Release notes und auch dem deutschen und englischen forum jede Menge Beiträge.

    ISPConig 2 und 3 sind beide stabil und funktionieren einwandfrei auf tausenden Produktivsystemen.
     
  17. Rush

    Rush New Member

    Hallo Till,

    ich glaube du hast mich da gerade mit dem anderen Typen verwechselt. Ich habe im ersten Beitrag, sowie in den darauf folgenden bereits diese Fragen beantwortet...

    wie gesagt werde ich jetzt erstmal ispconfig vom system runterwerfen und v2 neu drauf installieren...


    Gruss
    Rush
     
  18. Rush

    Rush New Member

    Hi,

    wollte nur nochmal meldung geben, dass ich v3 jetzt runtergeschmissen und durch v2 ersetzt habe, welche auf meinem system wunderbar funktioniert. Muss nochmal alles testen, aber es scheint bisher alles zu gehen.

    Gruß
    Rush
     

Diese Seite empfehlen