ISPCP3 ändert keine DNS Einträg mehr

Dieses Thema im Forum "Allgemein" wurde erstellt von SmileMan, 6. Aug. 2012.

  1. SmileMan

    SmileMan New Member

    [Gelöst] ISPCP3 ändert keine DNS Einträg mehr

    Hallo zusammen,

    ich habe seit neustem das Problem, dass geänderte DNS Einträge nicht mehr übernommen wurden. In der Datenbank werden diese geändert, aber nicht bei bind9.

    Wenn ich die server.sh Cron Datei manuell ausführe, während ich Log Level auf Debug stehen habe, heißt es nur "No update Records found".
    Andere Änderungen, beispielsweise an den Webseiten oder so, werden einwandfrei umgesetzt.

    Ich finde sonst in den Syslogs usw. keinerlei Fehlermeldungen. Was kann das sein, bzw. wie kann ich das Problem beheben?
     
    Zuletzt bearbeitet: 8. Aug. 2012
  2. Till

    Till Administrator

    Hast Du auch den cronjob der server.sh deaktiviertm bevor Du getestet hast wie in der FAQ beschrieben?
     
  3. SmileMan

    SmileMan New Member

    Mal abgesehen davon, dass ich gerade die ganze ISPConfig 3 FAQ durchgeschaut habe und nichts diesbezüglich gefunden habe, habe ich den Cronjob nicht deaktiviert.

    Ich wüsste spontan auch nicht, was die Deaktivierung eines Cronjobs da helfen soll?
     
  4. Till

    Till Administrator

    Es gibt nur einen einzigen Beitrag über das Debugging im FAQ und dort steht drin das man den Cronjob deaktivieren muss:

    Debugging of ISPConfig 3 server actions in case of a failure « FAQforge

    Ohne die Deaktivierung sind alle Ergebnisse wertlos, da Du nicht ausschließen kannst dass der Cronjob in dem Zeitraum wo Du im Interface auf speichern klickst bis zur manuellen Ausführung des Scriptes auf der Shell bereits ausgeführt wurde.
     
  5. SmileMan

    SmileMan New Member

    Ok, das leuchtet mir doch glatt ein :)

    Gesagt, getan, Cronjob deaktiviert, eine Änderung an den DNS Einträgen einer Domain gemacht und die server.sh ausgeführt. Leider sagte r aber weiterhin, dass keine Update records gefunden wurden.
     
  6. Till

    Till Administrator

    Ändere bitte mal etwas an einer Webseite und speichere doe Änderung, wird dann nagezeigt dass er Änderungen gefunden hat?
     
  7. SmileMan

    SmileMan New Member

    Entschuldige bitte, aber es wäre von Vorteil meine Beiträge richtig zu lesen. Ich hatte dies bereits im ersten Posting geschrieben.

    Wo wird denn genau die Info abgespeichert, dass Änderungen vorgenommen wurden?
     
  8. SmileMan

    SmileMan New Member

    Problem gelöst

    Ich habe das Problem selbst lösen können.

    Nach langem hin und her suchen und ausprobioeren ist mir dann am Ende aufgefallen, dass alle Domains in der Tabelle "dns_soa" auf server_id 2 standen und nicht auf 1. Nach Änderungen der Einträge auf "server_id=1" funktionierte dann endlich wieder alles.

    Da das Problem erst seit dem Update 3.0.4.6 war, gehe ich davon aus, dass dieser Umstand durch das Update aufgetreten ist.
     
  9. Till

    Till Administrator

    Das kann mit dem Update nichts zu tun haben, denn es werden keine Änderungen in den DNS tabellen durchgeführt. Da muss also jemand den DNS Server der Records geändert haben.
     
  10. SmileMan

    SmileMan New Member

    Naja, ich lass jetzt mal offen stehen, aus welchem Grund das kam. Wichtig ist mir, dass ich das Problem beseitigen konnte.
     

Diese Seite empfehlen