Jobwarteschlange wird nicht abgearbeitet ... ?

Dieses Thema im Forum "Allgemein" wurde erstellt von Bademeister, 14. Mai 2009.

  1. Bademeister

    Bademeister New Member

    Hallo zusammen,
    ersteinmal ein großes Lob an die Entwickler! Ich war lange auf der Suche nach einer alternative zu Confixx und habe ISPConfig 3.0.1.1 nun bei mir seit einige Zeit in Betrieb.

    Bisher gab es nie Probleme, allerdings seit heute werden angelegte eMails, einfach nicht mehr eingerichtet. Die Aufträge stehen zwar alle in der Jobwarteschlange, aber diese wird bei jeder Änderung immer größer :confused:

    Das Merkwürdige an der Geschichte ist ja, habe heute noch 2 Mails eingerichtet und weil gmx ein paar Probleme machte, den Hostnamen richtig eingestellt. Nun kommen die eMails bei gmx.de nun einwandfrei an, aber dieses Problem besteht noch immer.

    Ich bekomme auch folgende Fehlermeldung ausgegeben

    May 14 15:07:22 Excalibur postfix/pipe[19064]: 7AC9827D01B2: to=, relay=maildrop, delay=13005, delays=13004/0.65/0/0.05, dsn=4.3.0, status=deferred (temporary failure. Command output: maildirmake: /var/vmail/dsc-werbeagentur.de/info: Permission denied chmod: changing permissions of `/var/vmail/dsc-werbeagentur.de': Operation not permitted sh: /var/vmail/dsc-werbeagentur.de/info/ispconfig_mailsize: No such file or directory /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/dsc-werbeagentur.de/info/19091.0.Excalibur. )

    Das Cronprotokoll gibt folgendes aus
    maildirmake: /var/vmail/dsc-werbeagentur.de/info: Permission denied
    chown: cannot access `/var/vmail/dsc-werbeagentur.de/info': No such file or directory

    Im moment gibt es auch das Problem, dass die Meldung des öfteren kommt "Too many connections" (es laufen aber nur 5 kleine Seiten auf dem Server) und es werden bei ISPConfig keine Daten ausgegeben. Der Prozess maildirmake wird auch die ganze Zeit gestartet, kann ich irgendwie ispconfig neu starten ?

    Ich habe keine Rechte oder sontiges geändert, daher bin ich so verwundert. Könnte natürlich die Verz. von Hand anlegen, aber das wäre ja nicht gerade im Sinne des Erfinders ...
     
    Zuletzt bearbeitet: 14. Mai 2009
  2. Till

    Till Administrator

    Die Jobwarteschlange wird nicht weiter abgearbeitet wenn ein schwerer Fehler auftritt. Du musst den Fehler der ganz am Ende der Jobwarteschlange steht (also ganz unten auf der letzten Seite) beheben und danach den Fehler in der warteschlange löschen.

    ISPConfig muss bzw. kann nicht neu gestartet werden, da es garkein daemon ist, die Warteschlange wird per Cron aufgerufen. Die fehler im mail.log sind die Folgefehler die durch emails and nicht eingerichtete Konten entstehen.

    Zum Thema too many conections. Du musst die max connections und max user connections für mysql hochsetzen, jeweils z.b. auf 500.
     
  3. Bademeister

    Bademeister New Member

    Hallo Till,
    wo ich so über die ganze Sache nachdenke, fällt mir auch ein, dass ich gestern selbes Problem hatte und mehrmals einen User anlegen mußte, bis es überhaupt einmal geklappt hat. Hatte vorher nie irgendwelche Probleme gehabt ...

    Natürlich habe ich heute selbiges gemacht und so ist nun die Jobwarteschlange 3 Seiten lang ... :rolleyes:

    Die letzten Einträge sind also folgende:
    14.05.2009 11:31 Excalibur Insert mail_user

    14.05.2009 11:31 Excalibur Insert spamfilter_users

    14.05.2009 11:31 Excalibur Delete mail_user

    14.05.2009 11:31 Excalibur Delete spamfilter_users

    14.05.2009 11:30 Excalibur Insert mail_user

    14.05.2009 11:30 Excalibur Insert spamfilter_users

    14.05.2009 11:28 Excalibur Delete mail_user

    14.05.2009 11:28 Excalibur Delete spamfilter_users

    14.05.2009 11:11 Excalibur Update mail_user

    14.05.2009 11:10 Excalibur Insert mail_user
    Das könnte vielleicht ja auch mit den vielen Mysql Verbindungen zusammen hängen. Ich werde gleich mal die Verbindungen hochsetzen, aber kann ich nicht irgendwo die Jobwarteschlange löschen ? Weil er will ja einen User anlegen in der Tabelle mail_user ich hinder das Script ja nicht daran ;)
     
    Zuletzt bearbeitet: 14. Mai 2009
  4. Till

    Till Administrator

    Nein, da das system dann in einem inkonsistenten Zustand wäre.
     
  5. Bademeister

    Bademeister New Member

    Nabend,
    komme leider noch immer nicht weiter, denn in einem vorherigen Posting, hattest du geschrieben

    Der erste Fehler wäre dieser hier 14.05.2009 11:10 Excalibur Insert mail_user, allerdings existiert die Tabelle mail_user, somit frage ich mich, wie ich hier einen Fehler beheben kann ? Wie komme ich genau an diese Warteschlange ... ?
     
  6. Till

    Till Administrator

    Wie ist der Status des Eintrages? Wenn da nicht error als status steht dann ist es kein Fehler.
     
  7. Bademeister

    Bademeister New Member

    Ich bin nun einen großen Schritt weiter, denn der eMail Ordner unter /var/vmail/userdomain.de war als root angelegt. Wie der Ordner immer wieder zu dieser Berechigung kommt, bleibt ein Rätsel. Auch das löschen als root über Putty und wieder anlegen über ISPConfig geht zwar, dennoch erhält der Ordner immer wieder root Rechte ... :confused:

    Ich hatte aber zuvor 2 eMail Weiterleitungen eingerichtet, ob es damit etwas zu tun hat?

    Die eMail Warteschlange sieht im übrigen so aus: http://dscwebdesign.de/fehler.jpg , muss diese nicht leer sein ?

    Nachtrag: Habe die Mail Domain (/var/vmail/userdomain.de) nun mehrfach eingerichtet und wieder gelöscht, selten aber hin und wieder gehört der Ordner dann vmail.
     
    Zuletzt bearbeitet: 14. Mai 2009
  8. Bademeister

    Bademeister New Member

    Guten Morgen,
    also das Problem besteht auch beim angelegen von Domains. Ich kann irgendwie keine neuen Domains anlegen, nur diese dsc-werbeagentur.de, der rest will einfach nicht.


    Hier auch mal einen Screenshot, von den Berechtigungen http://dscwebdesign.de/berechtigung.jpg sehr merkwürdig finde ich, dass vorher alles vmail gehörte und nun die neuen nur noch root ...

    Gibt es nicht ein Zentrales Logfile von ISPConfig um den Fehler aufzuspüren, ich weiß einfach nicht wo ich suchen soll ....
     
    Zuletzt bearbeitet: 15. Mai 2009
  9. Till

    Till Administrator

    Du findest die Logging Infos all im monitoring Modul.
     
  10. Bademeister

    Bademeister New Member

    Hallo Till,
    danke für deine Antwort. Habe vor 2 Minuten nochmal eine Domain angelegt und leider passiert garnichts, nichtmal eine einzige Fehlermeldung im Logfile bzw. Monitor.

    Alle Dienste laufen auch einwandfrei und wie schon oben geschrieben, habe ich ISPConfig seit über 1 Monat mit 5 meiner eigenen Domains einwandfrei im Betrieb.

    Versteh ich es eigentlich richtig, dass die Jobwarteschlange nach und nach abgearbeitet wird?

    Was kann ich noch machen? Würde ja evtl. System neu aufsetzen, aber wenn ich ersteinmal alle Kunden auf den neuen Server habe und dieses Problem nocheinmal auftritt, gehen mir die Kunden an den Hals :eek:
     
  11. Bademeister

    Bademeister New Member

    Fehler gelöst! Die Jobwarteschlange wird also doch nach und nach abgearbeitet. Der Prozess maildirmake hat sich aufgehangen und würde über 3600 mal aufgerufen, bis sich der Server irgendwann aufgehangen hat.

    Habe den Prozess einfach manuell beendet und schon klappt wieder alles einwandfrei. :D
     

Diese Seite empfehlen