Jobwarteschlange wird nicht abgearbeitet....

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von stefanr, 30. Juli 2012.

  1. stefanr

    stefanr Member

    Hallo,

    bei mir wird leider die Jobwarteschlange leider nicht mehr richtig abgearbeitet.
    Als Info aus /var/log/ispconfig/ispconfig.log habe ich:


    30.07.2012-20:18 - DEBUG - Found 241 changes, starting update process.
    30.07.2012-20:18 - DEBUG - Calling function 'user_update' from plugin 'mail_plugin' raised by event 'mail_user_update'.

    Komisch finde ich im Moment bereits das die Uhrzeit im Logfile nicht stimmt. Ich habe es um 22:19 gestartet, date gibt auch die richtige Uhrzeit zurück.

    Nach dem letzten Eintrag passiert aber nichts mehr.

    Was kann ich tun?

    DANKE für Eure Hilfe.

    STEFAN
     
  2. Till

    Till Administrator

    Zur Uhrzeit, wahrscheinlich hast Du in den beide ispconfig config.inc.php dateien nicht die gleiche Zeitzone wie unter Linux eingestellt.

    Zum Fehler selbst: hast Du irgend was manuell in Bezug auf das /var/vmail Verzeichnis geändert, in ISPConfig oder auf der Shell / dateiebene? Und hast Du irgend was in der php.ini geändert die für cgi bzw. cli Scripte versendet wird, z.B. exec Funktionen deaktiviert?
     
  3. stefanr

    stefanr Member

    Guten Morgen Till,

    danke für die schnelle Antwort.

    Wo finde ich die beiden Dateien wegen der Uhrzeit? Würde ich gerne erst einmal genauer nachsehen.

    Ich hatte doch diesen Ausfall des Systems, hier habe ich über backuppc einige vmail Verzeichnise zurükgespielt. Eigentlich sollten dabei die Berechtigungen wieder gesetzt werden. Sollten wir aber irgendwie noch überprüfen. Was kann ich dir dazu an Infos geben?

    Gruß

    STEFAN
     
  4. Till

    Till Administrator

    /usr/local/ispconfig/server/lib/config.inc.php und /usr/local/ispconfig/interface/lib/config.inc.php

    Zu den dateiberechtigungen, alles in /var/vmail gehörtd em user vmail, Du kannst also gefahrlos folgendes machen:

    chown -R vmail:vmail /var/vmail

    kann einw enig dauern bis es durchgelaufen ist wenn Du große Maildirs hast.
     
  5. stefanr

    stefanr Member

    cat /usr/local/ispconfig/server/lib/config.inc.php |grep timezone

    //* Complete timezone list: PHP: List of Supported Timezones - Manual
    $conf['timezone'] = 'UTC';

    cat /usr/local/ispconfig/interface/lib/config.inc.php

    //* Complete timezone list: PHP: List of Supported Timezones - Manual
    $conf['timezone'] = 'UTC';

    Wie sehe ich was ich am Server habe?

    Den Benutzer habe ich neu gesetzt

    server:~# ps ax |grep maildirmake
    3436 ? S 0:00 su -c maildirmake -q 20971520S /var/vmail/domain.de/benutzer vmail
    3437 ? S 0:00 maildirmake -q 20971520S /var/vmail/domain.de/benutzer

    da scheint er immer wieder zu hängen, immer beim gleichen Benutzer.

    Gruß

    STEFAN
     
  6. Till

    Till Administrator

    Ok, dann ist wahrscheinlich irgend was im maildir defekt und Maildirmake hängt und ispconfig wartet darauf dass der maildirmake Befehl endet. Am einfachsten währe es wohl wenn Du mal das Maildir umbenennst:

    mv /var/vmail/domain.de/benutzer /var/vmail/domain.de/_benutzer

    damit es wieder läuft und dann ggf. nur den Inhalt der maildires ohne index und sonstige Config dateien die im maildir liegen zurück kopieren.
     
  7. stefanr

    stefanr Member

    Hallo Till,

    das habe ich bereits gemacht, habe es danach allerdings immer noch das Problem feststellen können. Ich denke ich beobachte das nun noch einmal ein bisschen.

    Gruß

    STEFAN
     
  8. gpi

    gpi New Member

    Jobwarteschlange wird nicht zu Ende abgearbeitet

    Hallo Till,

    habe ebenfalls das Problem, dass die Jobwarteschlage nicht abgearbeitet wird.

    Der Job scheint einfach weiterzulaufen.

    Folgendes gibt das Log aus:

    Für ein Info wäre ich dankbar.


    Gruß

    Günter
     
  9. gpi

    gpi New Member

    Jobwarteschlange wird nicht zu Ende abgearbeitet

    Noch folgendes:

    die Datei .ispconfig hat folgende Rechte:

    -rw-r--r-- 1 root ispconfig 0 19. Sep 19:30 .ispconfig_lock


    Gruß

    Günter
     
  10. Till

    Till Administrator

    Lösche bitte mal die lock Datei und rufe dann das server.sh script wie in der faq beschrieben manuell auf.
     
  11. gpi

    gpi New Member

    Das mache ich bereits bei jedem neuen Jobauftrag. Es wird beim manuellen Aufruf keine Fehlermeldung ausgegeben. Die Jobwarteschlage wird dann aus der Warteschlage abgearbeitet. Stellt man es wieder auf automatisch um, bleiben die Jobs in der Warteschlange hängen.

    Gruß

    Günter
     
  12. Till

    Till Administrator

    Dann läuft bei Dir wahrscheinlich der server.sh cronjob nicht, entweder er wurde aus der root crontab gelöscht oder aber der ganze cron daemon läuft nicht.
     

Diese Seite empfehlen