Jobwarteschlange wird nicht abgearbeitet....

#1
Hallo,

bei mir wird leider die Jobwarteschlange leider nicht mehr richtig abgearbeitet.
Als Info aus /var/log/ispconfig/ispconfig.log habe ich:


30.07.2012-20:18 - DEBUG - Found 241 changes, starting update process.
30.07.2012-20:18 - DEBUG - Calling function 'user_update' from plugin 'mail_plugin' raised by event 'mail_user_update'.

Komisch finde ich im Moment bereits das die Uhrzeit im Logfile nicht stimmt. Ich habe es um 22:19 gestartet, date gibt auch die richtige Uhrzeit zurück.

Nach dem letzten Eintrag passiert aber nichts mehr.

Was kann ich tun?

DANKE für Eure Hilfe.

STEFAN
 

Till

Administrator
#2
Zur Uhrzeit, wahrscheinlich hast Du in den beide ispconfig config.inc.php dateien nicht die gleiche Zeitzone wie unter Linux eingestellt.

Zum Fehler selbst: hast Du irgend was manuell in Bezug auf das /var/vmail Verzeichnis geändert, in ISPConfig oder auf der Shell / dateiebene? Und hast Du irgend was in der php.ini geändert die für cgi bzw. cli Scripte versendet wird, z.B. exec Funktionen deaktiviert?
 
#3
Guten Morgen Till,

danke für die schnelle Antwort.

Wo finde ich die beiden Dateien wegen der Uhrzeit? Würde ich gerne erst einmal genauer nachsehen.

Ich hatte doch diesen Ausfall des Systems, hier habe ich über backuppc einige vmail Verzeichnise zurükgespielt. Eigentlich sollten dabei die Berechtigungen wieder gesetzt werden. Sollten wir aber irgendwie noch überprüfen. Was kann ich dir dazu an Infos geben?

Gruß

STEFAN
 

Till

Administrator
#4
/usr/local/ispconfig/server/lib/config.inc.php und /usr/local/ispconfig/interface/lib/config.inc.php

Zu den dateiberechtigungen, alles in /var/vmail gehörtd em user vmail, Du kannst also gefahrlos folgendes machen:

chown -R vmail:vmail /var/vmail

kann einw enig dauern bis es durchgelaufen ist wenn Du große Maildirs hast.
 
#5
cat /usr/local/ispconfig/server/lib/config.inc.php |grep timezone

//* Complete timezone list: PHP: List of Supported Timezones - Manual
$conf['timezone'] = 'UTC';

cat /usr/local/ispconfig/interface/lib/config.inc.php

//* Complete timezone list: PHP: List of Supported Timezones - Manual
$conf['timezone'] = 'UTC';

Wie sehe ich was ich am Server habe?

Den Benutzer habe ich neu gesetzt

server:~# ps ax |grep maildirmake
3436 ? S 0:00 su -c maildirmake -q 20971520S /var/vmail/domain.de/benutzer vmail
3437 ? S 0:00 maildirmake -q 20971520S /var/vmail/domain.de/benutzer

da scheint er immer wieder zu hängen, immer beim gleichen Benutzer.

Gruß

STEFAN
 

Till

Administrator
#6
Den Benutzer habe ich neu gesetzt

server:~# ps ax |grep maildirmake
3436 ? S 0:00 su -c maildirmake -q 20971520S /var/vmail/domain.de/benutzer vmail
3437 ? S 0:00 maildirmake -q 20971520S /var/vmail/domain.de/benutzer

da scheint er immer wieder zu hängen, immer beim gleichen Benutzer.
Ok, dann ist wahrscheinlich irgend was im maildir defekt und Maildirmake hängt und ispconfig wartet darauf dass der maildirmake Befehl endet. Am einfachsten währe es wohl wenn Du mal das Maildir umbenennst:

mv /var/vmail/domain.de/benutzer /var/vmail/domain.de/_benutzer

damit es wieder läuft und dann ggf. nur den Inhalt der maildires ohne index und sonstige Config dateien die im maildir liegen zurück kopieren.
 
#7
Hallo Till,

das habe ich bereits gemacht, habe es danach allerdings immer noch das Problem feststellen können. Ich denke ich beobachte das nun noch einmal ein bisschen.

Gruß

STEFAN
 

gpi

New Member
#8
Jobwarteschlange wird nicht zu Ende abgearbeitet

Hallo Till,

habe ebenfalls das Problem, dass die Jobwarteschlage nicht abgearbeitet wird.

Der Job scheint einfach weiterzulaufen.

Folgendes gibt das Log aus:

[FONT=&quot]19.09.2012 16:12[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]There is already an instance of server.php running. [/FONT][FONT=&quot]Exiting.[/FONT]
[FONT=&quot]19.09.2012 16:11[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]There is already an instance of server.php running. [/FONT][FONT=&quot]Exiting.[/FONT]
[FONT=&quot]19.09.2012 16:10[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]There is already an instance of server.php running. [/FONT][FONT=&quot]Exiting.[/FONT]
[FONT=&quot]19.09.2012 16:09[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]There is already an instance of server.php running. [/FONT][FONT=&quot]Exiting.[/FONT]
[FONT=&quot]19.09.2012 16:08[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]There is already an instance of server.php running. [/FONT][FONT=&quot]Exiting.[/FONT]
[FONT=&quot]19.09.2012 16:07[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]There is already an instance of server.php running. [/FONT][FONT=&quot]Exiting.[/FONT]
[FONT=&quot]19.09.2012 16:06[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]There is already an instance of server.php running. [/FONT][FONT=&quot]Exiting.[/FONT]
[FONT=&quot]19.09.2012 16:05[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]No Updated records found, starting only the core.[/FONT]
[FONT=&quot]19.09.2012 16:05[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock[/FONT]
[FONT=&quot]19.09.2012 16:04[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock[/FONT]
[FONT=&quot]19.09.2012 16:04[/FONT]
[FONT=&quot]my.server.com[/FONT]
[FONT=&quot]Debug[/FONT]
[FONT=&quot]Calling function 'restartHttpd' from module 'web_module'.[/FONT]
Für ein Info wäre ich dankbar.


Gruß

Günter
 

gpi

New Member
#9
Jobwarteschlange wird nicht zu Ende abgearbeitet

Noch folgendes:

die Datei .ispconfig hat folgende Rechte:

-rw-r--r-- 1 root ispconfig 0 19. Sep 19:30 .ispconfig_lock


Gruß

Günter
 
#11
Das mache ich bereits bei jedem neuen Jobauftrag. Es wird beim manuellen Aufruf keine Fehlermeldung ausgegeben. Die Jobwarteschlage wird dann aus der Warteschlage abgearbeitet. Stellt man es wieder auf automatisch um, bleiben die Jobs in der Warteschlange hängen.

Gruß

Günter
 

Till

Administrator
#12
Dann läuft bei Dir wahrscheinlich der server.sh cronjob nicht, entweder er wurde aus der root crontab gelöscht oder aber der ganze cron daemon läuft nicht.
 

Werbung

Top