Joe öffnet Nano?

Dieses Thema im Forum "Server Administration" wurde erstellt von Stehlampe, 11. Nov. 2008.

  1. Stehlampe

    Stehlampe New Member

    Irgendwie stehe ich gerade aufm Schlauch. Der Rootserver, den wir übernommen haben wurde vom Provider geprestaged. Der Admin dort scheint ein Nano Fanboy zu sein und hat den Aufruf meines Lieblingseditors "Joe" mit seinem Nano verknüpft. Wenn man "Joe" startet, öffnet sich also immer Nano. Und das obwohl Joe in /usr/bin installiert ist.

    Wie bekomm ich das wieder weg? Irgendwie stehe ich da voll aufm Schlauch.
     
  2. Till

    Till Administrator

    Ruf mal auf:

    which joe

    dann erhältst Du einen Pfad. Dann ruf auf:

    ls -la /pfad/von/oben

    wobei Du natürlich den Pfad im Befehl ersetzen musst. Vermutlich gibt Dir ls an, dass der Pfad ein symlink auf nano ist, dann musst Du den symlink löschen und auf das richtige joe binary verweisen.
     
  3. Stehlampe

    Stehlampe New Member

    Hallo,

    auf den Trichter war ich auch schon gekommen. Nur leider wars das irgendwie nicht.

    So siehts bei mir aus:

    Code:
    ls -la | grep nano
    lrwxrwxrwx  1 root   root          9 Nov  4 13:51 nano -> /bin/nano
    lrwxrwxrwx  1 root   root          9 Nov  4 13:51 pico -> /bin/nano
    Code:
     ls -la | grep joe
    lrwxrwxrwx  1 root   root          3 Nov  3 23:02 jmacs -> joe
    -rwxr-xr-x  1 root   root     390484 Oct 19  2006 joe
    lrwxrwxrwx  1 root   root          3 Nov  3 23:02 jpico -> joe
    lrwxrwxrwx  1 root   root          3 Nov  3 23:02 jstar -> joe
    lrwxrwxrwx  1 root   root          3 Nov  3 23:02 rjoe -> joe
    Code:
    ls -la /usr/bin/joe
    -rwxr-xr-x 1 root root 390484 Oct 19  2006 /usr/bin/joe
     
  4. Till

    Till Administrator

    Poste bitte mal die Ausgabe von:

    which joe

    außerdem sieht man bei Deinen obigen Posts leider nicht, aus welchen Verzeichnissen Du das ls jeweisl ausgeführt hast.
     
  5. Stehlampe

    Stehlampe New Member

    Code:
    [root@test:/usr/bin]# which joe
    /usr/bin/joe
    Alle Befehle wurden von /usr/bin aus ausgeführt.
     
  6. Till

    Till Administrator

    Dann hat der Admin vermutlich das Binary umbenannt oder so. Ich würde mal joe neu installieren.
     

Diese Seite empfehlen