Joomla 1.5 und ISPConfig 3 auf Debian Lenny

#1
Hallo zusammen,

habe mir mal testweise einen Debian Lenny inkl. ISPConfig 3 laut Anleitung: HowtoForge Linux Tutorials » Der Perfekte Server - Debian Squeeze (Debian 6.0) mit BIND & Dovecot [ISPConfig 3]

zusammengestellt. Der Serverläuft stabil und das ISP Config ist auch recht übersichtlich, jedoch habe ich so einige Problem bei der Installation von Joomla. Die Dateien kann ich zunächst problemlos mit FileZilla auf den Server laden. Installation läuft auch problemlos durch. Installiere ich jedoch jetzt in Joomla ein Template oder ein Modul oder was auch immer, hat die Besitzrechte für die Dateien nur noch der wwwrun. Egal was ich nun im ISPConfig Admin Menü einstelle (CGI, fastCGI, SUPHP etc.) es funktioniert nicht, dass ich die Dateien nach der Installation bearbeiten, geschweige denn löschen kann. Wo ist mein Denkfehler, was muss ich noch umstellen?:confused:

Vielen Dank bereits jetzt für eure Hilfe!

Beste Grüße

Lui
 

Till

Administrator
#2
Du hast vergessen suexec zu aktivieren. Für CMS Systeme wie Joomla, Typo3 und Wordpress solltest Du die folgende Konfiguration nehmen:

Suexec: an
PHP Modus: php-fcgi

Jetzt musst Du nur noch Deine aktuelle Installation reparieren, idem Du den benutzer und die Gruppe aller datein im Web Verzeichnis auf den eb user und die client gruppe dieses Webs änderst.
 
#3
Hi Till,

vielen Dank für die Antwort, Suexec und php-fcgi sind bereits eingeschalten und die benutzergruppen lassen sich nicht editieren. was könnte ich noch vergessen haben?

root@+++:~# a2enmod fcgid
Module fcgid already enabled
root@+++:~# a2enmod suexec
Module suexec already enabled

Dies gebe ich zur änderung des Verzeichnisses ein, aber ich glaube ich hab da was verplant...

chmod -R web1:client1 /var/www/clients/client1/web1

Grüße

Lui
 
#4
Hi Till,

vielen Dank für die Antwort, Suexec und php-fcgi sind bereits eingeschalten und die benutzergruppen lassen sich nicht editieren. was könnte ich noch vergessen haben?

root@+++:~# a2enmod fcgid
Module fcgid already enabled
root@+++:~# a2enmod suexec
Module suexec already enabled

Dies gebe ich zur änderung des Verzeichnisses ein, aber ich glaube ich hab da was verplant...

chmod -R web1:client1 /var/www/clients/client1/web1

Grüße

Lui
Ich denke er meint du sollst für die Homepage suexec und php-fcgi im Webinterface aktivieren..

chown -R web1:client1 /var/www/clients/client1/web1 sollte dein Problem lösen.


Grüße
 
#5
:D Jaja, man sollte immer zweimal schauen bevor man etwas schreibet, vielen herzlichen dank!!! Es hat alles prima geklappt!!! Perfekt, super geiles Forum nur zu empfehlen!!!!

Beste GRüße

Lui
 

Werbung

Top