Joomla - Problem mit mod_rewrite - Scheint nicht zu funktionieren

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von EPMS, 8. Sep. 2011.

  1. EPMS

    EPMS Member

    Hallo Zusammen,
    ich habe einen OpenSuse 11.4 Server auf dem ich ISPConfig 3.0.3.3 installiert habe. Das hat auch alles wunderbar geklappt und läuft soweit auch alles.

    Jetzt hab eich ein Problem mit einer Joomla Seite. Ich habe die DB vom alten Server in den neuen importiert. Die Joomla Dateien habe ich in das Verzeichnis kopiert.

    Wenn ich die Domain aufrufe kommt auch die Startseite. Wenn ich aber einen der Links anklicke bekomme ich nur einen 404 Fehler.
    Ich gehe stark davon aus, dass es an mod_rewrite liegt.

    Jetzt habe ich schon bei Google geschaut. Bin aber noch nicht weiter gekommen.

    Wer könnte mir weiterhelfen? Wie kann ich rausfinden ob es an mod_rewrite liegt? Welche Logs könnte ich dafür posten?

    Für Hilfe, danke im voraus.
     
  2. Till

    Till Administrator

    Nach welchem Tutorial hast Du den Server installiert?
     
  3. EPMS

    EPMS Member

  4. Till

    Till Administrator

    Ok, dann ist mode rewrite installiert und auch aktiviert.

    Schau mal nach ob im web Verzeichnis auch wirklich die richtige und vollständige .htaccess datei von Joomla liegt. Da es sich um eine evrsteckte Datei handelt, kann es leicht passieren dass sie beim umzug nicht mit kopiert wird.
     
  5. EPMS

    EPMS Member

    Habe eben festgestellt das die .htaccess noch nicht umbenannt war. Habe ich jetzt gemacht. Dann bekomme ich folgenden Fehler

    a 500 Internal Server Error error was encountered

    Ich habe mal versucht auf einer anderen Domain Joomla neu zu installieren. Da sagt mir Firefox beim ersten aufrufen der Domain (ohne das ich überhaupt installiert habe)

    Fehler: Umleitungsfehler
    Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.
    Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden.
     
  6. stefanw

    stefanw New Member

    1. was sagt das error.log
    2. was hat das mit ISPConfig zu tun?
     

Diese Seite empfehlen