Kein E-Mail versand + Empfang !

#1
Moin,

erstmal muss ich sagen das sich ISPConfig gemacht hat bin echt sprachlos.
Nur ich habe dein Problem mit dem E-Mail Versand. Die ich empfange landen im Mailq und ein versenden nach draußen ist auch nicht möglich.

Hier mal paar Daten:

1. System

Debian Lenny
(Grundaustattung wie im Howto beschrieben)
Ist den Dezi also kein Vserver

2. Mail Logs und die Mailq

Mailq:

Code:
Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
783A01941F2     1855 Fri Oct 22 20:53:27 XXXXXXX@t-online.de
                   (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
                                         XXXX@XXXX.de

443591941F4      764 Fri Oct 22 20:58:32 XXXX@XXXXXX
                   (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
                                         XXXX@t-online.de

BB4EE1941F3     1841 Fri Oct 22 20:57:05 xxxxxxxx@t-online.de
                   (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
                                         XXXXXXXXX@XXXXXXXX

E87511941ED      522 Fri Oct 22 20:50:45  www-data@xxxxxxxxxxxxx
                   (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
                                         xxxxxx@xxxxxxx

-- 7 Kbytes in 4 Requests.
Mail Protokoll vom ISPConfig:

Code:
dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
mail.warn und mail.err sind leer.

So wie es aussieht kann er keine Verbindung mit der Mysql aufbauen oder sehe ich das falsch ? Mysql läuft das mein Blog erreichbar ist.

Hat jemand genauere Lösungsvorschläge bzw. Tipps ?

Lg
Dennis
 
#4
Moin,

habe nu folgendes Problem und beschmutze mal mein alten Treahd .

Gestern wurden meine NS-Server umgestellt. Seit dem kann ich zwar Mails verschicken aber keine Empfangen. Wenn ich mir eine E-Mail von T-Online schicken lasse bekomme ich diese Meldung zurück:

This is the mail system at host mail.sackratten.info.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<info@mein-bilder-blog.de>: unknown user: "info"

Okay, der sagt mir das der User "info" unbekannt ist.

Die Mail.warn gibt folgendes raus:

Oct 24 10:50:34 puppa postfix/trivial-rewrite[21267]: warning: do not list domain sackratten.info in BOTH mydestination and virtual_mailbox_domains
Oct 24 10:51:20 puppa postfix/trivial-rewrite[21291]: warning: do not list domain sackratten.info in BOTH mydestination and virtual_mailbox_domains
Oct 24 10:53:40 puppa postfix/trivial-rewrite[21331]: warning: do not list domain sackratten.info in BOTH mydestination and virtual_mailbox_domains
Oct 24 10:53:41 puppa postfix/trivial-rewrite[21331]: warning: do not list domain sackratten.info in BOTH mydestination and virtual_mailbox_domains
Oct 24 10:55:31 puppa postfix/trivial-rewrite[21560]: warning: do not list domain sackratten.info in BOTH mydestination and virtual_mailbox_domains
Oct 24 10:55:31 puppa postfix/trivial-rewrite[21560]: warning: do not list domain sackratten.info in BOTH mydestination and virtual_mailbox_domains
Oct 24 11:02:03 puppa postfix/trivial-rewrite[21962]: warning: do not list domain mein-bilder-blog.de in BOTH mydestination and virtual_mailbox_domains
Oct 24 11:02:03 puppa postfix/trivial-rewrite[21962]: warning: do not list domain mein-bilder-blog.de in BOTH mydestination and virtual_mailbox_domains
Oct 24 11:02:03 puppa postfix/trivial-rewrite[21962]: warning: do not list domain mein-bilder-blog.de in BOTH mydestination and virtual_mailbox_domains
Habe in der Datenbank geschaut und da sind die Domaine sowie die Benutzer eingetragen. Nu weiss ich nicht weiter wo ich noch schauen sollte oder was zu tun ist ?!

Lg
dennis


Ps: Die Domains sind meine habe nur den hostname abgeändert !!
 
#5
Du hast die Domain sackratten.info einmal in der /etc/postfix/main.cf stehen
in dieser Zeile, die dürfte bei dir folgendermaßen aussehen
Code:
mydestination = sackratten.info, mein-bilder-blog.de, localhost, localhost.localdomain
und du hast sie in der Datenbank für die virtual_mailbox_domains stehen.

Lösche sie in der main.cf raus.

Okay, der sagt mir das der User "info" unbekannt ist.
Das sagt er weils eben doppelt vorhanden ist, der Eintrag der Domain, und er sucht erstmal den User info local auf deinem System...
dort ist er natürlich nicht weil er ja in der Datenbank steht für die virtual user.
Sollte nach obiger Änderung passen.

Gruß Sven
 
Zuletzt bearbeitet:
#6
Danke schonmal weiter :)

nu macht aber clamav Ärger:

[.....]Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169) 451-4.5.0 LibClamAV Error: Problem parsing database at line 737 451-4.5.0 LibClamAV Error: Can't load /var/lib/amavis/tmp/clamav-79aeb3a033f9d4cc4fdb6add2a579de4/daily.ndb: Malformed database 451-4.5.0 LibClamAV Error: Can't load /var/lib/clamav//daily.cvd: Malformed database 451 4.5.0 ERROR: Malformed database" at (eval 88) line 527. (in reply to end of DATA command
Mails landen nu im Mailq weil clamav wohl nicht mehr will ?!
Bei einem neustart bekomme ich die gleiche Fehlermeldung
 
#8
Gesagt getan aber keine Änderung !!

Es wird mir gesagt das ich die aktuellste Version bereits installiert habe
 
Zuletzt bearbeitet:

Till

Administrator
#9
Installier es bitte nochmal wie auf faqforge bschrieben und starte dann den clamav und amavisd neu. Es ist sehr wichtig dass Du vorher das volatile repository einbindest wie dort beschrieben und dann mit apt-get update die quellen aktualisierst.
 

Werbung

Top