Kein Email-Login mehr nach Upgrade auf Squeeze

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von GrafPorno, 16. Aug. 2011.

  1. GrafPorno

    GrafPorno Member

    Ich habe eben ein Update von Lenny auf Squeeze gemacht und das hat soweit auch geklappt, allerdings kann ich mich nicht mehr in mein Postfach einloggen.
    Mailprogramm sagt, Verbidung unterbrochen oder so. Im mail.log sehe ich die Verbindung ankommen, dann passiert aber nichts mehr.
    Code:
    imapd: Connection, ip=[::ffff:80.187.103.148]
    Dann habe ich eine Verbindung per Konsole auf den Pop3d probiert:
    Code:
    co@bandit:~$ telnet localhost 110
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    +OK Hello there.
    user x@xyz.de
    +OK Password required.
    pass 1234
    -ERR POP3 access disabled for this account.
    Connection closed by foreign host.
    Also habe ich das Loglevel vom authd auf 1 geändert und den Versuch wiederholt.
    Code:
    Aug 16 22:55:18 bandit pop3d: Connection, ip=[::1]
    Aug 16 22:55:29 bandit authdaemond: received auth request, service=pop3, authtype=login
    Aug 16 22:55:29 bandit authdaemond: authmysql: trying this module
    Aug 16 22:55:29 bandit authdaemond: SQL query: SELECT email, password, "", uid, gid, homedir, maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE email = 'x@xyz.de'
    Aug 16 22:55:29 bandit authdaemond: password matches successfully
    Aug 16 22:55:29 bandit authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=x@xyz.de, fullname=<null>, maildir=/var/vmail/xyz.de/c, quota=2147483647, options=disableimap=,disablepop3=
    Aug 16 22:55:29 bandit authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=x@xyz.de, fullname=<null>, maildir=/var/vmail/xyz.de/c, quota=2147483647, options=disableimap=,disablepop3=
    Auch da kann ich nicht wirklich einen Fehler sehen - und so langsam bin ich mit meinem Latein am Ende - kann mir jemand ein paar Tips geben?
     
  2. Till

    Till Administrator

    Vermutlich hat das Debian update Konfigurationsdateien überschrieben. Führe bitte das ispconfig update nochmal aus und wähle dabei aus dass die Dienste neu konfiguriert werden sollen.
     
  3. GrafPorno

    GrafPorno Member

    Hallo Till,

    ich habe das Problem mittlerweile gelößt. Und zwar waren in der Tabelle mail_user keine Werte für disableimap und disablepop eingetragen. Das habe ich jetzt gefixt und kann auch wieder auf die Postfächer zugreifem.

    Allerdings meckert er jetzt beim Zugriff aufs Postfach:
    Code:
    Filesystem notification initialization error -- ... (check for configuration errors with the FAM/Gamin library)
    Ein ispconfig_update habe ich schon probiert, allerdings sagt er mir:
    Code:
    There are no updates available for ISPConfig 3.0.3.3
    Kann ich das irgendwie forcieren?
     
  4. Till

    Till Administrator

    Es geht ja jetzt, dann ist das nicht mehr notwendig.

    Zum anderen fehler, schau mal nach ob Du fam überhaupt installiert hast.
     
  5. GrafPorno

    GrafPorno Member

    fam war nicht installiert...
    *steckt die Hände in die Tasche und geht pfeifend weg ...*
     

Diese Seite empfehlen