Kein emailempfang, versand ?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mrairbrush, 9. Apr. 2015.

  1. mrairbrush

    mrairbrush Member

    In ispconfig emailkonten angelegt. Können auch von extern abgerufen werden aber es kommen keine mails rein und werden auch keine versendet. Erhalte von externen emailclienten auch keine Fehlermeldung. Verschwinden im Nirwana. Die Maillog von isp hat solche Einträge.
    Apr 9 14:24:36 Debian-78-wheezy-64-minimal postfix/error[20730]: 33012621839: to=<test@test.com>, relay=none, delay=38168, delays=38168/0.05/0/0.13, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
     
  2. robotto7831a

    robotto7831a Member

    Anscheinend läuft der Amavis Daemon nicht.
     
  3. mrairbrush

    mrairbrush Member

    bei apache restart bekomme ich

    /etc/init.d/apache2 restart
    [....] Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 000.000.000 for ServerName
    [Thu Apr 09 15:10:08 2015] [warn] NameVirtualHost *:443 has no VirtualHosts
    ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 213.239.000.000 for ServerName
    [Thu Apr 09 15:10:09 2015] [warn] NameVirtualHost *:443 has no VirtualHosts

    ------------------------------------------------------------------------------------------
    Anstatt 000.000.000 steht natürlich die richtige IP des servers.
    Vielleicht hängt es damit zusammen.
     
  4. robotto7831a

    robotto7831a Member

    Hast Du meine Antwort gelesen?
     
  5. mrairbrush

    mrairbrush Member

    ja habe ich gelesen Habe ihn versucht zu starten.


    /etc/init.d/amavis start
    Starting amavisd: The value of variable $myhostname is "Debian-78-wheezy-64-minimal", but should have been
    a fully qualified domain name; perhaps uname(3) did not provide such.
    You must explicitly assign a FQDN of this host to variable $myhostname
    in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
    network name!
    (failed).

    Habe für die mailboxen in ispconfig keine spamfilter aktiviert. Funktioniert das dann trotzdem nicht?
     
  6. robotto7831a

    robotto7831a Member

    Nach welchem Tutorial hast Du installiert?
     
  7. mrairbrush

    mrairbrush Member

    Habe dazu folgendes gefunden
    I then edited /etc/amavisd.conf and located this setting:
    #$myhostname = ''; # must be a fully-qualified domain name!
    and changed it to:
    $myhostname = 'mail.mydomain.com'; # must be a fully-qualified domain name!

    Dummerweise gibt es /etc/amavisd.conf nicht.
     
  8. robotto7831a

    robotto7831a Member

    Hör auf rumzudoktoren. Du hast garantiert den Hostnamen nicht gesetzt.
     
  9. mrairbrush

    mrairbrush Member

  10. Till

    Till Administrator

    Wie robotto angemerkt hat: Du hast den Hostnamen nicht gesetzt, nicht mehr und auch nicht weniger. Und dass Du nicht der erste bist der vergessen hat den Hostnamen zu setzen ist ja wohl nicht verwunderlich, das gibt es sicherlich seit der Steinzeit, also der Erfindung des Hostnamens ;) Und an der amavisd.conf brauchst Du da nichts zu ändern, mach es rückgängig und setze stattdessen den Hostnamen richtig, denn snst wird das sowieso nix mit dem Mail senden und empfangen.
     
  11. mrairbrush

    mrairbrush Member

    hostname ergibt
    Debian-78-wheezy-64-minimal

    Seit wann muss man das hinterher ändern? Ist es egal welche domain ich dafür eintrage
     
  12. robotto7831a

    robotto7831a Member

    Dein Problem hast Du selber verursacht.
     
  13. Till

    Till Administrator

    Das ändert man vorher und nicht hinterher, steht in jedem Perfect Server Tutorial drin.

    Es muss eine existierende SUB Domain sein, also sowas wie server1.example.com und eben nicht example.com und sie sollte mit dem Reverse Record (PTR) Deiner IP übereinstimmen.
     
  14. mrairbrush

    mrairbrush Member

  15. robotto7831a

    robotto7831a Member

    Nein natürlich nicht.

    Nach welcher Anleitung hast Du Postfix, Pure-FTP usw. usw. installiert?
     
  16. mrairbrush

    mrairbrush Member

    Hat das script von ispconfig gemacht.
     
  17. Till

    Till Administrator

    Er hat keine Anleitung benutzt sondern nur ein Script dass er auf github gefunden und welches nichts mit ISPConfig zu tun hat und ohne genau zu wissen was es macht anstatt einfach alles sauber nach Anleitung zu installieren.

    Ändere den Hostnamen in /etc/hosts, /etc/hostname, /etc/mailname, /etc/postfix/main.cf und starte den Server neu.

    Fazit: Du hast jede menge Zeit mit dem Script + Fehlersuche verschwendet anstatt sie gegenüber den offiziellen Installationsanleitungen einzusparen.
     
  18. mrairbrush

    mrairbrush Member

    sorry dachte es ist von ispconfig. Habe den Link aus dem forum.
    bei postfix/main.cf ist es korrekt eingetragen.
     
    Zuletzt bearbeitet: 9. Apr. 2015
  19. mrairbrush

    mrairbrush Member

    yeah er läuft.....
    Danke Till
     
  20. mrairbrush

    mrairbrush Member

    zu früh gefreut. zu googelamail kann ich senden aber bei den eingetragenen emailkonten kommt nix an.
    Bei einem Konto kommen die mails an. Bei anderen nicht??? Ist mit schleierhaft.
    Mailboxquota zeigt teilweise 180k an aber mailboxen sind leer.
     
    Zuletzt bearbeitet: 9. Apr. 2015

Diese Seite empfehlen