Kein https möglich.

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Paul, 29. Dez. 2009.

  1. Paul

    Paul Member

    Hallo.
    Ich stochere leider etwas im Nebel und hoffe bei Euch einen Tipp zu bekommen. Der Webserver (openSuse, ISPConfig3) antwortet nicht auf https-Anfragen. Firefox-Meldung: Fehler. Verbindung fehlgeschlagen. Firefox kann keine Verbindung ...
    Auf dem alten Server unter openSuse und ISPConfig2 hat alles anstandslos funktioniert. Der Blick auf die Konfigurationsdateien hat leider nichts ergeben.
    etc/apache2/httpd.conf
    etc/apache2/listen.conf
    etc/apache2/sites-available/*

    Habt Ihr eine Idee mehr, wo ich noch nachschauen kann?
    Ach ja, das Häkchen für SSL ist in ISPConfig natürlich angeklickt, und die Files mit dem Zertifikat und dem persönlichen Key sind im SSL-Ordner des virtuellen Hosts.

    Schönen Dank schon im Voraus.
     
  2. Till

    Till Administrator

    Überprüfe mal mit:

    netstat -tap

    ob der apache auf Deinem Server überhaupt auf dem https port lauscht.
     
  3. Paul

    Paul Member

    Schönen Dank für die superschnelle Antwort.
    Der Server lauscht auf imap, ssh, http, aber nicht auf https.
     
  4. Till

    Till Administrator

    Ruf mal den folgenden Befehl aus dem Howto auf:

    a2enmod ssl

    und starte apache neu.
     
  5. Paul

    Paul Member

    Jetzt geht's. Der Server reagiert auf https-Anfragen. Folgefehler: (Fehlercode: ssl_error_rx_record_too_long)
    Mal schauen, woran das noch liegt.
    Besten Dank!
     
  6. Till

    Till Administrator

    Entweder das SSL Cert ist defekt, weil z.B. eine Eingabe in den Feldern nicht verarbeitet werden konnte oder aber Du hast * statt einer IP für das Web ausgewählt. SSL Webs kann der apache nur mit IP und nicht * verarbeiten.
     
  7. Paul

    Paul Member

    Ich hoffe, dass Thawte mir kein defektes Zertifikat geschickt hat. Eine IP habe ich für das Web ausgewählt. Was aber beim Nachforschen noch aufgefallen ist:
    In etc/apache2/sites-available/domainname.de.vhost ist nur der Port 80 konfiguriert. Muss da nicht auch etwas über den Port 443 stehen?
    Und muss das dann für den entsprechenden Vhost evtl. auch in dem Ordner sites-enabled geschehen?
     

Diese Seite empfehlen