Kein Login nach installation möglich

#1
Hi Leuts,

ich habe die Schnautze voll von ISP-Control Omega da mir de Update Prozesse nur Probleme bereitet.
Jetzt bin ich auf ISPConfig 3 gestoßen und habe letzte Nacht das ganze auf eine VMWare Maschine mit Debian Lenny installiert um zu sehen ob es was taugt.
Ich habe mich bei der Installation an diese Anleitung gehalten:
http://www.howtoforge.com/perfect-server-debian-lenny-debian-5.0-with-bind-and-dovecot-ispconfig-3

Lief auch wärend der Installation alles klat durch und ich hatte keinen nennenswerten probs.

Jetzt kann ich mich nach der Installation nicht in den Admin-Bereich einlogen und kann keinen offensichtlichen Fehler dafür finden. Ich hab' in der "ispconfig.vhost" die SSL-Engine mal ausgeschaltet was leider nur deutlich machte das es ein anderes Problem gibt.

In dem Apache /var/log/apache2/error.log steht auch nüscht.

Ich bin nicht unbedingt der Linux Crack aber ich beschäftige mich schon einige Zeit damit und manage einen VPS für meine online Projekte.

Vielleicht habe ich Glück es kann jemand von änlichem berichten. Die SuFu habe ich genutzt nur nicht wirklich pasendes gefunden.

Gruß Marcus
 
#3
Hallo,

danke für deine mühe im voraus.

netstat -tap
Code:
Aktive Internetverbindungen (Server und stehende Verbindungen)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:imaps                 *:*                     LISTEN      13304/dovecot
tcp        0      0 *:pop3s                 *:*                     LISTEN      13304/dovecot
tcp        0      0 localhost:10024         *:*                     LISTEN      12567/amavisd (mast
tcp        0      0 localhost:10025         *:*                     LISTEN      12497/master
tcp        0      0 *:mysql                 *:*                     LISTEN      12335/mysqld
tcp        0      0 *:pop3                  *:*                     LISTEN      13304/dovecot
tcp        0      0 *:imap2                 *:*                     LISTEN      13304/dovecot
tcp        0      0 *:ssh                   *:*                     LISTEN      2258/sshd
tcp        0      0 *:smtp                  *:*                     LISTEN      12497/master
tcp        0    212 ispconfig.loc:ssh       ws-mr-lokal-001.f:57942 VERBUNDEN   2315/0
tcp6       0      0 [::]:http-alt           [::]:*                  LISTEN      14504/apache2
tcp6       0      0 [::]:www                [::]:*                  LISTEN      14504/apache2
tcp6       0      0 [::]:tproxy             [::]:*                  LISTEN      14504/apache2
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2258/sshd
tcp6       0      0 [::]:https              [::]:*                  LISTEN      14504/apache2
iptables -L
Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
fail2ban-ssh  tcp  --  anywhere             anywhere            multiport dports ssh

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain fail2ban-ssh (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere
Leider reicht mein know how nicht für iptables aus um was deuten zu können.
 

Till

Administrator
#4
Apache läuft inkl. ispconfig und es ist keine firewall die es blockiert.

Gib bitte mal folgendes im browser ein:

http://1.2.3.4:8080/

wobei Di 1.2.3.4 durch die IP Deines Servers ersetzen musst. im ispconfig vhost kann kein ssl aktiv gewesen sein wie Du oben beschrieben hast, da der ispconfig installer das in keiner der releasten Versionen unterstützt. Wenn bei Dir ssl aktiv war, dann stellt sich die frage welche Version Du installie hast und wo Du sie her hast.
 
#5
Apache läuft inkl. ispconfig und es ist keine firewall die es blockiert.

Gib bitte mal folgendes im browser ein:

http://1.2.3.4:8080/

wobei Di 1.2.3.4 durch die IP Deines Servers ersetzen musst. im ispconfig vhost kann kein ssl aktiv gewesen sein wie Du oben beschrieben hast, da der ispconfig installer das in keiner der releasten Versionen unterstützt. Wenn bei Dir ssl aktiv war, dann stellt sich die frage welche Version Du installie hast und wo Du sie her hast.
Ich wußte ich habe wieder was vergessen zu beschreiben.

Ich kan den Login Bildschirm sehen:

http://web-spirits.dyndns.org:8080/ hab ich mal kurz aufgemacht.

Nur wenn ich User: admin Pass: admin eingebe sagts mir das des falsch war.

Und zum SSL. Ja doch SSL war an. Das hat mir die Installation am ende angeboten und ich konnte mit aktiviertem SSL auch nur über https:// auf den Login Schirm zugreifen. Und dann hab ich es deaktiviert und ich konnte mit http:// zugreifen.
Code:
######################################################
# This virtual host contains the configuration
# for the ISPConfig controlpanel
######################################################

 Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
  ServerAdmin webmaster@localhost

  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
          php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>

  # ErrorLog /var/log/apache2/error.log
  # CustomLog /var/log/apache2/access.log combined
  ServerSignature Off

  <IfModule mod_security2.c>
    SecRuleEngine Off
  </IfModule>

  # SSL Configuration
  SSLEngine Off
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>
Sorry das ich mich nicht klar ausgedrückt hab. Hoffe du hast noch lust mir zu helfen?
 
Zuletzt bearbeitet:

Till

Administrator
#6
Schau mal bitte mit phpmyadmin nach, ob die ispconfig Datenbank angelegt worden ist und ob da Tabellen drin sind. Und außerdem müsste ich wissen welche Version Du installiert hast und wo Du sie her hast, also welches wo Du das tar.gz heruntergeladen hast.
 

Till

Administrator
#7
Und noch was, bei der Installation von ispconfig hast Du Dich an die Defaults gehalten? Also bei allen Fragen nur return drücken außer bei der Frage nach dem root Passwort, da natürlich das Passwort eingeben.

Wenn Du nämlich z.B. einen anderen mysql User als root nimmst (der Installer schlägt Dir root vor), wird die Installation ein nicht funktionierendes System ergeben.
 
#8
Schau mal bitte mit phpmyadmin nach, ob die ispconfig Datenbank angelegt worden ist und ob da Tabellen drin sind.
Check! (Ist so!)
Und außerdem müsste ich wissen welche Version Du installiert hast und wo Du sie her hast, also welches wo Du das tar.gz heruntergeladen hast.
Check!
Ich hab' Sie nach der Anleitung mit folgenden erhalten:
Code:
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
Dezufolge habe ich Version 3. Welche update Version das ist weis ich nicht aber ich glaube mal 3.0.3 gelesen zu haben finde es aber nicht mehr.
Und noch was, bei der Installation von ispconfig hast Du Dich an die Defaults gehalten? Also bei allen Fragen nur return drücken außer bei der Frage nach dem root Passwort, da natürlich das Passwort eingeben.

Wenn Du nämlich z.B. einen anderen mysql User als root nimmst (der Installer schlägt Dir root vor), wird die Installation ein nicht funktionierendes System ergeben.
Also da muss ich noch mal fragen. Alles mit Return bestätigen auser DB root Passwort?
 

Till

Administrator
#9
Die Version ist ok, das ist die aktuelle Stable (3.0.3).

Alles mit Return bestätigen auser DB root Passwort?
Ja. Ich vermute mal dass dem nicht so ist, denn sonst wärst Du nicht nach ssl gefragt worden. Der Standardinstallationsmodus fragt das nämlich nicht ab.

Folgende Dinge sind wichtig:

1) Datenbank host muss localhost sein.
2) Datenbankuser muss root sein, sonst kann ispconfig nicht seine User und DB anlegen. Daraus folgt auch, dass es keine Datenbank mit dem Namen der ISPConfig Datenbank vorher geben darf.

Da Du schreibst dass Du nochmal fragen musst, machst Du die installation wohl nicht alleine? Und Du bist sicher dass niemand das ispconfig default admin Passwort schon geändert hat?
 
#10
Also ich mach das alles selbst. Ich bin nur hellhörig geworden und wollte dich noch mal fragen.

Ich setze nochmal die VM zurück und fang von vorne an. Darf ich mich dann noch mal melden ;-)
 

Till

Administrator
#11
Du brauchst nicht nochmal von vorne anfangen. Mach einfach folgendes:

ispconfig tar.gz nochmal entpacken, dann gehst Du ins install Verteichnis und rufst auf:

php uninstall.php

und danach installierst Du neu mit:

php install.php
 
#12
Ok, ich habs geschaft. Ich hatte irgendwo gelesen folgendes in die MySQL konfiguration zu schreiben:
Code:
init_connect = ‘SET collation_connection = utf8_general_ci’
init_connect = ‘SET NAMES utf8′
Läuft aber nicht. Habe dan den Fehler im daemon.log gefunden.
Drotzdem danke ich Till ganz herzlich für seine Mühe.
 

Werbung