kein Login vom Android-Handy auf Courier-Imap möglich

#1
Hallo,

ich stehe vor einem für mich derzeit unlösbarem Problem.

Wenn ich mich von meinem Handy auf mein Postfach einlogen will erhalte ich immer die Meldung "Falscher Benutzername oder Passwort".
Mit den selben Einstellung (Name,Pawsswort,TSL,Port, usw) geht es aber.

Hier mal die Logeinträge:

vom Handy:
Code:
Dec 16 11:11:00 srv01 authdaemond: received auth request, service=imap, authtype=login
Dec 16 11:11:00 srv01 authdaemond: authmysql: trying this module
Dec 16 11:11:00 srv01 authdaemond: authmysqllib: connected. Versions: header 50149, client 50166, server 50166
Dec 16 11:11:00 srv01 authdaemond: SQL query: SELECT login, password, "", uid, gid, homedir, maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE login = 'name@domain.de'
Dec 16 11:11:00 srv01 authdaemond: supplied password 'XXXXXXXXXX' does not match encrypted password 'XXXXXXXXXXXXXXXX'
Dec 16 11:11:00 srv01 authdaemond: authmysql: REJECT - try next module
Dec 16 11:11:00 srv01 authdaemond: FAIL, all modules rejected
Dec 16 11:11:00 srv01 imapd: LOGIN FAILED, user=name@domain.de, ip=[::ffff:80.187.xxx.xxx]
"supplied password" und "encrypted password" habe ich überprüft. Sie sind zu 100% OK.

Login aus Thunderbird:
Code:
Dec 16 11:19:13 srv01 authdaemond: received auth request, service=imap, authtype=login
Dec 16 11:19:13 srv01 authdaemond: authmysql: trying this module
Dec 16 11:19:13 srv01 authdaemond: authmysqllib: connected. Versions: header 50149, client 50166, server 50166
Dec 16 11:19:13 srv01 authdaemond: SQL query: SELECT login, password, "", uid, gid, homedir, maildir, quota, "", concat('disableimap=',disableimap,',disablepop3=',disablepop3) FROM mail_user WHERE login = 'name@domain.de'
Dec 16 11:19:13 srv01 authdaemond: password matches successfully
Dec 16 11:19:13 srv01 authdaemond: authmysql: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=name@domain.de, fullname=<null>, maildir=/var/vmail/domain.de/name, quota=1073741824, options=disableimap=n,disablepop3=y
Dec 16 11:19:13 srv01 authdaemond: authmysql: clearpasswd=<null>, passwd=xxxxxxxxxxx
Dec 16 11:19:13 srv01 authdaemond: Authenticated: sysusername=<null>, sysuserid=5000, sysgroupid=5000, homedir=/var/vmail, address=name@domain.de, fullname=<null>, maildir=/var/vmail/domain.de/name, quota=1073741824, options=disableimap=n,disablepop3=y
Dec 16 11:19:13 srv01 authdaemond: Authenticated: clearpasswd=xxxxxxxx, passwd=xxxxxxxxxxxxxx
In beiden Einträgen ist "encrypted password" sind identisch zum Eintrag in der DB.
"supplied password" und "clearpasswd" identisch mit dem bei der Einrichtung vergeben Passwortes.

Wo liegt mein Fehler, habe ich irgendwo etwas falsch konfiguriert?
 
#4
Nenn mich Spielverderber, aber dein Passwort ist falsch :p

Ich würde jetzt folgendermaßen vorgehen:
- Noch mal das PAsswort ins Handy tippern
- Mich im Webmailer mit genau diesen Daten versuchen anzumelden

Wenn das geht, muss der Fehler im Handy liegen.
Benutzt du komisch Sonderzeichen in Adresse oder Passwort, die dein Handy falsch verschluckt? --> Passwort ändern
Klappt es immer noch nicht, benutze doch mal ein anderes Mailprogramm. Das von android ist eh Müll. Meine Empfehlung: K9-Mail

Grüße
Laubie
 
#5
Nenn mich Spielverderber, aber dein Passwort ist falsch :p

Ich würde jetzt folgendermaßen vorgehen:
- Noch mal das PAsswort ins Handy tippern
- Mich im Webmailer mit genau diesen Daten versuchen anzumelden

Wenn das geht, muss der Fehler im Handy liegen.
Benutzt du komisch Sonderzeichen in Adresse oder Passwort, die dein Handy falsch verschluckt? --> Passwort ändern
Klappt es immer noch nicht, benutze doch mal ein anderes Mailprogramm. Das von android ist eh Müll. Meine Empfehlung: K9-Mail

Grüße
Laubie
Die Logindaten sind richtig, sie werden auch auf meinem Rechner und iPad genutzt.
Passwort sind nur Groß-, Kleinbuchstaben und Zahlen, allerdings 32 Zeichen lang. Werde mal ein kürzeres testen.
 

Werbung