kein Upload mit PHP-Scripten möglich

Dieses Thema im Forum "Server Administration" wurde erstellt von Matus, 30. Aug. 2013.

  1. Matus

    Matus New Member

    Hiho,

    ich habe das tutorial für den perfekten Server mit Apache und ISPConfig3
    durch exzerziert und alles schien zu klappen.

    Nun es schien leider nur so.
    nach langer Zeit hat eine Userin versucht bei einem forum das auf meine Server gehostet wird eine Datei hochzuladen. Dies brach allerdings ab mit der Fehlermeldung "Internal Server Error" (500).
    Zuerst dachte ich die installation sei fehlerhaft und hab eine Kopie der Forensoftware auf einem eigenen Testaccount installiert. dort das selbe Problem. auch bei einem eigenem Projekt mit einem CMS der selbe Fehler.

    Die Errorlogs des Apache helfen leider auch nicht weiter weshalb ich jetzt hier mal frage ob jemand vielleicht einen verdacht oder eine Idee hat woran es liegen könnte.

    Viele Grüße, Matus
     
  2. nowayback

    nowayback Well-Known Member

    welchen php modus hast du ausgewählt?

    es sollte fast-cgi + suexec sein

    Grüße
    nwb
     
  3. Till

    Till Administrator

    Und schau mal ins error.log der webseite, dort steht die ursache für een fehler drin. Es kann auch srin dass due ie dateien als root hochgeladen und dann nicht mit chown auf den user der webseite geändert hast.
     
  4. Matus

    Matus New Member

    Also die Dateien wurden per FTP-user hochgeladen ware also richtig. Das Problem war das beim Update die mod_fcgi geändert wurde und der Upload auf 128kb beschrenkt wurde. Befehl zum überschreiben gesetzt, service apache reload und alles geht wieder.
     

Diese Seite empfehlen