Kein Zugriff auf Webinterface von ISPConfig nach Installation

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Nashoa, 27. Feb. 2013.

  1. Nashoa

    Nashoa New Member

    Hallo alle zusammen,
    zuerst etwas über mich, ich habe vor ca. einem Monat auf unseren Home-Server auf dem vorher Windows Home-Server lief Ubuntu Server installiert. Bin also ein Neuling im bezug auf Linux (hatte zwar vorher schon Ubuntu auf meinem Laptop aber mich nie groß damit beschäftigt, besonders nicht mit der Konsole) Jetzt möchte ich auch einen Mailserver drauf packen und bin auf die Anleitung Der Perfekte Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3) gestoßen und hab das dann mal alles installiert. Ich bin genau nach Anleitung vorgegangen und habe auch alle Schritte befolgt.
    Soweit ich es sehen kann hat auch alles geklappt. Ich komme aber obwohl mir keine Fehler bei der Installation aufgefallen sind nicht auf die Weboberfläsche von ISPConfig. Apache an sich läuft auf jeden fall, phpmyadmin und einen phpbb3 forum funktionieren ohne Probleme aber wenn ich jetzt https://server:8080 aufrufe kommt die Meldung:
    Code:
    Forbidden
    You don't have permission to access / on this server.
    Bei http://server:8080 (also ohne s) kommt das hier:
    Code:
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>400 Bad Request</title>
    </head><body>
    <h1>Bad Request</h1>
    <p>Your browser sent a request that this server could not understand.<br />
    Reason: You're speaking plain HTTP to an SSL-enabled server port.<br /> Instead use the HTTPS scheme to access this URL, please.<br />
    <blockquote>Hint: <a href="https://localhost:8080/"><b>https://localhost:8080/</b></a></blockquote></p>
    </body></html>
    Ich hab dann auch mal ausprobiert auf einen unterordner von ISPConfig zu gehen (login, admin, ...) aber ohne Erfolg.
    Außerdem habe ich versucht über http://server/ispconfig/ drauf zu kommen, hier bleibt die Seite aber komplett weiß und auch der Seitenquelltext ist leer.

    Hat jemand eine Idee was ich machen kann?

    Danke schonmal im Vorraus
     
  2. Till

    Till Administrator

    Aktualisiere ispconfig auf 3.0.5.1.
     
  3. Nashoa

    Nashoa New Member

    Ich habe ispconfig auf Version 3.0.5.1 aktualisiert aber es gab keine veränderung. Deshalb habe ich ispconfig nochmal deinstalliert und die version 3.0.5.1 neu installiert, diesmal aber ohne die option der ssl verbindung für die weboberfläsche. Jetzt habe ich die fehlermeldung halt bei http statt bei https
    Code:
    Forbidden
    You don't have permission to access / on this server.
     
  4. Till

    Till Administrator

    Dann wird der ispconfig vhost vomapache Deines Servers nicht geladen. Versuch mal ein:

    a2dismod ispconfig.vhost
    a2enmod ispconfig.vhost

    und dann apache neu starten.
     
  5. Nashoa

    Nashoa New Member

    da bekomme ich die meldung
    Code:
    ERROR: Module ispconfig.vhost does not exist!
     
  6. Till

    Till Administrator

    Poste bitte mal die Ausgabe von:

    ls -la /etc/apache2/sites-enabled/00*

    und

    ls /etc/apache2/sites-available/isp*
     
  7. Nashoa

    Nashoa New Member

    root@Server:/etc/apache2# ls -la /etc/apache2/sites-enabled/00*
    lrwxrwxrwx 1 root root 39 Feb 28 18:38 /etc/apache2/sites-enabled/000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
    lrwxrwxrwx 1 root root 26 Feb 26 22:59 /etc/apache2/sites-enabled/000-default -> ../sites-available/default
    lrwxrwxrwx 1 root root 43 Feb 27 19:04 /etc/apache2/sites-enabled/000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
    lrwxrwxrwx 1 root root 44 Feb 28 18:38 /etc/apache2/sites-enabled/000-ispconfig.vhost -> /etc/apache2/sites-available/ispconfig.vhost

    root@Server:/etc/apache2# ls /etc/apache2/sites-available/isp*
    /etc/apache2/sites-available/ispconfig.conf /etc/apache2/sites-available/ispconfig.vhost
     
  8. Till

    Till Administrator

    Das ist auch ok. Langsam gehen mir die Ideen aus vor allem da die Ubuntu server die ich für Kunden aktualisiert habe alle einwandfrei laufen. Poste bitte mal die Datei /etc/apache2/sites-enabled/000-ispconfig.vhost
     
  9. Nashoa

    Nashoa New Member

    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################

    Listen 8080
    NameVirtualHost *:8080

    <VirtualHost _default_:8080>
    ServerAdmin webmaster@localhost

    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    IPCCommTimeout 7200
    </IfModule>

    # <IfModule mod_php5.c>
    # DocumentRoot /usr/local/ispconfig/interface/web/
    # AddType application/x-httpd-php .php
    # <Directory /usr/local/ispconfig/interface/web>
    # # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
    # Options FollowSymLinks
    # AllowOverride None
    # Order allow,deny
    # Allow from all
    # php_value magic_quotes_gpc 0
    # </Directory>
    # </IfModule>

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    <IfModule mod_security2.c>
    SecRuleEngine Off
    </IfModule>

    # SSL Configuration
    #SSLEngine On
    #SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
    #SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
    #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle

    </VirtualHost>

    <Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>
     
  10. Till

    Till Administrator

    Das ist auch ok. ISPConfig müsste unter http://deinedomain.de:8080/ erreichbar sein. Hast Du mal den ganzen Server neu gestartet?
     
  11. Nashoa

    Nashoa New Member

    ob ich den server vorher schonmal neu gestartet habe weiß ich jetzt gerade garnicht mehr, habs auf jeden fall jetzt gemacht...keine veränderung. habe nach dem neustart auch nochmal "a2enmod ispconfig.vhost" versucht aber da kommt immernoch der error, dass das modul nicht existiert.
    ich habe bei der installation von ubuntu auch tomcat mitinstalliert, was standardmäßig eine seite auf port 8080 angezeigt hat, den port habe ich auf 8090 geändert. könnte es damit irgent etwas zu tun haben?
    falls es dir irgentetwas bringt die seite mal selbber zu sehen hier die adresse: "http://nashoa.selfip.net" habe vorrübergehend die ports 8080 und 8090 auch freigegeben
     
  12. chesoft

    chesoft New Member

    Hallo Till,
    habe das gleiche Problem nach update (Debian seq.). Bin wie Nashoa vorgegangen, neu aufgesetzt usw. Jedoch das gleiche Endergebnis. Bin etwas ratlos.
    Gruß chesoft
     
  13. Till

    Till Administrator

    Dass kann durchaus sein. Ich installier das debian und ubuntu perfect setup mehrmals pro Woche für Kunden und es gab noch nie einen Update Fehler, weder in den Betas, RC's noch finals der 3.0.5 und das gleiche Ergebnis bei allen ISPConfig Entwicklern die ich befragt habe. Das Problem muss also an irgend etwas liegen das nicht wie im Standardsetup ist.

    Wir haben für solche Fälle auch remote Login support, den kann ich aber nicht kostenlos anbieten.

    projektfarm :: Support Ticket System
     
  14. kugman

    kugman New Member

    Hallo zusammen...

    scheint irgendwie ein generelles Problem zu sein. Ich habe das Problem auch. Hab von 3.0.4.irgendwas auf 3.0.5.1 aktualisiert und eine weiße Admin-Seite...
    /var/log/apache2/error.log hat nach dem Update folgende Fehler geschmissen:

    Code:
    [Sat Mar 02 23:02:10 2013] [error] [client 10.47.211.67] PHP Warning:  require_once(/usr/local/ispconfig/interface/lib/config.inc.php): failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31
    [Sat Mar 02 23:02:10 2013] [error] [client 10.47.211.67] PHP Fatal error:  require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31

    Gruß
    Markus
     
  15. Till

    Till Administrator

    Stell sicher dass Du das apache fcgi Modul installiert hast, dass ein php-fcgi Binary installiert ist, dann funktioniert auch der Zugriff wieder.
     
  16. Nashoa

    Nashoa New Member

    Also...
    Erstmal danke ich dir Till für deine Hilfeversuche auch wenn es nicht funktioniert hat. Inzwischen habe ich es aufgegeben...
    Weil ich es nicht verstehe, warum es bei mir nicht läuft habe ich meinen Server heute Nachmittag nochmal formatiert und neu aufgesetzt. Abgesehen davon, dass ich die Installation ich deutsch durschgeführt habe, die Partitionierung von Hand gemacht habe und Samba mit installiert habe habe ich alles genau nach Anleitung gemacht und es funktionierte nichtmal php. Nachdem ich alles aus Schritt 14 mit apt-get purge wieder runtergeschmissen haben und dann nur die pakete apache2 apache2-doc php5 und phpmyadmin installiert habe ging php wieder (da scheint was nicht zu stimmen in der anleitung) Bis zu dem Schritt wo ISPConfig dann fertig installiert ist und eigentlich laufen sollte hat alles ohne weitere probleme funktioniert aber ich bekomme den selben fehler wie vorher.
    "403 Forbidden"
     
  17. Till

    Till Administrator

    Die apache und php pkete ie du instlliert hast reichen nicht für ispconfig da du nur mod_php aber nicht hp-fcgi installiert hast. Installier bitte all pakete wir im perfect setup beschrieben. Ich installiere nach der anleitung, ich meine ie englische originalanleitung, mehrere server pro woche, copy und paste der befehle und sie funktionieren immer ohne weitere änderungen.
     
  18. Nashoa

    Nashoa New Member

    das is doch kacke..... bis grade lief der apache server mit php
    jetzt habe ich so wie du gesagt hast nach der anleitung den rest installiert dh ich habe genau den befehl hier ausgeführt
    Code:
    apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork  apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common  php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi  libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt  php5-imagick imagemagick libapache2-mod-suphp libruby  libapache2-mod-ruby
    jetzt funktionier php wieder nicht
    wenn ich phpmyadmin aufrufen möchte will firerfox die index.php wieder runterladen und wenn ich meine phpinfo.php aufrufe bekomme ich 500 Internal Server Error
     
  19. Till

    Till Administrator

    Wenn du keine exakten fehlermeldungen aus den logs postest, dann kann ich dir nicht helfen. Dir it auch bewußt dass die rihenolge der installation wichtig ist, ispconfig muss z.b immer als letztes installiert werden.
     
  20. Nashoa

    Nashoa New Member

    Ich glaube mein server ist von geistern besessen. Ich habe grade in die log dateinen geguckt und hab dann nochmal die seite von isp config aufgerufen um zu sehen was sich im log tut und auf einmal gehts(also ISPConfig), ich habe aber NICHTS verändert, nicht neu gestartet oder sonst was
    was aber jetzt immernoch nicht geht ist phpinfo.php und phpmyadmin

    wenn ich auf die phpinfo zugreife bekomme ich in der error.log diese meldung
    Code:
    [Mon Mar 04 22:57:22 2013] [error] [client 192.168.2.10] SoftException in Application.cpp:350: UID of script "/var/www/phpinfo.php" is smaller than min_uid, referer: http://server/
    [Mon Mar 04 22:57:22 2013] [error] [client 192.168.2.10] Premature end of script headers: phpinfo.php, referer: http://server/
    
    greife ich auch phpmyadmin zu bekomme ich keinen eintrag in der error.log

    edit: wenn ich auf squirrelmail zugreife bekomme ich auch das downloadfenster
    edit2: wenn ich über ispconfig auf squirrelmail zugreife also http://server:8080/webmail/src funktioniert es
     
    Zuletzt bearbeitet: 4. März 2013

Diese Seite empfehlen