Keine Begrüßungs E-Mails

#1
Hallo,

zunächst ein Lob an die Devs, ein wirklich gelungenes Projekt - sehr sauber und durchdacht! :)

bei der aktuellen Version 2.2.23 werden leider keine Begrüßungsemails versandt, zumindest sehe ich in der mail.log keine Regung :( Eine E-Mail Adresse wird eingetragen beim "Kunden anlegen" Formular, eine Text Vorlage für Kunden habe ich ebenfalls angelegt.

Woran könnte es liegen?

Vielen Dank im vorraus für eure Hilfe!

Grüße,
freemind
 

Till

Administrator
#2
Keine Ahnung, zumindest ist in dem Bereich kein Bug bekannt. Ich habe s mal in den Bugtracker zur Überprüfung aufgenommen.
 
#4
Hallo,

zunächst ein Lob an die Devs, ein wirklich gelungenes Projekt - sehr sauber und durchdacht! :)

bei der aktuellen Version 2.2.23 werden leider keine Begrüßungsemails versandt, zumindest sehe ich in der mail.log keine Regung :( Eine E-Mail Adresse wird eingetragen beim "Kunden anlegen" Formular, eine Text Vorlage für Kunden habe ich ebenfalls angelegt.

Woran könnte es liegen?

Vielen Dank im vorraus für eure Hilfe!

Grüße,
freemind
Hallo freemind,

ich habe es eben überprüft und es funktioniert. Die Begrüßungsmail wird allerdings erst versandt, nachdem Du dem Kunden Zugangsdaten zugewiesen hast. Hast Du das gemacht?

Grüße,
flip
 
Zuletzt bearbeitet:
#5
Hallo!

Die Zugangsdaten gebe ich ja im selben Atemzug an.. Also nein, leider liegt es nicht an fehlenden Zugangsdaten :(

Der Server hat eine feste IP und die mail.log schweigt gänzlich nachdem ein Kunde(mit Zugangsdaten) angelegt wurde.

Hat noch jemand eine Idee?

Danke jedenfalls für eure Anteilnahme Jungs! :)

LG,
freemind
 
#6
na klar, noch einige :D

nun, dann ist es fraglich ob PHP's mail() überhaupt in deinem System funktioniert. Es nutzt sendmail -t -i für das Versenden der E-Mails.
Gib doch mal folgendes in deiner Shell ein, wobei du {EMAIL} mit deiner E-Mailadresse ersetzt:

Code:
echo -e "subject: ein test\nwirklich nur ein test.." | sendmail -t -i -f {EMAIL} {EMAIL}
Funktioniert das?

Grüße,
flip
 
#7
hi,

ja, das funktionierte, nachdem ich noch "To: <email>" in das echo eingefügt habe :) Die Mail ging raus und kam sauber an.

Gruß,
freemind
 
#8
hi,

ja, das funktionierte, nachdem ich noch "To: <email>" in das echo eingefügt habe :) Die Mail ging raus und kam sauber an.

Gruß,
freemind
Wieso? Der Empfänger stand doch schon als letzter Parameter in der Kommandozeile, gleich nach dem Absender.

Leg auf jeden Fall mal eine Datei test.php in /home/admispconfig/ispconfig/web an mit folgendem Inhalt, wobei du {EMAIL} wieder mit deiner emailaddy ersetzt:

Code:
<?php
mail("{EMAIL}", "testmail", "ein test");
?>
oder einfach:

Code:
echo '<?php mail("{EMAIL}", "testmail, "ein test"); ?>' >> /home/admispconfig/ispconfig/webtest.php
auf der shell ausführen..

dann einfach mal http://deinserver:81/test.php aufrufen.
kommt die mail auch an? nach dem test kannst du die datei natürlich wieder löschen.

grüße,
flip
 
Zuletzt bearbeitet:
#9
hallo,

es ging nicht ohne "To" Field:
echo -e "subject: ein test\nwirklich nur ein test.." | sendmail -t -i -f<address>
sendmail: fatal: No recipient addresses found in message header

der php test verlief erfolgreich, die test.php kann mails senden die auch sauber ankommen.

noch irgendwelche ideen? :( :confused:

gruß,
freemind
 
#10
nunja, in meinem beitrag hatte ich ja auch zweimal die E-Mailadresse geschrieben. -f <address> steht für den Absender und die zweite E-Mail-Adresse ist der Empfänger. Aber wieauchimmer. Mit To geht es natürlich auch.

Nun, wenn die test.php funktioniert, scheint das Problem irgendwo in ISPConfig zu liegen. Hast Du denn den neuen Kunden überhaupt den Anbieter zugewiesen, der die Begrüßungsmail eingestellt hat? Falls nicht, weise dem Kunden den richtigen Anbieter zu, und setzt ihm nochmals ein Passwort. Dann wird wieder die Begrüßungsmail des entsprechenden Anbieters versandt.
 
Zuletzt bearbeitet:
#11
Hast Du denn den neuen Kunden überhaupt den Anbieter zugewiesen, der die Begrüßungsmail eingestellt hat? Falls nicht, weise dem Kunden den richtigen Anbieter zu, und setzt ihm nochmals ein Passwort. Dann wird wieder die Begrüßungsmail des entsprechenden Anbieters versandt.
Hallo Leute,

ich habe in der aktuellen 3.0.16 leider gar keine Möglichkeit dem Kunden einen reseller zuzuordnen?! Oder ich übersehe diesen Punkt einfach. Aber wenn ich einen neuen Kunden anlegen will habe ich lediglich folgende Punkte die ich eintragen kann:
Firmenname
Kontakt
Benutzername
Passwort
Passwortkomplexität


Sprache bg hu fi ru nl pl br en it es de se fr
Thema default
Straße
PLZ
Ort
Bundesland
Staat Afghanistan Albania Algeria American Samoa Andorra Angola Anguilla Antarctica Antigua and Barbuda Argentina Armenia Aruba Australia Austria Azerbaijan Bahamas Bahrain Bangladesh Barbados Belarus Belgium Belize Benin Bermuda Bhutan Bolivia Bosnia and Herzegovina Botswana Bouvet Island Brazil British Indian Ocean Territory Brunei Darussalam Bulgaria Burkina Faso Burundi Cambodia Cameroon Canada Cape Verde Cayman Islands Central African Republic Chad Chile China Christmas Island Cocos (Keeling) Islands Colombia Comoros Congo Congo, the Democratic Republic of the Cook Islands Costa Rica Cote D'Ivoire Croatia Cuba Cyprus Czech Republic Denmark Djibouti Dominica Dominican Republic Ecuador Egypt El Salvador Equatorial Guinea Eritrea Estonia Ethiopia Falkland Islands (Malvinas) Faroe Islands Fiji Finland France French Guiana French Polynesia French Southern Territories Gabon Gambia Georgia Germany Ghana Gibraltar Greece Greenland Grenada Guadeloupe Guam Guatemala Guinea Guinea-Bissau Guyana Haiti Heard Island and Mcdonald Islands Holy See (Vatican City State) Honduras Hong Kong Hungary Iceland India Indonesia Iran, Islamic Republic of Iraq Ireland Israel Italy Jamaica Japan Jordan Kazakhstan Kenya Kiribati Korea, Democratic People's Republic of Korea, Republic of Kuwait Kyrgyzstan Lao People's Democratic Republic Latvia Lebanon Lesotho Liberia Libyan Arab Jamahiriya Liechtenstein Lithuania Luxembourg Macao Macedonia, the Former Yugoslav Republic of Madagascar Malawi Malaysia Maldives Mali Malta Marshall Islands Martinique Mauritania Mauritius Mayotte Mexico Micronesia, Federated States of Moldova, Republic of Monaco Mongolia Montserrat Morocco Mozambique Myanmar Namibia Nauru Nepal Netherlands Netherlands Antilles New Caledonia New Zealand Nicaragua Niger Nigeria Niue Norfolk Island Northern Mariana Islands Norway Oman Pakistan Palau Palestinian Territory, Occupied Panama Papua New Guinea Paraguay Peru Philippines Pitcairn Poland Portugal Puerto Rico Qatar Reunion Romania Russian Federation Rwanda Saint Helena Saint Kitts and Nevis Saint Lucia Saint Pierre and Miquelon Saint Vincent and the Grenadines Samoa San Marino Sao Tome and Principe Saudi Arabia Senegal Serbia and Montenegro Seychelles Sierra Leone Singapore Slovakia Slovenia Solomon Islands Somalia South Africa South Georgia and the South Sandwich Islands Spain Sri Lanka Sudan Suriname Svalbard and Jan Mayen Swaziland Sweden Switzerland Syrian Arab Republic Taiwan, Province of China Tajikistan Tanzania, United Republic of Thailand Timor-Leste Togo Tokelau Tonga Trinidad and Tobago Tunisia Turkey Turkmenistan Turks and Caicos Islands Tuvalu Uganda Ukraine United Arab Emirates United Kingdom United States United States Minor Outlying Islands Uruguay Uzbekistan Vanuatu Venezuela Viet Nam Virgin Islands, British Virgin Islands, U.s. Wallis and Futuna Western Sahara Yemen Zambia Zimbabwe
Telefon
Handy
Fax
Email
Internet
ICQ
Notizen

Muss man diese Funktion irgendwo aktivieren?
Ich bin derzeit als admin eingeloggt und habe erstmal alle Kunden angelegt und wollte diese nachträglich dann an einen reseller "übergeben"
der reseller existierte auch vor dem anlegen der Kunden schon.

Auch der Eintrag unter "Tools" fehlt mir leider komplett :-(

Kann jemand helfen?

Gruß & Dank xxfog
 

Till

Administrator
#12
Dieser Thread bezieht sich auf ISPConfig 2, das ist eine ganz andere Software als ISPConfig 3. Also bitte nicht in ISPConfig 2 threads posten wenn Ihr ISPCOnfig 3 einsetzt sondern macht einen neuen Thread auf.

Zu Deiner Frage, Logge Dich als Reseller ein und lege den Kunden dann an.
 
#13
Hi Till,

sorry, dass mit der Version habe ich übersehen, da die Forumstruktur keinen genauen Hinweis darauf gibt.

Kann ich im Nachhinein die User nicht noch einem anderen Reseller zuordnen?
Ist es geplant so ein Feature einzubauen?

Hintergrund ist der: Ich hatte z.B. auch früher schon mal einen reseller, der dann aufgehört hat. Er schrieb alle seine Kunden an und bat ihnen an, dass ich die Domains und Webs ja weiterhin für die Kunden betreuen könnte.
Alle die dem Zugestimmt haben, konnte ich in Confixx einfach in meinen reseller-Account übernehmen - ich finde diese Funktion sehr nützlich.
 

Werbung