Keine Stats / Keine Logfiles

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von mintess, 2. Juni 2014.

  1. mintess

    mintess Member

    Hi,

    bei manchen Webseiten werden keine Logfiles erzeugt.

    D.h. sie liegen schon hier: /var/log/ispconfig/httpd/WEBSEITE/access.log
    aber nicht hier: /var/www/WEBSEITE/log

    Und damit meldet awstats auch nur einen 404 weil die awindex.html fehlt


    Aufruf von /usr/local/ispconfig/server/cron_daily.sh bringt keine Fehler.


    Cron.log schreibt etwas ansatzweise damit verknüpfbares (es handelt sich um den Client 17 und das Web 77):
    Do 15. Mai 00:30:03 CEST 2014 Warnung: Überlanges Verweis-Feld abgeschnitten
    Do 15. Mai 00:30:26 CEST 2014 gzip: /var/www/clients/client17/web77/log/error.log: file size changed while zipping

    Irgendwelche Ideen ?
    In einem anderen Thread war die Lösung Zeitzonen, bei mir stehen alle auf Europe/Berlin.
     
  2. nowayback

    nowayback Well-Known Member

    ist es ein längerer Domainname?
     
  3. mintess

    mintess Member

    21-stellig, also eher nicht.
     
  4. mintess

    mintess Member

    Update:
    Wie ich in einem ähnlichen Thread herausfan sind die Logfileordner gemountet.
    Das sind sie aber offenbar nur bei einem Bruchteil der Webseiten!

    Bitte um Hilfe, ich weiß nicht wie ich weiter vorgehen soll, löschen und neu anlegen eher nicht das sind mitunter große Webseiten mit Datenbanken und FTP Usern usw usw.
     
  5. Till

    Till Administrator

    Schau in /etc/fstab nach, ob dort mount zeilen für existierende Seiten fehlen. Wenn das der fall ist, kannst Du sie fort auch manuell einfügen und dann:

    mount -a

    ausführen.
     
  6. mintess

    mintess Member

    Update:
    Folgendes passierte nun:

    - In der /etc/fstab waren alle Einträge bereits drin
    - "mount -a" löste das mount Problem, das scheint ispconfig nicht (immer) bei Client- oder Webseiten-Anlage korrekt durchzuführen
    - Es wurde danach immernoch ein 404 angezeigt statt der stats
    - Ich führte /usr/local/ispconfig/server/cron_daily.sh händisch aus
    - Es kamen ein Haufen Meldungen "Warnung: Überlanges Verweis-Feld abgeschnitten" ohne weitere Info leider,
    - aber die Stats Anzeige funktioniert nun :)

    Dank dir Till!
     
  7. Till

    Till Administrator

    das muss ispconfig auch nicht, denn mount -a mountet alles neu. ISConfig mountet bei anlage einer neuen website aber nur die webseite neu und eben nicht alle, weil es nicht notwendig ist.

    Statistiken werden nachst erstellt, Du kannst da also nicht gleich eine Änderung erwarten.
     

Diese Seite empfehlen