Krieg roundcube nicht zum laufen

#1
Hallo,

ich habe gerade einen neuen Server aufgesetzt und will roundcube als Webmailer haben. Wenn ich meinserver.tld/roundcube aufrufe bekomme ich einen HTTP 500 Fehler. Im error.log steht dieses:

proxy: No protocol handler was valid for the URL /webmail/. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.

Meine config dafür sieht so aus:

Alias /roundcube /var/www/roundcube

RedirectMatch permanent /webmail /webmail/

ProxyPreserveHost On

<Location /webmail/>
ProxyPass http://name.tld/roundcube/
ProxyPassReverse http://name.tld/roundcube/

SetEnv force-proxy-request-1.0 1
SetEnv proxy-nokeepalive 1
Order deny,allow
Allow from all
</Location>



<Directory /var/www/roundcube>
AllowOverride all
Options FollowSymLinks
DirectoryIndex index.php

<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>

Order allow,deny
Allow from all
</Directory>

Die habe ich mir von einem anderen funktionierenden Server kopiert. Das Proxy modul ist auch geladen. So sieht /mods-aviable/ aus:

0 lrwxrwxrwx 1 root root 28 2011-01-27 10:43 proxy.conf -> ../mods-available/proxy.conf
0 lrwxrwxrwx 1 root root 28 2011-01-27 10:43 proxy.load -> ../mods-available/proxy.load

Habt Ihr einen Tipp für mich?

Danke

Stefan
 

Till

Administrator
#2
Apache hat 2 proxy module die beide für einen reverse proxy nötig sind, schau mal ob beide aktiv sind:

a2enmod proxy
a2enmod proxy_http
 

Werbung