Kunden-Limits-Template Inputfelder verschoben.

Dieses Thema im Forum "Allgemein" wurde erstellt von Duisburger, 12. März 2009.

  1. Duisburger

    Duisburger New Member

    Hallo Forum,
    bin jetzt doch auf -Lenny umgestiegen und ISPConfig 3.0.0.9 installiert, läuft auf Anhieb! Danke an Till für das sehr gute HOwTo. :)

    Allerdings habe ich beim Aufruf der Seite: Kunden / Limits die Inputfelder über den Text liegen. (siehe Grafik im Anhang)
    HAbe schon im IE-6 und IE-7 die Schriftgröße und Codierung geändert, bleibt aber so....

    Ups, sehe gerade noch... der Firefox stellt es richtig dar.... :cool:
    (den benutze ich aber eher selten)

    Für eine Lösung wäre ich sehr dankbar..
     

    Anhänge:

  2. Till

    Till Administrator

    Wie Du sicherlich gesehen hast ist 3.0.0.9 kein stable release sondern noch eine Vorabversion, also nicht fehlerfrei. Aktualisiere Deine Installation am besten mal auf den aktuellen Stand im SVN mit dem Befehl:

    ispconfig_update_from_svn.sh
     
  3. Duisburger

    Duisburger New Member

    danke für die info

    Hallo Till,
    ich habe deinen tip mit dem SVN beherzigt. Anzeige ist im IE6/IE7 jetzt
    auch (fast) ok. (vorletzte Feld 'Standarddatenbankserver' fließt noch
    in das inputfeld ein und bei der deutschen Darstellung des ISPConfig
    erscheint nur bei aktiven-Link der Text "Kunde" ansonsten immer "Client". )

    Beim HOWTO der pferfekte server mit debian5.... erhalte ich allerdings noch eine Warnug nach dem Erstellen des MyDns

    debian:/etc/init.d# update-rc.d mydns defaults
    update-rc.d: warning: /etc/init.d/mydns missing LSB information
    update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
    Adding system startup for /etc/init.d/mydns ...
    /etc/rc0.d/K20mydns -> ../init.d/mydns
    /etc/rc1.d/K20mydns -> ../init.d/mydns
    /etc/rc6.d/K20mydns -> ../init.d/mydns
    /etc/rc2.d/S20mydns -> ../init.d/mydns
    /etc/rc3.d/S20mydns -> ../init.d/mydns
    /etc/rc4.d/S20mydns -> ../init.d/mydns
    /etc/rc5.d/S20mydns -> ../init.d/mydns
    debian:/etc/init.d# debian:/etc/init.d#

    und MyDsn wird im ISPConfig als nicht aktiv angezeigt. Hängt das evtl. zusammen?

    Nachdem ich nun mehrmals den server neu aufgesetzt habe, habe ich noch folgendes großes Porblem. Egal, ob deutsche oder englische Version, habe ich keinen Browser-Zugriff auf das CGI-BIN-Verzeichnis eines Kunden, Error 403.
    Habe auch die Einstellung mit und ohne SUEXEC ausprobiert, keine Änderung, die vhost sieht allerding dann etwas anders aus.
    Hier mal ein Auszug einer ***.vhost:

    debian:/etc/apache2/sites-enabled# cat siq-kunstharze.net.vhost
    |<Directory /var/www/siq-kunstharze.net>
    | AllowOverride None
    | Order Deny,Allow
    | Deny from all
    |</Directory>

    Ist das der richtige Ort? (vor dem virtualcontainer?)

    <VirtualHost *:80>
    DocumentRoot /var/www/siq-kunstharze.net/web
    ServerName siq-kunstharze.net
    ServerAlias www.siq-kunstharze.net
    ServerAdmin webmaster@siq-kunstharze.net
    ErrorLog /var/log/ispconfig/httpd/siq-kunstharze.net/error.log

    <Directory /var/www/siq-kunstharze.net/web>
    Options FollowSymLinks
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    <Files ~ '.php[s3-6]{0,1}$'>
    Order allow,deny
    Deny from all
    Allow from none
    </Files>
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    Options FollowSymLinks
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    <Files ~ '.php[s3-6]{0,1}$'>
    Order allow,deny
    Deny from all
    Allow from none
    </Files>
    </Directory>
    # cgi enabled
    ScriptAlias /cgi-bin/ /var/www/clients/client1/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    * <Directory /var/www/clients/client1/web1/cgi-bin>
    * AllowOverride None
    * Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    * Order allow,deny
    * Allow from all
    * </Directory>
    </VirtualHost>


    wobei kein Zugriff auf das CGI-Verzeichniss möglich war. Erst durch
    manuelles Hinzufügen der markierten Directory-Zeilen funktionierte es.
     
    Zuletzt bearbeitet: 14. März 2009
  4. Till

    Till Administrator

Diese Seite empfehlen