Lenny: Nach ISP3-Installation geht FTP-Server nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von pee, 26. Mai 2009.

  1. pee

    pee New Member

    Hallo,

    ich habe soeben ISPConfig 3.0.1.2 auf meinem Lennyserver installiert. E-Mail geht, jedoch funktioniert der FTP-Server nicht.

    So sieht im Adminmenü die Fehlermeldung aus: http://pics.netzor.de/ftp.png.

    Habe die Installations-Anleitung unter http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3 befolgt.

    Zudem kann ich mich nur mit der Shell über SSH in den Root-Server einloggen, nicht aber über Nautilus (Dateimanager von Gnome).

    Wäre klasse wenn mir jemand helfen würde. ;)

    Viele Grüße!
     
  2. Till

    Till Administrator

    Poste mal die Ausgabe von:

    netstat -tap
     
  3. pee

    pee New Member

    Bitteschön (XXXX soll den Servernamen anonymisieren).

    XXXX:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:645 *:* LISTEN 3861/famd
    tcp 0 0 *:41446 *:* LISTEN 1904/rpc.statd
    tcp 0 0 localhost:10024 *:* LISTEN 24481/amavisd (mast
    tcp 0 0 localhost:10025 *:* LISTEN 24412/master
    tcp 0 0 localhost:mysql *:* LISTEN 24229/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 2197/portmap
    tcp 0 0 XXXX.cyan.fast:http-alt 0x573b282e.kbnqu1:10828 SYN_RECV -
    tcp 0 0 XXXX.cyan.fastwebse:www 0x573b282e.kbnqu1:10828 SYN_RECV -
    tcp 0 0 XXXX.cyan.fastwe:domain *:* LISTEN 25206/mydns
    tcp 0 0 localhost:domain *:* LISTEN 25206/mydns
    tcp 0 0 *:ftp *:* LISTEN 14268/inetd
    tcp 0 0 *:ssh *:* LISTEN 2056/sshd
    tcp 0 0 *:smtp *:* LISTEN 24412/master
    tcp 0 0 XXXX.cyan.fastweb:https 0x573b282e.kbnqu1:10828 SYN_RECV -
    tcp 0 0 XXXX.cyan.fastwebse:ssh p4FCE0C9D.dip0.t-:63440 ESTABLISHED 2304/0
    tcp 0 0 localhost:mysql localhost:60113 ESTABLISHED 24229/mysqld
    tcp 0 0 localhost:55733 localhost:mysql ESTABLISHED 24877/amavisd (ch2-
    tcp 0 192 XXXX.cyan.fastwebse:ssh p4FCE0C9D.dip0.t-:63733 ESTABLISHED 9792/1
    tcp 0 0 localhost:mysql localhost:55733 ESTABLISHED 24229/mysqld
    tcp 0 0 localhost:60113 localhost:mysql ESTABLISHED 24878/amavisd (ch2-
    tcp6 0 0 [::]:imaps [::]:* LISTEN 25122/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 25150/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 25133/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 25105/couriertcpd
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 9322/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 9322/apache2
    tcp6 0 0 localhost:domain [::]:* LISTEN 25206/mydns
    tcp6 0 0 [::]:ssh [::]:* LISTEN 2056/sshd
    tcp6 0 0 [::]:https [::]:* LISTEN 9322/apache2
    tcp6 0 0 XXXX.cyan.fastwebse:www adsl-89-217-31-13:20269 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www 141.201.199.84%30:48861 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www dslb-088-065-066-:36475 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www rstk-5f76fbb0.poo:60109 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www port-83-236-182-77:6754 ESTABLISHED 10340/apache2
    tcp6 0 0 XXXX.cyan.fastwebse:www p548367BE.dip.t-d:43175 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www dslnet.85-22-4.ip:63139 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www xdsl-87-78-25-173:40664 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www e177189098.adsl.a:64518 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www e177222065.adsl.a:33891 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www pat-97.sg.de.o2.co:5075 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www dslb-088-065-173-:61198 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www merri.ET.UniBw-Mu:42905 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www i59F75D52.versane:62954 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www 62.159.91.50%3039:55727 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www 192.100.130.228%3:42377 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www dslb-088-068-222-:60479 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www gutmann.mmz.uni-d:53235 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www pat-97.sg.de.o2.c:36791 ESTABLISHED 10355/apache2
    tcp6 0 0 XXXX.cyan.fastwebse:www p548367BE.dip.t-d:43183 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www dslb-084-060-110-:57306 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www dslnet.85-22-4.ip:63117 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www g225203207.adsl.a:16509 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www pool-70-17-232-79:47220 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www xdsl-87-78-25-173:48335 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www dslb-088-065-173-:61195 FIN_WAIT2 -
    tcp6 0 0 XXXX.cyan.fastwebse:www i59F75D52.versane:62956 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www merri.ET.UniBw-Mu:42906 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www e177189098.adsl.a:59694 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www rstk-5f76fbb0.poo:60103 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www port-83-236-182-7:16936 TIME_WAIT -
    tcp6 0 0 XXXX.cyan.fastwebse:www g225203207.adsl.a:16503 TIME_WAIT -
     
  4. Till

    Till Administrator

    Dein FTP Server läuft noch über inetd. Schau bitte nochmal ins howto, Du musst die Zeile in der inetd.conf auskommentieren und dann den inetd neu starten und danach dann noch den pureftpd starten.
     
  5. pee

    pee New Member

    Ich habe die Anleitung bereits zuvor befolgt und jene Zeile auskommentiert. In meiner Datei befindet sich nur diese eine Zeile:

    Code:
    ftp     stream  tcp     nowait  root    /usr/sbin/tcpd /usr/sbin/pure-ftpd-wrapper
    Bist du sicher, dass es daran liegt?
     
  6. Till

    Till Administrator

    Ja, die mus mit # auskommentiert werden. Oder der inetd ist nicht neu gestartet worden. Du kannst sonst auch nochmal schauen ob es eine xinetd.conf Datei oder ein xinetd läuft, da liegen die Dateien in /etc/xinetd
     
  7. pee

    pee New Member

    Stimmt, die Zeile war nicht auskommentiert. War ein Versehen. :)

    Habe danach alles neu gestartet:

    Code:
    c082:~# /etc/init.d/openbsd-inetd restart 
    Restarting internet superserver: inetdNot starting internet superserver: no services enabled.
    c082:~# /etc/init.d/pure-ftpd-mysql start
    Starting ftp server: perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "de_DE.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -A -u 1000 -E -b -O clf:/var/log/pure-ftpd/transfer.log -B
    c082:~# 
    
    Verschaffte allerdings keine Änderung. Die Datei xinetd.conf gibt es bei mir nicht. Konnte sie mit

    Code:
    find / -name xinetd.conf
    nicht aufspüren. Selbst das Verzeichnis habe ich nicht:

    Code:
    c082:/# cd /etc/xinetd
    -bash: cd: /etc/xinetd: No such file or directory
    
     
  8. pee

    pee New Member

    Die Ausgabe von netstat -tap hat sich allerdings verändert:

    Code:
    c082:/# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost:645           *:*                     LISTEN      3861/famd       
    tcp        0      0 *:41446                 *:*                     LISTEN      1904/rpc.statd  
    tcp        0      0 localhost:10024         *:*                     LISTEN      24481/amavisd (mast
    tcp        0      0 localhost:10025         *:*                     LISTEN      24412/master    
    tcp        0      0 localhost:mysql         *:*                     LISTEN      24229/mysqld    
    tcp        0      0 *:sunrpc                *:*                     LISTEN      2197/portmap    
    tcp        0      0 *:ftp                   *:*                     LISTEN      26504/pure-ftpd (SE
    tcp        0      0 c082.cyan.fastwe:domain *:*                     LISTEN      25206/mydns     
    tcp        0      0 localhost:domain        *:*                     LISTEN      25206/mydns     
    tcp        0      0 *:ssh                   *:*                     LISTEN      2056/sshd       
    tcp        0      0 *:smtp                  *:*                     LISTEN      24412/master    
    tcp        0      0 localhost:33038         localhost:mysql         ESTABLISHED 26517/smtpd     
    tcp        0      0 localhost:33043         localhost:mysql         TIME_WAIT   -               
    tcp        0      0 localhost:mysql         localhost:33032         ESTABLISHED 24229/mysqld    
    tcp        0      0 c082.cyan.fastwebse:ssh p4FCE0C9D.dip0.t-:63440 ESTABLISHED 2304/0          
    tcp        0      0 localhost:33042         localhost:mysql         TIME_WAIT   -               
    tcp        0      0 localhost:mysql         localhost:60113         ESTABLISHED 24229/mysqld    
    tcp        0      0 localhost:33033         localhost:mysql         ESTABLISHED 26517/smtpd     
    tcp        0      0 localhost:mysql         localhost:33031         ESTABLISHED 24229/mysqld    
    tcp        0      0 localhost:33040         localhost:mysql         TIME_WAIT   -               
    tcp        0      0 localhost:55733         localhost:mysql         ESTABLISHED 24877/amavisd (ch2-
    tcp        0      0 localhost:33044         localhost:mysql         TIME_WAIT   -               
    tcp        0    192 c082.cyan.fastwebse:ssh p4FCE0C9D.dip0.t-:63733 ESTABLISHED 9792/1          
    tcp        0      0 localhost:33032         localhost:mysql         ESTABLISHED 26517/smtpd     
    tcp        0      0 localhost:mysql         localhost:33038         ESTABLISHED 24229/mysqld    
    tcp        0      0 localhost:mysql         localhost:33033         ESTABLISHED 24229/mysqld    
    tcp        0      0 localhost:33041         localhost:mysql         TIME_WAIT   -               
    tcp        0      0 localhost:mysql         localhost:55733         ESTABLISHED 24229/mysqld    
    tcp        0      0 localhost:60113         localhost:mysql         ESTABLISHED 24878/amavisd (ch2-
    tcp        0      0 localhost:33031         localhost:mysql         ESTABLISHED 26517/smtpd     
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      25122/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      25150/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      25133/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      25105/couriertcpd
    tcp6       0      0 [::]:http-alt           [::]:*                  LISTEN      26435/apache2   
    tcp6       0      0 [::]:www                [::]:*                  LISTEN      26435/apache2   
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      26504/pure-ftpd (SE
    tcp6       0      0 localhost:domain        [::]:*                  LISTEN      25206/mydns     
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2056/sshd       
    tcp6       0      0 [::]:https              [::]:*                  LISTEN      26435/apache2   
    tcp6       0      0 c082.cyan.fastwebs:pop3 hbrn-5f721e7c.poo:51682 ESTABLISHED 26624/courierpop3lo
    tcp6       0      0 c082.cyan.fastwebse:www e177189098.adsl.a:61614 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www 147.86.196.135%35:58768 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www dslnet.85-22-4.ip:63349 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www g226133129.adsl.a:56170 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www gutmann.mmz.uni-d:50573 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www dslb-088-065-173-:62242 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www g225203207.adsl.a:25670 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www 123.125.64.38%350:39641 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www 141.201.199.84%35:46186 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www p57B766C7.dip.t-di:9899 ESTABLISHED 26586/apache2   
    tcp6       0      0 c082.cyan.fastwebse:www p548367BE.dip.t-d:42783 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www rstk-5f76fbb0.poo:60773 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www p548367BE.dip.t-d:42783 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www rstk-5f76fbb0.poo:60773 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www e177222065.adsl.a:53681 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www port-8298.pppoe.w:33297 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www 194.209.146.84%35:49623 ESTABLISHED 26621/apache2   
    tcp6       0      0 c082.cyan.fastwebse:www e177189098.adsl.a:58566 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www merri.ET.UniBw-Mu:45724 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www g225203207.adsl.a:25671 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www dslb-088-065-173-:62241 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www g226133129.adsl.a:64719 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www g226232011.adsl.a:34190 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www 62.159.91.50%3508:55855 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www dsdf-5d82f16a.poo:46654 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www adsl-89-217-226-4:41710 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www dslb-088-068-222-:55172 FIN_WAIT2   -               
    tcp6       0      0 c082.cyan.fastwebse:www p54B07A65.dip.t-di:3383 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www dslnet.85-22-4.ip:63343 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www llf531380.crawl.y:48735 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www 91-64-100-140-dyni:3151 TIME_WAIT   -               
    tcp6       0      0 c082.cyan.fastwebse:www 91-64-100-140-dyni:3151 TIME_WAIT   -           
     
  9. Till

    Till Administrator

    Ok, das ist soweit schon mal gut. Poste bitte nochmal die Ausgabe von netstat -tap und dann auch noch die Ausgabe von "iptables -L"
     
  10. Till

    Till Administrator

    Ok, netstat sieht schonmal gut aus.
     
  11. pee

    pee New Member

    Danke Till. Nachdem ich mich neu eingeloggt habe, geht der FTP-Server. Du warst so schnell mit dem Antworten, dass mir keine Zeit zum erneuten Einloggen blieb. Vielen vielen Dank für deine prima Hilfe. ;)
     
  12. gansa28

    gansa28 New Member

    Hoi,

    bei mir siehts folgendermaßen aus:

    tcp6 0 0 [::]:ftp [::]:* LISTEN 32411/xinetd

    in xinetd steht folgendes:
    ________________________________________________________________

    # Simple configuration file for xinetd
    #
    # Some defaults, and include /etc/xinetd.d/

    defaults
    {

    # Please note that you need a log_type line to be able to use log_on_success
    # and log_on_failure. The default is the following :
    # log_type = SYSLOG daemon info

    disable = yes
    }

    includedir /etc/xinetd.d
    _________________________________________________________________


    Wie muss ich hier Verfahren?

    System Debian Lenny.

    MFG

    Gansa28
     
    Zuletzt bearbeitet: 22. Juni 2009
  13. Till

    Till Administrator

    Du hast vergessen den ftp server im xinetd zu deaktivieren und ihn als standalone zu starten. Schau bitte nochmal ins manual und kommentier die Zeile in der xinetd conf aus und starte danach xinetd neu.
     
  14. gansa28

    gansa28 New Member

    Mmmmmh,

    also meine /etc/inetd.conf sieht so aus:

    Die /etc/default/pure-ftpd-common

    Beim Versuch den inetd neuzustarten:

     
  15. Till

    Till Administrator

    Es läuft aber ein xinetd. Schau mal nach was Du mit Namen inetd oder xinetd so in /etc/init.d findest aund dann seh mal in /etc nach ob da eine xinetd.conf oder im xinet.d Verzeichnis was für ftp drin ist.
     
  16. gansa28

    gansa28 New Member

    Ja habe ich alles schon durchsucht und zwar:

    In der Server1:/etc# vi xinetd.d

    Server1:/etc# vi xinetd.conf

    Habe ich so ein Komisches System Aufgesetzt oder bin ich einfach nut zu Blöd dafür :)
     
  17. Till

    Till Administrator

    Starte mal den ganzen Server neu und check dann nochmal mit netstat -tap
     
  18. gansa28

    gansa28 New Member

    Nach Server neustart :

    mit /etc/init.d/pure-ftpd-mysql start

     
    Zuletzt bearbeitet: 24. Juni 2009
  19. Till

    Till Administrator

    Ist das ein vserver?
     
  20. gansa28

    gansa28 New Member

    So, ja das ist ein VServer von Strato. habe das mit den Capabilities schon Probiert leider klappt das nicht so ganz.
    Habe den Server daheim mehrmals ohne probleme aufgesetzt, aber jetzt kommt halt wieder dieses leidige Thema mit dem FTP Server.
     

Diese Seite empfehlen