Lösung: Initialer Login klappt nicht: Benutzername oder Passwort ist leer.

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von fx666, 15. Mai 2014.

  1. fx666

    fx666 New Member

    Hallo zusammen,

    ich hatte beim ersten Weblogin diese Fehlermeldung:

    "Benutzername oder Passwort ist leer."

    Wie man an vielen Stellen lesen kann ist der Grund wohl ein Datenbankfehler. Das sieht man auch im Apache error.log.

    Also:

    Config Datei suchen und das Passwort prüfen und in der DB am besten nochmal eintragen.
    Aber: Es gibt 2 Konfigdateien.

    /usr/local/ispconfig/interface/lib/config.inc.php
    /usr/local/ispconfig/server/lib/config.inc.php

    Die im Verzeichnis .../interface/... ist diejenige welche das hier gesuchte Passwort enthaelt. Die Datei im Verzeichnis .../server/... ist vermutlich die mit dem mysql-admin(root)-passwort zur Verwaltung der mysql-accounts.

    Deswegen also die erste Datei anschauen, die Werte db_user db_host db_password db_database notieren und jetzt die Datenbank entsprechend korrigieren:

    Code:
     mysql -h -uroot -pROOTPW 
    mysql> 
    grant all on db_database.* to '<db_user>'@'<server-ip>' identified by 'db_password'; 
    flush privileges; 
    
    server-ip ist die Server-IP Eures Servers.

    (Die Perfect-Serveranleitung konfiguriert mysql auf die Öffentliche IP) Danach vielleicht nochmal den Apache neu starten. Jetzt sollte der Login klappen.(Die Fehlermeldungen im Apache error.log dürften nicht mehr auftauchen.)
     
    Zuletzt bearbeitet: 15. Mai 2014

Diese Seite empfehlen