Mail "loops back to myself" Meldung

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Feanwulf, 20. Feb. 2008.

  1. Feanwulf

    Feanwulf Member

    Hallo,

    ich habe heute festgestellt, das mein Server für die "@coe.utopic.de" eMails annimmt - diese werden dann zwar nicht zugestellt, aber anscheinend nur weil laut Delivery Report die in einer Schleife laufen:

    Code:
                       The mail system  <[EMAIL="ambozzz@coe.utopic.de"]ambozzz@coe.utopic.de[/EMAIL]>: mail for coe.utopic.de loops back to myself
    Jetzt frage ich mich, warum nimmt mein Mailserver die überhaupt an, anstatt direkt abzulehnen.

    Meine main.cf sieht wie folgt aus:
    Code:
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = mail.ausgangsserver.de
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination,check_policy_service unix:private/po
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    
    Ich habe alles nach einen Perfect Setup DEBIAN installiert und lasse ISPConfig 2.2.21 laufen.

    Ein Open Relay Test verlief glücklicherweise positiv (= kein offenes Relay)


    Frage: Wie krieg ich "loops back to myself" weg und eine direkte Ablehnung!
     
  2. Till

    Till Administrator

    Wenn Du einen Loops Back Fehler erhältst, ist die Fehlerlösung immer wie folgt:

    Füge die Domain, die in der Fehlermeldung genannt wird (in Deinem Fall coe.utopic.de) am Ende der Datei /etc/postfix/local-host-names ein und starte postfix neu. Dann erkennt postfix, dass es sich um eine lokale domain handelt, falls es ein Postfach dann nicht gibt, wird die Mail abgelehnt.
     
  3. Feanwulf

    Feanwulf Member

    da es sich um eine Subdomain handelt - die garnicht konfiguriert ist irritiert mich das allerdings ein wenig!

    Ich möchte halt daß emails an coe.utopic.de (was nicht im DNS konfiguriert ist) direkt abgelehnt werden.

    Dies gilt übrigens für alle Domains die auf dem Server betrieben werden. Es sollen nur eMails angenommen werden, bzw auf einen Benutzer geprüft werden, wenn die Domain auch in der local-host-names Datei drinstehen!

    Ansonsten müsste ich jetzt für jede Subdomain die es geben könnte einen Eintrag manuell hinzufügen! Will ich aber nicht ;)
     
  4. Till

    Till Administrator

    Die Domain verweist aber im Moment auf die IP Deines Servers, daher die loops back Meldung. Du solltest also Deinen DNS so ändern, dass die Domain nicht mehr auf den Server verweist oder aber die Domain konfigurieren, wie ich es oben beschrieben habe.
     
  5. Feanwulf

    Feanwulf Member

    Code:
    web-ng:~# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mail.ausgangsserver.de ESMTP Postfix (Debian/GNU)
    helo intra.tal.de
    250 mail.ausgangsserver.de
    mail from: joerges@tal.de
    250 2.1.0 Ok
    rcpt to: test@cesar.utopic.de
    250 2.1.5 Ok
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.
    web-ng:~# ping cesar.utopic.de
    ping: unknown host cesar.utopic.de

    Anhand obigem Beispiel müsste doch direkt eine Ablehnung kommen! Wo liegt mein Denkfehler?
     
  6. Feanwulf

    Feanwulf Member

    Folgender Fehler bei mir:

    * A-Record war gesetzt (*.utopic.de) - also GAB es einen A-Record für die Domain und der Server hat alles angenommen.
     

Diese Seite empfehlen