Mail-Problem

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von pixeluser, 27. Jan. 2008.

  1. pixeluser

    pixeluser New Member

    Hallo,

    ich habe heute den Servernamen geändert und kann seitdem keine Mails mehr empfangen. Wenn ich von einer anderen Adresse aus Mails an mich auf dem Server schicke bekomme ich immer die Meldung:

    The original message was received at Sun, 27 Jan 2008 19:20:38 +0100
    from i577A0035.versanet.de [87.122.0.53]

    ----- The following addresses had permanent fatal errors -----
    <jan@******.de>
    (reason: 554 5.7.1 <jan@******.de>: Relay access denied)

    ----- Transcript of session follows -----
    ... while talking to mail.*****.de.:
    >>> RCPT To:<jan@******.de>
    <<< 554 5.7.1 <jan@******.de>: Relay access denied
    554 5.0.0 Service unavailable


    Einloggen per Webmail geht und das versenden von dort auch.

    Per Outlook 2007 geht es nicht.

    Wenn ich dort die SMTP-Authentifizierung einschalte kommt:

    Testnachricht senden: Die Nachricht kann nicht gesendet werden. Überprüfen Sie die E-Mail-Adresse in den Kontoeigenschaften.

    Wenn ich sie auschalte kommt die Meldung :

    Testnachricht senden: Antwort des Servers: 554 5.7.1 <jan@*****.de>: Relay acce

    Irgendjemand ein Tip für mich die Suchfunktion hat mir leider auch keine Klarheit gebracht.

    Danke

    Gruß Jan
     
  2. planet_fox

    planet_fox Super-Moderator

    Wo hast du den namen geänder im ispconfig oder wo.

    Poste mal die ausgabe von

    Code:
    hostname
    und

    Code:
    postconf myhostname
    Code:
    postconf mydestination
     
  3. pixeluser

    pixeluser New Member

    Hallo,

    danke für die Hilfe, nein ich habe den hostname geändert. In ISPConfig und halt im System

    Hostname:
    HTML:
    mojo.******.de
    
    postconf myhostname:
    HTML:
    myhostname = mojo.******.de
    
    postconf mydestination:
    HTML:
    mydestination = mojo.******.de, localhost.******.de, localhost.localdomain, localhost
    
    Da scheint mir aber alles richtig zu sein.

    Gruß Jan
     
  4. Till

    Till Administrator

    Stell bitte sicher, dass Du die mydestination Zeile auskommentierts und sattdessen die folgenden beiden Zeilen reinschreibst:

    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names

    Die werden automatisch vom ISPConfig installer reingeschrieben, vermutlich hast Du sie aus Versehen gelöscht oder bei einem Paket-Update überschrieben.
     
  5. pixeluser

    pixeluser New Member

    Hallo Till,

    danke hat geklappt die mydestination waren beide aktiv.

    Gruß Jan
     
  6. pixeluser

    pixeluser New Member

    Hallo
    ich nochmal,

    ich kann jetzt wieder Empfangen, allerdings geht Senden nur an Domains die auf dem gleichen server liegen. An alle anderen kommt via Outlook Relay Access denied.

    An die Domains auf dem Server geht es in Outlook auch nur dann wenn ich die Smtp Auth abschalte. Wenn Sie an ist geht es nochnicht einmal innerhalb des Servers.

    Ich habe den Server nach dem How To für Debian 4 Etch aufgesetzt.

    Gruß Jan
     
  7. pixeluser

    pixeluser New Member

    So ich nochmal,

    ich sitze hier gerade in der Firma und kann via Thunderbird Emails auch an andere Domains verschicken die nicht auf dem Server angelegt sind.

    Wobei ich dazu sagen muss, das der Server im gleichen Class C Netz liegt wie der Rest des Hauses.

    Hat den keiner einen Tip für mich warum ich von Kabel Deutschland, bzw Versatel via Outlook 2007, Apple Mail 3.*, Entourage 2004 keine Mails an andere Domians verschicken kann.

    Gruß Jan
     
  8. Till

    Till Administrator

    Ist Dein Server in einem Rechenzentrum oder bei Dir zuhause und ist an der Kabel Deutschland Leitung angeschlossen?
     
  9. pixeluser

    pixeluser New Member

    Hallo Till

    Mein "Server" steht quasi bei uns im "Rechenzentrum" wir sind via Funkstrecke mit QSC verbunden und haben ein komplettes Class C Netz für uns.

    Leider war das mit Thunderbird ein Trugschluß ich hatte den flaschen SMTP Server im Profil ausgewählt, er versendet also auch nicht via SMPT von "mojo" sondern über den aus der Firma aber mit der "richtigen" Absenderadresse.

    Ich verstehe bloß nicht wo mein Problem liegt. Via Webinterface geht es aber wenn ich versuche das über einen normalen E-Mail Client zu machen kommt immer Relay Acess Denied.

    Ich habe micht an das HowTo für Debian gehalten und es will einfach nicht klappen.

    Gruß Jan
     
  10. Till

    Till Administrator

    1) Hast Du Deinen Server wie im perfect setup beschrieben konfiguriert?
    2) Hast Du smtp Authentifizierung im Mail-Client aktiviert.
     
  11. pixeluser

    pixeluser New Member

    Ja ich habe alles so gemacht wie im Perfect Setup beschrieben ist.
    Und ja ich habe smtp Authentifizierung im Mail-Client aktiviert.

    Wenn ich bei Outlook 2007 die Einstellungen teste kommt der Hinweis bei aktivierter smtp Authentifizeriung das ich die E-Mail addresse prüfen soll.

    Wenn ich sie abschalte kann ich mir selber eine Mail schicken aber halt nicht an andere.

    Gruß Jan
     
  12. beta-red

    beta-red New Member

    mir scheint so als wäre der Postfix nicht offen für Anmeldungen außerhalb deines Lokalen Netzes. Hast Du das mal überprüft?
     
  13. Till

    Till Administrator

    Sieh bitte mal in der Mail Log datei nach, welche Fehlermeldungen Du dort erhältst.
     
  14. pixeluser

    pixeluser New Member

    Hallo,

    hier der Auszug aus Mail.log

    HTML:
    Jan 30 08:56:45 mojo courierpop3login: Connection, ip=[::ffff:87.122.33.193]
    Jan 30 08:56:45 mojo courierpop3login: LOGIN, user=web1_jan, ip=[::ffff:87.122.33.193]
    Jan 30 08:56:45 mojo courierpop3login: LOGOUT, user=web1_jan, ip=[::ffff:87.122.33.193], top=0, retr=0, rcvd=12, sent=39, time=0
    Jan 30 08:58:19 mojo courierpop3login: Connection, ip=[::ffff:87.122.33.193]
    Jan 30 08:58:19 mojo courierpop3login: LOGIN, user=web1_jan, ip=[::ffff:87.122.33.193]
    Jan 30 08:58:20 mojo courierpop3login: LOGOUT, user=web1_jan, ip=[::ffff:87.122.33.193], top=0, retr=0, rcvd=12, sent=39, time=1
    Jan 30 08:58:20 mojo postfix/smtpd[17770]: connect from i577A21C1.versanet.de[87.122.33.193]
    Jan 30 08:58:21 mojo postfix/smtpd[17770]: lost connection after UNKNOWN from i577A21C1.versanet.de[87.122.33.193]
    Jan 30 08:58:21 mojo postfix/smtpd[17770]: disconnect from i577A21C1.versanet.de[87.122.33.193]
     
  15. Till

    Till Administrator

    Der Log Auszug enthält keine Zeilen vom Sendeversuch des Outlook Clients. Versuch bitte nochmal zu senden und schau nachher mal nach, welche Zeilen im Log neu sind.
     
  16. pixeluser

    pixeluser New Member

    Hallo Till,

    Ohne SMTP Auth, da bekomme ich die Testmail von Outlook zurück
    HTML:
    Jan 30 18:32:53 mojo courierpop3login: LOGIN, user=web1_jan, ip=[::ffff:87.122.35.100]
    Jan 30 18:32:55 mojo courierpop3login: LOGOUT, user=web1_jan, ip=[::ffff:87.122.35.100], top=0, retr=3493, rcvd=72, sent=3886, time=2
    Jan 30 18:33:18 mojo courierpop3login: Connection, ip=[::ffff:87.122.35.100]
    Jan 30 18:33:19 mojo courierpop3login: LOGIN, user=web1_jan, ip=[::ffff:87.122.35.100]
    Jan 30 18:33:19 mojo courierpop3login: LOGOUT, user=web1_jan, ip=[::ffff:87.122.35.100], top=0, retr=0, rcvd=12, sent=39, time=0
    Jan 30 18:33:19 mojo postfix/smtpd[26866]: connect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:33:19 mojo postfix/smtpd[26866]: 793FA2D2ADD: client=i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:33:19 mojo postfix/cleanup[27059]: 793FA2D2ADD: message-id=<20080130173319.793FA2D2ADD@mojo.++++.de>
    Jan 30 18:33:19 mojo postfix/qmgr[26832]: 793FA2D2ADD: from=<jan@++++.de>, size=696, nrcpt=1 (queue active)
    Jan 30 18:33:19 mojo postfix/smtpd[26866]: disconnect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:33:19 mojo postfix/pickup[26831]: CBD922D2AE5: uid=10001 from=<web1_jan>
    Jan 30 18:33:19 mojo postfix/cleanup[27059]: CBD922D2AE5: message-id=<20080130173319.CBD922D2AE5@mojo.++++.de>
    Jan 30 18:33:19 mojo postfix/qmgr[26832]: CBD922D2AE5: from=<web1_jan@mojo.++++.de>, size=370, nrcpt=1 (queue active)
    Jan 30 18:33:19 mojo postfix/local[27080]: CBD922D2AE5: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.14, delays=0.1/0.01/0/0.03, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan 30 18:33:19 mojo postfix/qmgr[26832]: CBD922D2AE5: removed
    Jan 30 18:33:26 mojo postfix/local[27061]: 793FA2D2ADD: to=<web1_jan@mojo.++++.de>, orig_to=<jan@pixeluser.de>, relay=local, delay=7.1, delays=0.3/0.01/0/6.8, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan 30 18:33:26 mojo postfix/qmgr[26832]: 793FA2D2ADD: removed
    Jan 30 18:33:36 mojo courierpop3login: Connection, ip=[::ffff:87.122.35.100]
    Jan 30 18:33:36 mojo postfix/smtpd[26866]: connect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:33:36 mojo postfix/smtpd[26866]: lost connection after UNKNOWN from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:33:36 mojo postfix/smtpd[26866]: disconnect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:33:36 mojo courierpop3login: LOGIN, user=web1_jan, ip=[::ffff:87.122.35.100]
    Jan 30 18:33:37 mojo courierpop3login: LOGOUT, user=web1_jan, ip=[::ffff:87.122.35.100], top=0, retr=1165, rcvd=40, sent=1368, time=1
    Email an externe Adresse ohne SMTP Auth:
    HTML:
    Jan 30 18:46:58 mojo postfix/smtpd[26866]: connect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:46:58 mojo postfix/smtpd[26866]: NOQUEUE: reject: RCPT from i577A2364.versanet.de[87.122.35.100]: 554 5.7.1 <jan@+++++.net>: Relay access denied; from=<jan@++++.de> to=<jan@+++++.net> proto=SMTP helo=<MrHiggens>
    Jan 30 18:47:00 mojo postfix/smtpd[26866]: disconnect from i577A2364.versanet.de[87.122.35.100]
    Mit SMTP Auth:

    HTML:
    Jan 30 18:34:58 mojo postfix/smtpd[26866]: connect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:34:58 mojo postfix/smtpd[26866]: lost connection after UNKNOWN from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:34:58 mojo postfix/smtpd[26866]: disconnect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:35 mojo courierpop3login: Connection, ip=[::ffff:87.122.35.100]
    Jan 30 18:35:35 mojo courierpop3login: LOGIN, user=web1_jan, ip=[::ffff:87.122.35.100]
    Jan 30 18:35:35 mojo courierpop3login: LOGOUT, user=web1_jan, ip=[::ffff:87.122.35.100], top=0, retr=0, rcvd=12, sent=39, time=0
    Jan 30 18:35:35 mojo postfix/smtpd[26866]: connect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:35 mojo postfix/smtpd[26866]: lost connection after UNKNOWN from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:35 mojo postfix/smtpd[26866]: disconnect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:53 mojo postfix/smtpd[26866]: connect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:54 mojo postfix/smtpd[26866]: lost connection after UNKNOWN from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:54 mojo postfix/smtpd[26866]: disconnect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:57 mojo courierpop3login: Connection, ip=[::ffff:87.122.35.100]
    Jan 30 18:35:57 mojo postfix/smtpd[26866]: connect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:57 mojo postfix/smtpd[26866]: lost connection after UNKNOWN from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:57 mojo postfix/smtpd[26866]: disconnect from i577A2364.versanet.de[87.122.35.100]
    Jan 30 18:35:57 mojo courierpop3login: LOGIN, user=web1_jan, ip=[::ffff:87.122.35.100]
    Jan 30 18:35:57 mojo courierpop3login: LOGOUT, user=web1_jan, ip=[::ffff:87.122.35.100], top=0, retr=0, rcvd=12, sent=39, time=0
    Mehr gibt das Logfile leider nicht her



    Gruß Jan

    Update Dritte Variante
    HTML:
    Jan 30 18:40:45 mojo postfix/local[27205]: 5C4A42D2AB8: to=<web7_mail@mojo.+++++.de>, orig_to=<mail@####.com>, relay=local, delay=8, delays=0.17/0.01/0/7.8, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan 30 18:40:45 mojo postfix/qmgr[26832]: 5C4A42D2AB8: removed
    Jan 30 18:41:00 mojo postfix/smtpd[26866]: connect from unknown[91.64.31.6]
    Jan 30 18:41:00 mojo postfix/smtpd[26866]: NOQUEUE: reject: RCPT from unknown[91.64.31.6]: 554 5.7.1 <dirk.k****@*****.com>: Relay access denied; from=<mail@####.com> to=<dirk.k****@******.com> proto=SMTP helo=<Pinchy.local>
    Jan 30 18:41:03 mojo postfix/smtpd[26866]: disconnect from unknown[91.64.31.6]
    
     
    Zuletzt bearbeitet: 30. Jan. 2008
  17. pixeluser

    pixeluser New Member

    Mal eine Frage, wie muss die Postfix Master.CF aussehen ?

    HTML:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n       -       -       -       -       smtpd
    #  -o smtpd_enforce_tls=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps     inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #628      inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
            -o fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
    
    So?

    Gruß Jan
     
  18. Till

    Till Administrator

    Dein Outlook sendet keine SMTP Authentifizierung. Du musst in Autlook bei den SMTP Settings einen Haken bei "Server benötigt Authentifizierung " (oder so ähnlich ;) ) machen.

    An der master.cf brauchst Du nichts ändern. Du könntest höcstens die # vor der Zeile smtps weg machen, webb Du auch smtps nutzen möchtest.
     
  19. beta-red

    beta-red New Member

    Danke für Deine Antwort, ich wusel auch auf "Mojo dem Hilfsserver" rum (bin Update Dritte Variante), wir haben 4 Clients probiert, Server benötigt Authentifizierung ist gesetzt.

    Per Webmailer werden Mails an externe Domains verschickt, wenn ich meine IP in die mynetworks eintrage, kann ich auch versenden...

    Meine Vermutung, der smtp auth Dienst findet die User nicht, denn wenn von lokal aus gesendet wird, eh keine Authentifizierung stattfindet, oder?
     
  20. Till

    Till Administrator

    Dem Logfile nach wird die Authentifizierung garnicht erst versucht, d.h. der Client sendet überhaupt keine Aithentifizierungsanfrage an den Server sondern versucht gleich zu senden, was natürlich fehlschlagen muss, sonst wäre der Server falsch (als Open Relay) konfiguriert.

    Lade Dir doch mal den Mailclient Thunderbird portable runter, der funktioniert auch ohne Installation, und teste es damit.
     

Diese Seite empfehlen