Mail Server will nicht funktionieren

M

mike1970

Guest
#1
Hallo,

Mein erstes Posting hier. Ich stehe vor einen wirklich grossen Problem.
Mein Server (Hetzner) Debian 6.0 64 Bit mit ISPConfig 3 will keine Mails annehmen.

was hab ich getan :

1.) Mail Domain angelegt bitandbyte.org
2.) Mail Adresse angelegt und aktiviert ..

darauf ist im webmail folgende mail gekommen ..
Subject: Ihr Mailaccount ist aktiv. From: "ISPConfig" <postmaster@localhost.localdomain>








Wenn ich nun von extern über einen anderen Provider eine Mail an diese Mail schicke kommt diese nicht an ...

Ich vermute mal das beim installieren des Postfix servers etwas schief ging.
Welche Infos braucht Ihr um mir da weiterhelfen zu können ?

lg
Mike

EDIT: wenn ich per Webmail eine Mail an diese Adresse sende, kommt diese auch nicht an.
 
Zuletzt von einem Moderator bearbeitet:
M

mike1970

Guest
#3
Erstens, Vielen Dank für die Antwort!

Der Fehler war wie immer ein PEBCAK oder auch ein Layer 8 Problem :)
Nachdem mir das keine Ruhe gelassen hat, habe ich versucht webmin zu installieren und habe festgestellt das es schon installiert war.

Dann dachte ich das es wohl ein Konflikt zwischen den beiden Tools sein könnte und habe eine debian minimal installation gestartet!

Anschliessend nochmal die Anleitung step by step befolgt
The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Dovecot [ISPConfig 3] - Page 6 | HowtoForge - Linux Howtos and Tutorials

... siehe da, Kunde angelegt, Domain angelegt und Mail funktioniert.
Ich hoffe das bleibt so denn ISPConfig schaut echt gut aus und ist pfeilschnell!

Welchen Spamfilter soll ich auswählen von den vielen die mir angeboten werden ? Was muss ich beachten wenn ich den Server aus Post-Ausgangsserver verwenden will ?

lg

Mike
 

Till

Administrator
#4
Welchen Spamfilter soll ich auswählen von den vielen die mir angeboten werden ?
Ich würde an Deiner Stelle erstmal mit "Normal" starten. Wenn Du dann feststellst dass Dir noch zu viel spam durchkommt, dann kannst Du unter Spamflter > Policy > Normal den "SPAM tag2 level" runter setzen auf z.B. 4.0 oder ich hab bei mir "3.501" gesetzt.

Was muss ich beachten wenn ich den Server aus Post-Ausgangsserver verwenden will ?
- Deine IP-Adresse sollte einen reverse DNS Record bsitzen, der auf den Hostnamen des Servers verweist (kannst Du im hetzner robot selbst setzen).
- Der Hostname Deines Servers sollte im DNS existieren, so dass externe Mailserver ihn auflösen können.
- Im Emailclient muss smtp authentifizierung aktiviert sein, damit sich Dein Mailclient korrekt beim Server anmeldet.
 
M

mike1970

Guest
#5
- Deine IP-Adresse sollte einen reverse DNS Record bsitzen, der auf den Hostnamen des Servers verweist (kannst Du im hetzner robot selbst setzen).
- Der Hostname Deines Servers sollte im DNS existieren, so dass externe Mailserver ihn auflösen können.
- Im Emailclient muss smtp authentifizierung aktiviert sein, damit sich Dein Mailclient korrekt beim Server anmeldet.
Ok super, danke. Das mit den Reverse sollte passen, das hab ich am alten Server bei Strato auch hinbekommen.

Eine Frage noch zum "normal" wo finde ich diese Option mit der "spam tag level 2 " ?
 
M

mike1970

Guest
#6
Eine Frage noch.

Der ganze Server heisst "defcontrol.com" hostname und hostname -f auch. Wenn ich nun eine Mail Domain anlege, und Mail Accounts anlege werden diese nicht zugestellt an den Empfänger.

Welche Logfiles braucht ihr ?

lg
Mike

EDIT: senden funktioniert zwar technisch ohne Fehlermeldung, jedoch erreichen die Mails auch nicht den Emfänger.
 
Zuletzt von einem Moderator bearbeitet:
M

mike1970

Guest
#7
Mail-Warn

Code:
Oct 17 18:15:43 defcontrol postfix/trivial-rewrite[25212]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 18:15:44 defcontrol postfix/trivial-rewrite[25212]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 18:19:02 defcontrol postfix/trivial-rewrite[25373]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 18:54:02 defcontrol postfix/trivial-rewrite[26081]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 18:56:48 defcontrol postfix/trivial-rewrite[26081]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 18:59:02 defcontrol postfix/trivial-rewrite[26081]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 19:20:38 defcontrol postfix/trivial-rewrite[26720]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 19:20:39 defcontrol postfix/trivial-rewrite[26720]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 19:20:39 defcontrol postfix/trivial-rewrite[26720]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 19:21:02 defcontrol postfix/trivial-rewrite[26720]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Oct 17 19:23:00 defcontrol postfix/trivial-rewrite[26720]: warning: do  not list domain defcontrol.com in BOTH mydestination and  virtual_mailbox_domains
Ich denke mal das ist mein Problem, wie löse ich das ?
 

nowayback

Well-Known Member
#8
Ich denke mal das ist mein Problem, wie löse ich das ?
Zitat aus dem Tutorial, welches du verwendet hast:
Now run

echo server1.example.com > /etc/hostname
/etc/init.d/hostname.sh start
du sollst deinen server halt entsprechenend benennen (in deinem Fall z.B.: server1.defcontrol.com) und nicht einfach nur den domain namen (in deinem Fall: defcontrol.com), denn sonst tritt der fehler auf, den du gerade hast :)

Grüße
nwb
 
M

mike1970

Guest
#9
Das heisst diesen Step einfach wiederholen mit einer anderer Eingabe.
Hat das sonst keine Auswirkung auf andere Funktionen, jetzt wo alles so schön läuft :)


lg
Mike
 

Till

Administrator
#10
Du musst den Hostnamen auch in /etc/mailname, /etc/hosts und /etc/postfix/main.cf anpassen, wenn er dort vorkommt und dann postfix neu starten.
 
M

mike1970

Guest
#11
also

echo server.defcontrol.com > /etc/hostname
/etc/init.d/hostname.sh start

.. hab ich gemacht

Nun kann ich zumindest mal damit per Thunderbirtd senden. Jedoch Empfang klappt noch nicht. Bin imo nicht zu Hause kann das von Till erst am Abend testen.

Ich melde mich dann wieder, vielen Dank.

lg
Mike
 
M

mike1970

Guest
#12
Du musst den Hostnamen auch in /etc/mailname, /etc/hosts und /etc/postfix/main.cf anpassen, wenn er dort vorkommt und dann postfix neu starten.

Hallo,

Habs jetzt zusätzlich in der /etc/postfix/main.cf geändert, jetzt funktionierts. Möchte mich für eure super Hilfe bedanken, nettes Forum welches auch mal einen junggebliebenen älteren User leicht verständlich weiter hilft.

Danke sehr!

lg
Mike

EDIT: spart mir 7,90.- / Monat für die Plesk Lizenz (da hätte ich mich besser ausgekannt) :):D
 

Werbung