Mail wird rejected

#1
Mail wird rejected, ClamAV sock wird nich angelegt

EDIT 2: Hat sich alles erledigt!

Bei Fall 1 hing scheinbar noch einiges im DNS-Cache fest, jetzt klappt alles wie erhofft.

Bei Fall 2 habe ich einfach einen Cronjob erstellt der @reboot diesen Symlink anlegt, funktioniert jetzt wunderbar. Sollte man vielleicht mit ins Perfect Server Howto aufnehmen.


Hallo an alle, hoffe Ihr habt Weihnachten gut überstanden.

Ich habe aktuelle ein Problem mit meinen ISPConfig 3 verwalteten Server und meinen Confixx verwalteten Servern und komme überhaupt nicht weiter.

Von meinem ISPConfig 3 Server kann ich E-Mails überall hin versenden, auch auf meine Confixx Server und diese kommen auch an. Auf meinem ISPConfig 3 Server kommen Mails von z.B. Providern wie Arcor oder web.de ohne weiteres an aber wenn ich E-Mails von meinen Confixx Server zu meinen ISPConfig 3 Servern sende erhalte ich folgendes:

Sending failed:
Message sending failed since the following recipients were rejected by the server:
info@xyz.de (The server responded: "5.1.1 <info@xyz.de>: Recipient address rejected: User unknown in virtual alias table")
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport was used:
Hauptmail
info@xyz.de existiert als E-Mailalias. Eine ähnliche Meldung erhalte ich auch wenn ich an irgendetwas@xyz.de eine Mail sende obwohl eine Catchall für xyz.de eingerichtet wurde. Aber nur wenn ich über meine Confixx Server sende.

Jetzt die große Frage... liegt das an meinen Confixx Servern oder ist an den ISPConfig 3 Servern etwas falsch konfuguriert?

Vielen Dank für eure Antworten

EDIT: Was mir noch aufgefallen ist, Falko erwähnt in seinem Perfect Server Howto für openSUSE 12.1 folgendes:

Then create a symlink from /var/run/clamav/clamd to /var/lib/clamav/clamd-socket:


mkdir -p /var/run/clamav
ln -s /var/lib/clamav/clamd-socket /var/run/clamav/clamd


OpenSUSE 12.1 has a /run directory for storing runtime data. /run is now a tmpfs, and /var/run is now bind mounted to /run from tmpfs, and hence emptied on reboot. This means that after a reboot, the directory /var/run/clamav that we have just created will not exist anymore, and therefore clamd will fail to start. Therefore we create the file /etc/tmpfiles.d/clamav.conf now that will create this directory at system startup (see tmpfiles.d for more details):



vi /etc/tmpfiles.d/clamav.conf
D /var/run/clamav 0755 root root -
Jetzt wird zwar nach jedem Neustart das Verzeichnis clamav angelegt aber der clamd Link nicht. Wie kann ich das denn erreichen da tmpfiles.d ja (zumindest finde ich keine) keine Möglichkeit bietet symlinks anzulegen.
 
Zuletzt bearbeitet:

Werbung