mail_user Replication schlägt fehl

#1
Hallo,

habe ein auf openSUSE 13.1 basierendes Multiserver Setup mit ISPC3 3.0.5.4p1 erstellt.

Server 1: Web, DNS, File
Server 2: Mail
Server 3: MySQL

Installation erfolgte, mehr oder weniger nach dem Perfect Server Howto für openSUSE 13.1 und dem Multiserver Setup.

Beim anlegen der E-Mailadressen bekomme ich folgenden Fehler:

Replication failed. Error: (mail_user) in MySQL server: (localhost) Incorrect date value: '' for column 'last_quota_notification' at row 1 # SQL: REPLACE INTO mail_user (`mailuser_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`email`,`login`,`password`,`name`,`uid`,`gid`,`maildir`,`quota`,`cc`,`homedir`,`autoresponder`,`autoresponder_start_date`,`autoresponder_end_date`,`autoresponder_subject`,`autoresponder_text`,`move_junk`,`custom_mailfilter`,`postfix`,`access`,`disableimap`,`disablepop3`,`disabledeliver`,`disablesmtp`,`disablesieve`,`disablesieve-filter`,`disablelda`,`disablelmtp`,`disabledoveadm`,`last_quota_notification`,`backup_interval`,`backup_copies`) VALUES ('1','1','2','riud','riud','','2','gaga@lady.de','gaga@lady.de','$1$GiJ6IUCy$NJbNW/S0DTvZ3NUkSE1.R1','','5000','5000','/var/vmail/lady.de/gaga','0','','/var/vmail','n','0000-00-00 00:00:00','0000-00-00 00:00:00','Out of office reply','','n','','y','y','n','n','n','n','n','n','n','n','n','','none','1')
Die Ordner unter /var/vmail werden auch nicht angelegt. Woran liegt da der Fehler? Hab zwar schon einige Threads im englischen Howtoforge gefunden aber leider keine Antwort hierzu...
 

Till

Administrator
#2
Replikationsfehler treten an sich nur bei ispconfig Versionsuntrschieden auf. Sind master und slave auf dem selben Stand, also selbe ispconfig Version?
 
#3
Also nach Interface ist es alles die 3.0.5.4p1. Habe die tars auch alle über den selben Link runtergeladen.

Habe gerade gesehen das anlegen dieser Mailbox liegt auch noch in der Jobwarteliste... wobei ich annehme das dies korrekt ist weil er einfach diesen Replicationfehler davor hat, oder?
 

Till

Administrator
#4
Habe gerade gesehen das anlegen dieser Mailbox liegt auch noch in der Jobwarteliste... wobei ich annehme das dies korrekt ist weil er einfach diesen Replicationfehler davor hat, oder?
ja, das ist korrekt. versuch mal den Fehler in ispconfig zu bestätigen, indem Du auf den löschen Button hinter der Fehlermeldung clickst. dann warte 1-2 Minuten, erscheint der Fehler dann erneut?
 
#5
ja, das ist korrekt. versuch mal den Fehler in ispconfig zu bestätigen, indem Du auf den löschen Button hinter der Fehlermeldung clickst. dann warte 1-2 Minuten, erscheint der Fehler dann erneut?
Also, er setzt den Fehler erst in den DEBUG Level, dann dauert es etwas (so 2-3 Minuten) und dann taucht der Fehler erneut auf (der "bestätigte" Fehler verschwindet aber nicht)
 

Till

Administrator
#6
Ok. Schau Dir bitte mal die Struktur der mail_user tabelle im master und slave mit phpmyadmin an. fehlen da spalten auf dem slave oder hat eine spalte einen anderen typ?
 
#7
Also, es sind genau 38 Spalten in beiden mail_user Tabellen und dort haben alle den identischen Datentyp (also Master hat in der gleichen Spalte den gleichen wie Slave).

Gut in der vom Master steht halt noch die angelegte Mailadresse drin. Ich weiß echt nicht weiter bei diesem Fehler...
 

Till

Administrator
#8
Welchen datentyp hat die spalte last_quota_notification in beiden datenbantabellen? Ist sie beide maile ein date datentyp?
 
#12
Also dieser Fehler bringt mich echt zum verzweifeln :(

Ich finde absolut keinen Ansatzpunkt an was er liegen könnte und noch weniger wie ich ihn beheben kann. Gibt es von deiner Seite aus noch etwas Till oder kann man dich beauftragen nach diesem Fehler bzw. dessen Behebung zu suchen?
 

Werbung