Mailbox nicht erreichbar

#1
Hallo zusammen,

ich habe gerade auf einem vserver ispconfig 3.0.3 installiert und konfiguriert. Nun habe ich eine Frage zu einer Mailbox, die nicht richtig funktioniert.

Die Mailbox-Domäne hat den gleichen Namen wie der Servernamen. Über die Oberfläche lässt sich diese auch ohne Probleme erstellen. Es wird jedoch nicht die "Willkommensmeldung" zugestellt, auch wird jede Mailzustellung an den Account mit der Meldung abgewiesen, dass der Account nicht existiert. Einen anderen anderen Namen unter der gleichen Domain bringt das gleiche Ergebnis.
Domains die ich zusätzlich auf den Server adressiert haben, funktionieren ohne Probleme, nur die Domain nicht, die mit dem vserver bestellt wurde und auf deren Name der Server auch läuft. Lt. Hoster gibt es keine Umleitungen etc. die den Mailbetrieb verhindern.

Hat mir jemand einen Tipp, was hier falsch läuft.

Danke!
sapro
 

Till

Administrator
#2
Der Servername darf bei postfix niemals gleich einer mailbox domain sein, sonst kann postfix die emails nicht zustellen. Deshalb schreiben wir das ja auch extra im perfect setup guide dass Du server1.example.com nehmen musst und eben nicht example.com.

Öffne die postfix main.cf und ggf. die /etc/mailname Datei und ändere alle vorkommen der Domain von z.B. example.com zu server1.example.com oder einer anderen subdomain.
 
#3
Danke Till!
Die Subdomain für Postfix habe ich völlig überlesen. Jetzt läuft nach erstem Test alles wie gewünscht. Merci!
 
#4
Hi Till,

eine Frage noch zu meiner falschen Konfiguration in postfix.

Nach jedem Update und dem entsprechenden reconfigure der Dienste habe ich wieder meinen ursprünglichen Fehler in main.cf drin.

Wie kann ich den Domainnamen dauerhaft ändern?
 

Till

Administrator
#5
Stell sicher, dass Du den korrekten Hostnamen auch in /etc/hostname stehen hast sowie dass er auch korrekt in /etc/hosts eingetragen ist.
 

Werbung