Mailempfang nach dist-upgrade nicht möglich

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ven0m, 17. Mai 2013.

  1. ven0m

    ven0m New Member

    Hallo,

    ich habe gestern Abend ein dist-upgrade bei debian squezze gemacht.

    Dovecot hatte danach einige Probleme und wollte auch erst mal nicht mehr starten. Die Fehlermeldungen habe ich soweit beheben können und Dovecot lässt sich nun auch wieder ohne Probleme starten.

    Allerdings kann ich seit dem keine Mails mehr empfangen.

    Die postqueue hat sich zwar mittlerweile geleert, allerdings wurden die Mails nicht zugestellt und auch neue Mails können nicht empfangen werden.
    Das versenden von Mails klappt ohne Probleme.

    In der main.cf musste ich noch einen weiter hinzufügen, da ich sonst nur Fehlermeldungen in den logs hatte.
    Habe den wert von virtual_mailbox_limit auf 0 gesetzt.


    Leider bin ich mittlerweile an einem Punkt angelangt an dem ich nicht mehr weiß, wo ich noch nach einem Fehler suchen kann/soll um diesen zu beheben und den Mail Empfang wieder gescheit ans laufen zu bekommen.

    Hier mal meine dovecot.conf
    Code:
    ## ISPConfig3 Template file.
    ## This file was installed by ISPConfig3
    ## It will be replaced if ISPConfig3 is updated.
    
    ## Dovecot configuration file
    base_dir = /var/run/dovecot/
    
    listen = *,[::]
    
    disable_plaintext_auth = no
    log_timestamp = "%Y-%m-%d %H:%M:%S "
    
    # ssl_cert_file = /etc/ssl/_.my-domain.tld/_.my-domain.tld.crt
    # ssl_key_file = /etc/ssl/_.my-domain.tld/_.my-domain.tld.key
    
    ssl_cert = </etc/postfix/smtpd.cert
    ssl_key = </etc/postfix/smtpd.key
    
    mail_privileged_group = mail
    
    login_greeting = ISPConfig3 IMAP server ready...
    
    ## IMAP specific settings
    service imap {
      executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/imap
    }
    
    ## POP3 specific settings
    service pop3 {
      executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/pop3
    }
    
    protocol imap {
      mail_plugins = quota imap_quota
    }
    
    protocol pop3 {
      mail_plugins = quota
      pop3_uidl_format = %08Xu%08Xv
    }
    
    ## LDA specific settings
    protocol lda {
      auth_socket_path = /var/run/dovecot/auth-master
      mail_plugin_dir = /usr/lib/dovecot/modules/lda
      mail_plugins = sieve quota
      postmaster_address = postmaster@my-domain.tld
    }
    
    
    ## Plugin settings
    plugin {
      quota = dict:user::file:/var/vmail/%d/%n/.quotausage
      sieve = /var/vmail/%d/%n/.sieve
    }
    
    
    ## Authentication processes
    
    auth_mechanisms = plain login
    
      # SQL database <doc/wiki/AuthDatabase.SQL.txt>
      passdb {
        args = /etc/dovecot/dovecot-sql.conf
        driver = sql
      }
    
    # new quota support:
    
      userdb {
        driver = prefetch
      }
    
      userdb {
        args = /etc/dovecot/dovecot-sql.conf
        driver = sql
      }
    
    
    protocols = imap pop3
    service auth {
      unix_listener /var/spool/postfix/private/auth {
        group = postfix
        mode = 0660
        user = postfix
      }
      unix_listener auth-master {
        mode = 0600
        user = vmail
      }
    }
    
    
    
    mail_location = maildir:/var/vmail/%d/%n/Maildir
    
    mail_uid = 5000
    mail_gid = 5000
    
    Ich hoffe das mir jemand bei diesem Problem helfen kann.


    Gruß
    ven0m


    Edit:
    Ich habe gerade folgenden Eintrag in den Logs gefunden.
    Code:
    dovecot: lda: Fatal: Plugin 'quota' not found from directory /usr/lib/dovecot/modules/lda
    Leider kann ich dazu nichts finden um dieses Problem in den Griff zu bekommen.
     
    Zuletzt bearbeitet: 17. Mai 2013
  2. nowayback

    nowayback Well-Known Member

    hi,

    "dovecot-mysql" und "dovecot-sieve" haste installiert?
    und nachm upgrade auch ein ispconfig update durchgeführt?
     
  3. ven0m

    ven0m New Member

    dovecot-mysql und dovecot-sieve sind installiert.

    wenn ich ispconfig_update.sh ausführe und dann stable wähle bekomme ich nur die Meldung das die Version aktuell wäre.
     
  4. ven0m

    ven0m New Member

    Kann mir niemand bei diesem Problem helfen?
     
  5. Laubie

    Laubie Member

    Du musst die aktuelle Version von ISPC runterladen, entpacken und das update.php ausführen.
     
  6. ven0m

    ven0m New Member

    @Laubie
    Ich danke dir vielmals!!!! Du bist mein Retter in der Not :)
     
  7. Laubie

    Laubie Member

    kein problem ;)

    Hab ich selber noch nie probiert... es steht aber gefühlte 200mal hier in den Threads ;)
     

Diese Seite empfehlen