Mailfilter funktioniert nicht - Problem mit sieve

#1
Hallo Zusammen,
ich habe eine Domain angelegt und dazu eine Mailbox. Dann noch zwei Aliase die auf die Mail der angelegten Mailbox zeigt. Danach habe ich einen Filter angelegt, bei dem alle E-Mails an den Empfänger webmaster@domain.de in das Verzeichnis Webmaster verschoben werden soll.

Leider klappt das nicht.

Die .sieve log im Mailbox-Verzeichnis schreibt folgendes:
sieve: info: started log at Sep 13 15:52:29.
main_script: line 13: error: unexpected character(s) starting with '`'.
main_script: line 13: error: unexpected unknown characters found at (the presumed) end of file.
main_script: error: parse failed.
.sieve sieht so aus:
require ["fileinto", "regex", "vacation"];


# Move spam to spam folder
if header :contains "X-Spam-Flag" "YES" {
fileinto "Junk";
# Stop here so that we do not reply on spams
stop;
}

### BEGIN FILTER_ID:5

`test -e "$DEFAULT/.Webmaster" && exit 1 || exit 0`
if ( $RETURNCODE != 1 )
{
`maildirmake -f "Webmaster" $DEFAULT`
`chmod -R 0700 "$DEFAULT/.Webmaster"`
`echo "INBOX.Webmaster" >> $DEFAULT/courierimapsubscribed`
}
if (/^To:webmaster@betzepower\.de$/:h)
{
exception {
ID5EndFolder = "$DEFAULT/.Webmaster/"
to $ID5EndFolder
}
}
### END FILTER_ID:5
Wer kann mir da weiterhelfen? Danke im voraus.
 

Till

Administrator
#2
Wie es aussieht hast Du in den server settings als Filter Sprache maildrop anstatt sieve eingestellt. Ändere das mal, dann lösche den Filter und erstelle ihn neu.
 

Werbung

Top