[Mailman] eMail an Liste intern möglich, von Extern nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Der-Tim, 18. Nov. 2013.

  1. Der-Tim

    Der-Tim New Member

    Moin,

    wie der Titel schon sagt, habe ich ein kleines Problem mit Mailman.

    Intern (also vom selben Server) kann ich eMails an die Liste senden - die werden auch verteilt und archiviert, alles sauber.

    Von Extern (also einem anderen Mailserver) bekomme ich folgenden Fehler:

    Nov 18 14:19:24 mailhost postfix/smtpd[13400]: NOQUEUE: reject: RCPT from mout.gmx.net[212.227.17.20]: 550 5.1.1 <liste@lists.domain.net>: Recipient address rejected: User unknown in virtual mailbox table; from=<foobar=123@gmx.tld> to=<liste@lists.domain.net> proto=ESMTP helo=<mout.gmx.net>

    Alias-Files vom Mailman sind aktuell und enthalten entsprechende Einträge.

    Hat jemand 'ne spontane Idee?

    System läuft auf Debian 7.0.1 mit IPv4 und IPv6 (Reverse DNS ist "sauber").

    Danke und G, Tim
     
  2. Laubie

    Laubie Member

    Hi,

    das Problem kenne ich.
    Wann hast du den Server aufgesetzt?

    Es scheint, dass mailman deine Mailadressen mit "listenname@server1.domain.de" anlegt und nicht mit "listenname@meineWunscheomain.de".

    Du kannst eine Weiterleitung von "listenname@meineWunschdomain.de" auf listenname@server1.domain.de im ISPConfig eintragen. Dann sollte es gehen.

    Hatte gehofft, dass dieser Bug behoben ist, da er bei meiner letzten Debian-Installation nicht auftrat, aber vielleicht ist das nur so ein "ab-und-zu" Fehler ;)


    Grüße
    Laubie
     
  3. Der-Tim

    Der-Tim New Member

    Hi Laubie,

    danke für Deine Antwort. Ich habe gerade mal in der DB des Mailservers geschaut (das ist ein Cluster aus einigen ISPConfig Installationen).

    Das Feld "domain" ist mit der korrekten Listendomain gefüllt:

    mysql> select * from mail_mailinglist;
    +----------------+------------+-------------+---------------+----------------+----------------+-----------+-----------------+----------+--------------+----------+
    | mailinglist_id | sys_userid | sys_groupid | sys_perm_user | sys_perm_group | sys_perm_other | server_id | domain | listname | email | password |
    +----------------+------------+-------------+---------------+----------------+----------------+-----------+-----------------+----------+--------------+----------+
    | 2 | 1 | 2 | riud | ru | | 7 | lists.domain.net | Announce | user1@domain1.tld | |
    | 3 | 1 | 3 | riud | ru | | 7 | lists.domain.net | foo | user2@domain1.tld | |
    +----------------+------------+-------------+---------------+----------------+----------------+-----------+-----------------+----------+--------------+----------+
    2 rows in set (0.00 sec)

    Oder habe ich gerade falsch gedacht?

    LG, Tim
     
  4. Der-Tim

    Der-Tim New Member

    Auch Mailman sagt, dass die bevorzugte Domain "lists.domain.net" ist... :confused:
     
  5. Der-Tim

    Der-Tim New Member

    Hi Laubie,

    ich muss Dir Recht geben, es ist genau das von Dir beschriebene Problem.

    eMail an liste@lists.domain.net geht von extern nicht, eMail an liste@mailserver.domain.net (der FQDN) funktioniert ... Unglaublich ...

    Wann ich den installiert habe wolltest Du noch wissen, gelle? Das muss so im Juli 2013 gewesen sein. Ganz genau hab ich das jetzt nicht mehr auf dem Schirm.

    Das Mailforwarding kann ich natürlich einrichten, ist aber ja nicht Sinn und Zweck der Sache, oder? ;-)

    LG, Tim
     
  6. Laubie

    Laubie Member

    Hi Der-Tim,
    komme jetzt erst zum antworten...

    Ja, das ist irgendwie blöd... dann scheint es kein "temporäres" Problem zu sein, sondern eins was sporadisch auftaucht.

    Ich hatte den letzten Server im Januar 2013 mit Mailman aufgesetzt, da funktionierte es perfekt (debian 6).

    Als Workaround klappt das so wie beschrieben natürlich. aber du hast schon recht, perfekt ist das nicht. Vor allem, da ja noch mehrere Adressen bestehen (bounce, ...)

    Vielleicht kann der Author der Mailman-Erweiterung da ncoh mal nach schauen?!?

    Grüße
    Laubie
     
  7. Der-Tim

    Der-Tim New Member

    Ich würde auch selbst draufschauen (und nen Bugfix einreichen), wenn ich nur gerade wüsste, wo ich suchen sollte... Weil in der DB ansich sieht ja alles soweit gut aus. Scheinbar ist das ein Problem, dass Postfix die Adressen nicht als Lokal ansieht (weil er sie scheinbar nicht aus der DB gefischt bekommt)...
     
  8. Laubie

    Laubie Member

    Die DB ist meiner Meinung nach nicht das Problem.
    Das Problem liegt eher in den Dateien welche die Mailman-Erweiterung schreibt bzw. schreiben müsste...
     
  9. derbaumi

    derbaumi New Member

    gleiches Problem - stehe auf dem Schlauch

    Hi,

    habt ihr die Sache in den Griff bekommen? Und wenn ja, wie?
    Ich habe gerade einen neuen Server aufgesetzt, der meinen alten Server (mit ISPcp) ablösen soll. Bei mir ist es genauso mit Mailman. Eine E-Mail an listename@serverFQDN funktioniert, aber an listenname@listendomain leider nicht.

    Vielen Dank und Gruß
    derBaumi
     
  10. derbaumi

    derbaumi New Member

    Workaround

    Also ich habe jetzt mal noch ein bisschen getestet...

    Wenn ich eine Liste in ISPConfig anlege, werden im Pfad /var/lib/mailman/data alle Maps und DBs erneuert. Steht auch überall das richtige drin. Soweit so gut.

    Aus welchem Grund auch immer (ich kann mich nicht erinnern), habe ich auf alle (aliases, transport-mailman und virtual-mailman) nochmal ein postmap ausgeführt und siehe da: Auf einmal kann man auch an listenname@listendomain senden. Jippie :)
    Ich habe das ganze nun insoweit eingegrenzt, dass es ausreicht postmap virtual-mailman auszuführen. Danach klappts.

    Ich habe spaßeshalber auch mal /var/lib/mailman/bin/genaliases ausgeführt. Dabei ist mir aufgefallen, dass die virtual-mailman.db nicht erneuert wird, obwohl alle anderen neu geschrieben werden. Vielleicht hängt das Problem damit zusammen?

    Ich denke ich werde mir jetzt einen Cron einrichten, der ab und an die virtual-mailman neu mapt.
     
  11. derbaumi

    derbaumi New Member

    Anpassungen an Mailman und ISPConfig

    Ich habe noch eine Webseite gefunden, wo jemand ein ähnliches Problem hatte: FS#2867 : No update of mailman-files virtual-mailman and transport-mailman

    Ich habe die /etc/mailman/virtual_to_transport.sh und die /usr/local/ispconfig/server/plugins-available/mailman_plugin.inc.php entsprechend angepasst. Allerdings habe ich in der mailman_plugin.inc.php den Aufruf genaliases auch noch in die function update und function insert rein geschrieben. Dann klappte es auch ohne manuelles Eingreifen.
     
  12. Till

    Till Administrator

    Danke für den Hinweis, ich habe de Thread mal im Bugtracker verlinkt.
     

Diese Seite empfehlen