Mailman erkennt keine EMails

#1
Hallo,

ich hatte es hier schon mal erwähnt, das Mailman bei mir nicht funktioniert. Aber ich denke es ich eher ein Mailman-Config Problem und hat nichts mit ISPConfig zu tun.

Ausgangssituation:

Server läuft auf sub1.domain1.de
Für Mailman habe ich eine eigene Domain eingerichtet: sub2.domain2.de

Weiterhin gibt es noch einen Kunden mit domain1.de

Nach der Installation von Mailman habe ich die Liste 'mailman' angelegt.


Code:
newlist -u sub2.domain2.de -e sub2.domain2.de mailman
Die Begrüßungsmail wird anschließend auch zugestellt.

Danach habe ich eine Maillist in ISPConfig angelegt. Auch hier erhalte ich die Begrüßungsmail.

Manuell musste ich nur
Code:
 postmap /var/lib/mailman/data/virtual-mailman
aufrufen.

Wenn ich an die neu erstellte Liste z.B. eine liste-request Email sende, wird diese an root bzw an meine dazugehörige alias-Adresse zugestellt.
Es scheint als wenn Mailman die EMail garnicht "erhält"

Wo kann denn hier der Fehler liegen?
 
Zuletzt bearbeitet:
#2
Ich habe nochmal alles durchgeschaut.

Es gabe einen eintrag als Catch-All-Adresse und die serverdomain existierte in ispconfig.

Habe diese Einträge alle gelöscht und Mailman neu installiert.

Jetzt habe ich das Problem, dass Mailman sine eigene Domain nicht erkennt.

Eine Mail an mailman-request@sub.domain.de

führt zu einer Undelivered Mail.
 
#3
Habe die den Fehler gefunden.

Ich hatte noch einen Fehler in meinen EMail-Aliases in ISPConfig.

Nun läuft alles so weit und die Liste funktioniert.

Allerdings habe ich einen merkwürdigen Eintrag in meiner main.cf

Code:
myhostname = sub.domain.de
und ich musste folgenden Eintrag machen

Code:
mydestination = localhost, localhost.localdomain, sub.domain.de
ansonsten hatte ich folgenden Fehler bekommen:
Code:
mail for sub.domain.de loops back to myself
Ich dachte der Eintrag in myhostname darf nicht in mydestination erscheinen?
 

Werbung

Top