Mailman-Integration nicht sinnig?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von win_tho, 11. Feb. 2012.

  1. win_tho

    win_tho Member

    Hallo zusammen,

    habe mich heute Mittag nun einmal daran gemacht, die Mailinglisten auf meinem Server (Debian 6 + ISPC 3.0.4) komplett zum Laufen zu bekommen. Die eigentlichen Listen funktionierten schon tadellos, nur mit dem Webinterface gab es noch Probleme.

    Direkt nach dem Anlegen der Liste erhält der Admin eine Mail mit diversen Links. Diese haben alle die Form:

    http://email-domain.de/cgi-bin/mailman/....

    Problem dabei ist nun, dass das Webfrontend unter dieser URL nicht aufrufbar ist. Till sagte dazu in einem anderen Thread:

    Da es für den "normalen" Kunden nur schwer vermittelbar ist, dass Links, die ihm per Mail zugeschickt werden, fallsch sind, habe ich etwas geforscht, woher diese Links kommen.

    Alle Anpassungen in der /usr/local/ispconfig/server/conf/mm_cfg.py.master zeigen nur bedingt Wirkung, das ISPC die Listen mit folgendem Befehl anlegt:

    PHP:
    exec("/usr/lib/mailman/bin/newlist -u ".escapeshellcmd($data["new"]["domain"])." -e ".escapeshellcmd($data["new"]["domain"])." ".escapeshellcmd($data["new"]["listname"])." ".escapeshellcmd($data["new"]["email"])." ".escapeshellcmd($data["new"]["password"])."");
    Der parameter -u sorgt dafür, dass die aktuelle E-Mail-Domain als Web-Domain in die Listen einstellungen eingetragen wird. Somit gibt es keine Chance, gleich nur auf die Haupt-Server URL zu linken. Lässt man diesen Parameter weg, kommen die Mails gleich richtig.

    ------

    Da es mir aber eigentlich nicht gefallen hat, und ich mailman für jeden vhost aktiv haben wollte, habe ich noch etwas weitergeforscht. Mailman für jeden vhost ist relativ einfach über

    Code:
    [COLOR=#000000]ln -s /etc/mailman/apache.conf /etc/apache2/conf.d/mailman.conf[/COLOR]
    zu erreichen. Das funktioniert auch wunderbar, solange für den jeweiligen vhost suExec nicht aktiv ist. Ansonsten erhällt man nur den Fehler:

    Ich verfahre jetzt zunächst nach Variante zwei und deaktiviere suexec für den jeweiligen vhost, da im konkreten Fall sowieso keine CGI Script gebraucht werden.

    Würde mich freuen, wenn das Anlegen der Listen in den zukünftigen Versionen etwas intuitiver ist. Entweder müsste man die Mails gleich mit dem Hostname des Servers versenden, oder /mailman müsste für jeden Vhost aktiv sein.
     
  2. Till

    Till Administrator

    Ich schau mir das mal an.

    Suexec bauchst Du auch für die PHP Modi cgi und fcgi, falls Du in DEinen Seiten CMS Systeme wie Joomla/Typo3/Wordpresss etc. verwendest, insbesondere auch aus Sicherheitsgründen.
     

Diese Seite empfehlen