Mailman-Konfiguration

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von klicki, 7. Juli 2014.

  1. klicki

    klicki New Member

    Hi,

    momentan versuche ich Mailman unter Ubuntu 14.04 einzurichten. Ich kann Listen mit ISPconfig anlegen, aber der Email-Austausch klappt noch nicht.

    Wenn ich in /var/log/mailman/smtp-failure schaue, sehe ich, dass jeweils ein "Relay access denied" kommt. Per Webmail kann ich aber Emails von dem Server senden und empfangen.

    Wenn ich an die Liste sende, sagt mir schon der Client: "Recipient address rejected: User unknown in virtual mailbox table" In der Nutzertabelle mail_user stehen die Namen der Listen tatsächlich nicht drin. Ist das in Ordnung?

    Die Tabelle mail_transport war bei mir leer. Ich habe meine Domain dort nachgetragen. In früheren Versionen von Mailman musste man ja "lists" vor den Domain-Namen setzen. Ist das immer noch so?

    Gruß
    Carsten
     
  2. Till

    Till Administrator

    Ja, das ist richtig. Mailman verwaltets eine Adressen separat in Konfigurationsdateien.

    Dann nimm sie dort mal wieder raus. In mail_transport dürfen keine lokalen Domains drin stehen, also keine Domains die Du für Postfächer oder Mailman verwenden willst.

    Wie hast Du denn Mailman installiert? So wie im perfect server Ubuntu 14.04 beschrieben? Und hast Du es auch vor ispconfig installiert, denn sonst wird es nicht funktionieren da es nicht durch den ISPConfig Installer konfiguriert wurde.
     
  3. klicki

    klicki New Member

    Habe ich entfernt. Trotzdem nimmt er noch keine Emails von extern an. Einen Abonnenten vom gleichen Server hat er aber jetzt akzeptiert.
    Ich hatte das nach Anleitung unter Ubuntu 13.04 installiert und dann einen Update von ISPconfig und vom Ubuntu auf die aktuellen Versionen gemacht. Alles andere läuft, so weit ich das übersehen kann. Mailman zickt weiter. Emails an den Verteiler werden nicht abgearbeitet. Lediglich ein "help" an list-request@domain.de von einer internen Adresse aus wurde umgesetzt. (Allerdings kam der Email-Inhalt doppelt.)

    Sollte ich die Software noch einmal installieren und konfigurieren? :confused:
     
  4. Till

    Till Administrator

    Schau am Besten mal ins 14.04 tutorial und führe allte installationsschritte des email kapitels nochmal aus, dann lade ispconfig runter, entpacke es, geh ins install Verzeichnis und führe das update.php script aus. Wähle beim Update aus dass Du die Dienste rekonfigurieren möchtest.
     
  5. klicki

    klicki New Member

    Hi

    den ganz harten Weg der Rekonfiguration konnte / wollte ich vermeiden, weil dann möglicherweise andere Dinge ins Rutschen gekommen wären, die nun mühsam funktionieren. Ich habe es aber hin bekommen! Der letzte Fehler, der zu Loops geführt hatte, wurde hier erklärt. Vielen Dank dafür!

    Mailman scheint jetzt wie vorgesehen zu arbeiten. Jippie! :)

    P.S.: Das Skript am Ende der 14.04 Anleitung war sehr wertvoll! Bei mir haben Pakete nach dem Update auf 14.04 gefehlt. Einige wirre Fehler aus anderen Bereichen sind jetzt verschwunden.
     
    Zuletzt bearbeitet: 8. Juli 2014

Diese Seite empfehlen