Mailproblem: The Perfect Server – OpenSUSE 11.1 [ISPConfig 3]

#1
Hallo!

Ich hab mir letzte Woche den perfekten Server eingerichtet und war sehr überrascht, wie schnell man mit ISPConfig 3 einen echt guten, leistungsfähigen Server aufsetzen kann, der auch richtig gut funktioniert! ;)

Allerdings habe ich ein Problem mit der Mailkonfiguration, zudem ich hier bisher leider nichts brauchbares finden konnte. :(

Ich kann Maildomains einrichten und mich mit den erstellten Mailboxen auch im webmail einloggen. Der Versand über das Webfrontend funktioniert tadellos, allerdings kann ich keine Mails empfangen und auch der Versand über einen externen client funktioniert leider nicht.

Im Mail Error Protokoll steht folgendes:
Code:
Jan 17 23:16:02 host imapd: Failed to create cache file: maildirwatch (name@domain.de)
Jan 17 23:16:02 host imapd: Error: Input/output error
Jan 17 23:16:02 host imapd: Check for proper operation and configuration
Jan 17 23:16:02 host imapd: of the File Access Monitor daemon (famd).
kann damit jemand was anfangen, bzw. mir sagen, was da schief läuft!?!?


thx.
gruss Dieter
 
#3
Hi Till,

danke für die schnelle Antwort.
Die SMTP Authentifizierung ist eingeschaltet, das Passwort wird bei der Anmeldung aber nicht akzeptiert.
Allerdings ist der Mailversand zwar ein Problem, das große Problem ist aber, das mir keine zugestellt werden. Sprich, ich kann zwar emails an die Mailboxen verschicken, die Mails kommen aber nie an. (Weder im Webmail, noch extern).
 

Till

Administrator
#4
Log dich bitte mal lokal auf dem Server ein und schick Dir dann an den selben account vom webmail aus eine Nachricht und poste die Meldungen, die dann im mail log erscheinen.
 
#5
oh Mann, das ist mal wieder voll der Vorführ-Effekt. Jetzt geht’s... (!?)
Der Mailversand von extern tut noch immer nicht, ich kann aber welche erhalten.

Wieso kann ich den SMTP-Server nicht von extern erreichen? Verwendet der einen ungewöhnlichen Port oder was mach ich da falsch!?
Hier die letzte Fehlermeldung aus dem Mailerror Log:

Code:
Jan 18 11:54:05 vz402 imapd: Failed to create cache file: maildirwatch (name@domain.tld)
Jan 18 11:54:05 vz402 imapd: Error: Input/output error
Jan 18 11:54:05 vz402 imapd: Check for proper operation and configuration
Jan 18 11:54:05 vz402 imapd: of the File Access Monitor daemon (famd).
...ach ja, die Systemzeit geht auch nach´m Mond. Muss ich da beim ntp auch noch was spezielles definieren?
 
#7
Alles klar, hier die Ausgaben:

Code:
tcp        0      0 *:smtp                  *:*                     LISTEN      5522/master
und iptables:

Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
 

Till

Administrator
#8
Ok, daran liegt es also nicht. Ist Dein Server in einem Rechenzentrum oder an einer (A/S)DSL Leitung angeschlossen? Ist davor ein router?
 
#9
Der Server steht (als vServer) in einem Rechenzentrum. Also kein DSL Router oder sowas dazwischen.
Als Firewall ist nur die ISPConfig interne aktiviert, freigegeben sind die Standard Ports.
 

Till

Administrator
#10
Hmmm, der SMTP Server müsste definitiv von extern zu erreichen sein, da er auf allen Interfaces lauscht und auf dem Server keine Firewall aktiv ist. Kann es vielleicht sein dass der Internetprovider, über den Du mit Deiner Workstation ins internet gehst, irgendwie keine SMTP Verbindungen zu beliebigen Servern zulässt? Denn an Deinem ISPConfig Server scheint soweit alles ok zu sein. Poste doch bitte mal die IP oder den Hostnamen des Servers, so dass ich die mal testen kann.
 
#11
Hi Till,

ich hoffe, du hast vergangene Woche meine PN bekommen!?
Leider bin ich noch immer nicht weiter. :(

Das zweite Problem steht auch schon an, möchte ich aber erst aufgreifen, wenn das Mailproblem gelöst ist.

gruss diehard
 

Till

Administrator
#12
Der SMTP Server ist von extern erreichbar. Dann solltest Du also mal die DNS Records der Domain überprüfen (A,CName und MX), ob die auch wirklich auf Deinen Server zeigen.
 

Till

Administrator
#14
Logge Dich bitte mal im webmail ein und sende eine email an die gleiche Email Adresse, mit der Du dich eingeloggt hast. Dann warte mal eine Minute und aktualisiere webmail. Kommt diese Email wieder im Konto an oder nicht? Wenn nicht, schau ins mail log und poste alle Zeilen, die bei diesem Test hinzugekommen sind.
 
#15
Also, übers Webmail klappt das ganz prima. Die Mail kam unverzüglich an. ;)

Aber über den externen client fragt er das Passwort ab, akzeptiert aber das Passwort des Mailaccounts nicht. :(
 

Till

Administrator
#16
Ok. Dann ist Dein mailsystem schonmal ok und es liegt nur ein Problem mit sasl vor. Dann poste bitte die Exakten Meldungen, die bei der fehlgeschlagenen Authentifizierung ins mail log geschrieben werden.
 
#17
Hi Till,

hier das Protokoll:

Code:
Feb 2 21:28:29 vz402 postfix/smtpd[11277]: warning: connect to private/tlsmgr: No such file or directory
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: warning: connect to private/tlsmgr: No such file or directory
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: warning: problem talking to server private/tlsmgr: No such file or directory
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: warning: no entropy for TLS key generation: disabling TLS support
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: connect from xxx [xx.xxx.xxx.xxx]
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: warning: SASL authentication failure: Password verification failed
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: warning: xxx [xx.xxx.xxx.xxx]: SASL PLAIN authentication failed: authentication failure
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: lost connection after AUTH from xxx [xx.xxx.xxx.xxx]
Feb 2 21:28:30 vz402 postfix/smtpd[11277]: disconnect from xxx[xx.xxx.xxx.xxx]
Feb 2 21:28:33 vz402 postfix/smtpd[11277]: connect from xxx[xx.xxx.xxx.xxx]
Feb 2 21:28:34 vz402 postfix/smtpd[11277]: warning: SASL authentication failure: Password verification failed
Feb 2 21:28:34 vz402 postfix/smtpd[11277]: warning: xxx[xx.xxx.xxx.xxx]: SASL PLAIN authentication failed: authentication failure
Feb 2 21:28:34 vz402 postfix/smtpd[11277]: lost connection after AUTH from xxx[xx.xxx.xxx.xxx]
Feb 2 21:28:34 vz402 postfix/smtpd[11277]: disconnect from xxx[xx.xxx.xxx.xxx]
Feb 2 21:28:59 vz402 imapd: Failed to create cache file: maildirwatch (mail@domain.de)
 

Werbung

Top