Mailprobleme

#1
Mailprobleme [DONE]

Ich habe Probleme mit dem Mail Empfang.

Grob zusammengefasst:
vServer mit Debian Etch 64 Bit.
Frisch aufgesetztes ISPConfig.

Mail-Log:
Code:
Nov 28 17:59:17 host postfix/qmgr[1870]: warning: private/amavis socket: malformed response
Nov 28 17:59:17 host postfix/qmgr[1870]: warning: transport amavis failure -- see a previous warning/fatal/panic logfile record for the problem description
Nov 28 17:59:17 host postfix/master[31471]: warning: process /usr/lib/postfix/smtp pid 1871 exit status 1
Nov 28 17:59:17 host postfix/master[31471]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
Nov 28 17:59:17 host postfix/master[31471]: warning: process /usr/lib/postfix/smtp pid 1872 exit status 1
Nov 28 17:59:17 host postfix/qmgr[1870]: 061CF1FFCAC5: to=, orig_to=, relay=none, delay=11849, delays=11848/1.3/0/0, dsn=4.3.0, status=deferred (unknown mail transport error)
Nov 28 17:59:17 host postfix/qmgr[1870]: warning: connect to mysql server 78.46.202.32: Access denied for user 'ispconfig'@'host.newbi.org' (using password: YES)
Nov 28 17:59:17 host postfix/qmgr[1870]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
Nov 28 17:59:18 host postfix/master[31471]: warning: process /usr/lib/postfix/qmgr pid 1870 exit status 1
Nov 28 17:59:19 host postfix/proxymap[29072]: warning: connect to mysql server 78.46.202.32: Access denied for user 'ispconfig'@'host.newbi.org' (using password: YES)
Nov 28 17:59:19 host postfix/proxymap[29072]: warning: connect to mysql server 78.46.202.32: Access denied for user 'ispconfig'@'host.newbi.org' (using password: YES)
Nov 28 17:59:19 host postfix/trivial-rewrite[1917]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Nov 28 17:59:20 host postfix/master[31471]: warning: process /usr/lib/postfix/trivial-rewrite pid 1917 exit status 1
Nov 28 17:59:20 host postfix/master[31471]: warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling
Nov 28 17:59:20 host postfix/smtpd[29071]: warning: premature end-of-input on private/rewrite socket while reading input attribute name
Nov 28 17:59:20 host postfix/smtpd[29071]: warning: problem talking to service rewrite: Success
Nov 28 18:00:01 host postfix/anvil[27763]: statistics: max connection rate 1/60s for (smtp:78.46.202.32) at Nov 28 17:50:04
Nov 28 18:00:01 host postfix/anvil[27763]: statistics: max connection count 1 for (smtp:78.46.202.32) at Nov 28 17:50:04
Nov 28 18:00:01 host postfix/anvil[27763]: statistics: max cache size 2 at Nov 28 17:50:04
Freshclam - Log:
Code:
--------------------------------------
Received signal: wake up
ClamAV update process started at Fri Nov 28 17:41:54 2008
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.94.1 Recommended version: 0.94.2
DON'T PANIC! Read http://www.clamav.net/support/faq
main.cvd is up to date (version: 49, sigs: 437972, f-level: 35, builder: sven)
daily.cvd is up to date (version: 8693, sigs: 31234, f-level: 38, builder: mcichosz)
--------------------------------------
Wenn ich was vergessen habe, einfach sagen / fragen.

Danke für eure Hilfe

MfG
Newbi
 
Zuletzt bearbeitet:
#2
So nach einer menge googellei und einigen anderen Tipps, bin ich nun soweit gekommen:

Mail-err.log:
Code:
IST LEHR
Mail-warn.log:
Code:
Nov 30 07:45:07 host amavis[4138]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:18:27 host amavis[31601]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:18:27 host amavis[31601]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:18:27 host amavis[13800]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:35:07 host amavis[31601]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:35:07 host amavis[13800]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:35:07 host amavis[31601]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:35:07 host amavis[31601]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Nov 30 08:36:11 host postfix/smtpd[32349]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Nov 30 08:36:11 host postfix/smtpd[32349]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Nov 30 08:36:11 host postfix/smtpd[32349]: warning: SASL authentication failure: no secret in database
Nov 30 08:36:11 host postfix/smtpd[32349]: warning: 124-8-108-193.dynamic.tfn.net.tw[124.8.108.193]: SASL CRAM-MD5 authentication failed: authentication failure
Nov 30 08:36:52 host postfix/smtpd[32349]: warning: SASL authentication failure: need authentication name
Nov 30 08:36:52 host postfix/smtpd[32349]: warning: 124-8-108-193.dynamic.tfn.net.tw[124.8.108.193]: SASL CRAM-MD5 authentication failed: bad protocol / cancel
Nov 30 08:51:47 host amavis[31601]: (!) DENIED ACCESS from IP 78.46.202.32, policy bank ''
Weiter bin ich noch nicht gekommen.

Wenn jemadn eine Idee oder so hat, immer her damitt, bin für alles dankbar.
 
#3
Oft ist es nur ein einfacher Fehler z.B. wurden bei mir einmal keine Dienste gestartet außer SSH, FTP, Apache und ein paar andere aber alles andere nicht. Ich würde einfach mal das Gerät neustarten oder/und alle Daemons wie Postfix etc. hat bei mir mehr als einmal gut geklappt.
 
#4
AEG (Auschlaten - Einschalten - Geht wieder), hat bei mir leider nicht gefruchtet.

Hier mail EIn Auszug aus dem Mail-Quere:

Code:
8A5F91FFCB9B     1723 Fri Nov 28 18:07:02  root@****
(delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)
                                         root@host.newbi.org

8BC451FFCBA3     1018 Sat Nov 29 11:46:32 ****@gmx.net
(delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)
                                         test@newbi.org

B20AF1FFCBA4     1018 Sat Nov 29 10:34:01 ****@gmx.net
(lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)
                                         test@newbi.org
 
#5
Code:
lost connection with 127.0.0.1[127.0.0.1]
Ich denke das ist das Problem. Er versucht eine Mail an 127.0.0.1 zu senden. Bei mir ist an dieser stelle immer eine IP.

Warum das so ist weiß ich auch nicht, mal goooogeln ;) Ich meld mich wenn ich mehr weiß....
 
#6
So, anscheinend haut nu alles, noch die ein oder andere Anpassung der Configs und ich sollte alle Fehler nach und nach wegbekommen.

Danke hier an Timmersen2004, der mit seinem Hinweis den richtigen Denkprozess angestoßen hat.

Ich denke man mal, das ich bis heute Abend alle Fehler weg haben müsste, sollte es noch was geben, werde ich hier entsprechend posten.

MfG
Newbi
 
#7
Irgendwie habe ich mich jetzt bei folgendem Problem festgefahren:

Code:
Dec  8 22:30:57 host postfix/master[14815]: daemon started -- version 2.3.8, configuration /etc/postfix
Dec  8 22:32:55 host postfix/smtpd[15258]: connect from mail.gmx.net[213.165.64.20]
Dec  8 22:32:56 host postfix/smtpd[15258]: 147741AB8BD0: client=mail.gmx.net[213.165.64.20]
Dec  8 22:32:56 host postfix/cleanup[15273]: 147741AB8BD0: message-id=<20081208213253.19940@gmx.net>
Dec  8 22:32:56 host postfix/qmgr[14820]: 147741AB8BD0: from=<*****@gmx.net>, size=1359, nrcpt=1 (queue active)
Dec  8 22:32:56 host postfix/smtpd[15258]: disconnect from mail.gmx.net[213.165.64.20]
Dec  8 22:32:57 host postfix/smtpd[15279]: connect from localhost.localdomain[127.0.0.1]
Dec  8 22:32:57 host postfix/smtpd[15279]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 554 5.7.1 <test@*****.org>: Recipient address reject$
Dec  8 22:32:57 host amavis[14343]: (14343-01) (!) mail_via_smtp: DATA skipped, no valid recips, 0
Dec  8 22:32:57 host postfix/smtpd[15279]: disconnect from localhost.localdomain[127.0.0.1]
Dec  8 22:32:57 host amavis[14343]: (14343-01) (!) FWD via SMTP: <*****@gmx.net> -> <test@*****i.org>, BODY=8BITMIME 554 5.6.0 Failed, id=14343-01, fro$
Dec  8 22:32:57 host postfix/smtpd[15279]: connect from localhost.localdomain[127.0.0.1]
Dec  8 22:32:57 host postfix/smtpd[15279]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 554 5.7.1 <*****@gmx.net>: Recipient address r$
Dec  8 22:32:57 host amavis[14343]: (14343-01) (!) mail_via_smtp: DATA skipped, no valid recips, 0
Dec  8 22:32:57 host postfix/smtpd[15279]: disconnect from localhost.localdomain[127.0.0.1]
Dec  8 22:32:57 host amavis[14343]: (14343-01) (!) SEND via SMTP: <> -> <*****@gmx.net>, ENVID=AM..20081208T213257Z@host.*****.org 554 5.6.0 Failed, i$
Dec  8 22:32:57 host amavis[14343]: (14343-01) (!) NOTICE: UNABLE TO SEND DSN to <*****@gmx.net>: 554 5.7.1 Failed, id=14343-01, from MTA([127.0.0.1]:$
Dec  8 22:32:57 host amavis[14343]: (14343-01) Blocked CLEAN, [213.165.64.20] [87.122.1.189] <*****@gmx.net> -> <test@newbi.org>, Message-ID: <2008120$
Dec  8 22:32:57 host postfix/smtp[15275]: 147741AB8BD0: to=<test@*****.org>, relay=**.46.202.32[**.46.202.32]:10024, delay=1.1, delays=0.5/0.01/0.01/0.61, d$
Dec  8 22:32:57 host postfix/cleanup[15273]: 1506D1AB8BD2: message-id=<20081208213257.1506D1AB8BD2@host.*****.org>
Dec  8 22:32:57 host postfix/qmgr[14820]: 1506D1AB8BD2: from=<>, size=3474, nrcpt=1 (queue active)
Dec  8 22:32:57 host postfix/bounce[15280]: 147741AB8BD0: sender non-delivery notification: 1506D1AB8BD2
Dec  8 22:32:57 host postfix/qmgr[14820]: 147741AB8BD0: removed
Dec  8 22:32:57 host postfix/smtp[15283]: 1506D1AB8BD2: to=<*****@gmx.net>, relay=mx0.gmx.de[213.165.64.100]:25, delay=0.15, delays=0.02/0.01/0.03/0.0$
Dec  8 22:32:57 host postfix/qmgr[14820]: 1506D1AB8BD2: removed
Bin für jede Hilfe dankbar.
 
Zuletzt bearbeitet:

Till

Administrator
#10
Also, es gibt 2 komplett unetschiedliche Versionen von ISPConfig, ISPConfig 2 und ISPConfig 3. Für beide gibt es eine aktuelle Trunk Version.
 
#12
Hat denn keiner eine Lösung, oder gibt es Grundsätzlich keinen Support für die 3 Version ??

Würde mich halt echt freuen, wenn mir jemand helfen könnte.

Wird denn die 2 Version immernoch weiter entwickeltet ??
 

Werbung

Top