Mails in mailque und amavis fehlermeldung

#1
Hallo zusammen,

ich habe gerade gesehen, dass ich mehrere mails in der queue habe. Gefunden habe ich diese Meldung:

Code:
Jun  4 15:19:37 titan amavis[2218]: (02218-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;port=3306': Access denied for user 'ispconfig'@'127.0.0.1' (using password: YES)
Jun  4 15:19:37 titan amavis[2218]: (02218-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 111) line 247.
Jun  4 15:19:37 titan amavis[2218]: (02218-01) (!)Requesting process rundown after fatal error
Allerdings kann ich mich ohne Probleme mit dem user ispconfig local anmelden.

postfix Log

Code:
Jun  4 15:35:06 titan postfix/smtpd[7521]: connect from mout.web.de[212.227.15.14]
Jun  4 15:35:06 titan postfix/smtpd[7521]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Jun  4 15:35:06 titan postfix/smtpd[7521]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
Jun  4 15:35:06 titan postfix/smtpd[7521]: NOQUEUE: reject: RCPT from mout.web.de[212.227.15.14]: 451 4.3.5 <mout.web.de[212.227.15.14]>: Client host rejected: Server configuration error; from=<@...> to=<mail@...> proto=ESMTP helo=<mout.web.de>
Jun  4 15:35:06 titan postfix/smtpd[7521]: disconnect from mout.web.de[212.227.15.14]
 
Zuletzt bearbeitet:

Till

Administrator
#2
Hast Du Dich beim test auch über localhost angemeldet und nicht ggf. ohne angabe des hosts? Versuch es mal mit:

mysql -h localhost -u ispconfig -p dbispconfig

und dann das Passwort des ispconfig Users angeben.
 
#3
Ok, ich denke ich habe den Fehler gefunden:

Code:
additional_conditions = and active = 'y' and server_id = 1
Ich hatte vor kurzem meinen ISPConfig Mirror-Server aufgelöst.
In der mysql-Conf war der Eintrag server_id = 1 auskommentiert. Das scheint den Fehler zu verursachen.

Nachdem ich den Eintrag server_id = 1 in die my.cnf hinzugefügt habe, wurden alles Mails versendet.
 
#4
zu früh gefreut.

Code:
Jun  4 15:50:49 titan postfix/trivial-rewrite[9377]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
Jun  4 15:50:49 titan postfix/trivial-rewrite[9377]: warning: relay_domains lookup failure
Jun  4 15:50:49 titan postfix/trivial-rewrite[9377]: warning: mysql:/etc/postfix/mysql-virtual_relaydomains.cf: table lookup problem
und

Code:
Jun  4 15:55:57 titan postfix/trivial-rewrite[9474]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
/var/run/mysqld/mysqld.sock ist vorhanden und die Rechte stimmen

@till

Ja, das klappt.
 
Zuletzt bearbeitet:
#5
Der Fehler scheint jetzt auch behoben zu sein.

Durch einen alten Forumeintrag hatte ich

Code:
hosts = 127.0.0.1
auf

Code:
hosts = localhost
geändert.

Das habe ich jetzt rückgängig gemacht und nun können auch Mails wieder empfangen werden.
 

Werbung

Top