Mails senden

#1
Hallo,

Ich habe hier einen vServer mit ISPConfig 3.0.1 laufen (endlich weg von Plesk und seinen Fesseln!).
Weil die Dienste viel zu viel RAM gefressen haben, habe ich clamavd, freshclam und spamassassin (brauche ich alle drei nicht) einfach aus dem Verzeichnis /etc/init.d entfernt. Sie starten auch nicht mehr, RAM-Auslastung ist fast halbiert, sehr schön ;-). Gibt es da einen "offiziellen" Weg, die Dienste zu deaktivieren oder macht das sonstige Probleme (bisher keine festgestellt)?

Auf meinem Mailserver kann ich per IMAP ganz normal Mails empfangen (sogar über SSL), allerdings ist das Senden für Thunderbird eine unüberwindliche Hürde.
Gibt es da bekannte Probleme oder einen Hebel, an dem ich drehen muss? Im Mail-Log sehe ich keine Hinweise, muss ich woanders gucken oder wollt ihr es trotzdem sehen? Es scheint mir so, dass Thunderbird schon nicht bis zum Server kommt, es also kein Sendeproblem an sich ist, sondern eher ein Übertragungsproblem...

Danke für alle Hinweise und das wundervolle Tool (das sogar sehr gut aussieht, sehe ich selten bei OSS :)),
forgist
 
#2
Hallo,

Ich habe hier einen vServer mit ISPConfig 3.0.1 laufen (endlich weg von Plesk und seinen Fesseln!).
Weil die Dienste viel zu viel RAM gefressen haben, habe ich clamavd, freshclam und spamassassin (brauche ich alle drei nicht) einfach aus dem Verzeichnis /etc/init.d entfernt. Sie starten auch nicht mehr, RAM-Auslastung ist fast halbiert, sehr schön ;-). Gibt es da einen "offiziellen" Weg, die Dienste zu deaktivieren oder macht das sonstige Probleme (bisher keine festgestellt)?
Der offical Weg ist -> apt-get remove --purge $paket
bzw aptitude remove .....

Auf meinem Mailserver kann ich per IMAP ganz normal Mails empfangen (sogar über SSL), allerdings ist das Senden für Thunderbird eine unüberwindliche Hürde.
Gibt es da bekannte Probleme oder einen Hebel, an dem ich drehen muss? Im Mail-Log sehe ich keine Hinweise, muss ich woanders gucken oder wollt ihr es trotzdem sehen? Es scheint mir so, dass Thunderbird schon nicht bis zum Server kommt, es also kein Sendeproblem an sich ist, sondern eher ein Übertragungsproblem...

Danke für alle Hinweise und das wundervolle Tool (das sogar sehr gut aussieht, sehe ich selten bei OSS :)),
forgist
Bzgl dem zum Server kommen, du kannst die beste Hilfe bekommen wenn du mal versuchst eine e-Mail via Thunderbird / Outlook oder whaterver zu senden. Anschließend gehst du in die Datei /var/log/mail.log und schaust mal was dort in den untersten Zeilen drin steht. Wenn es Probleme gibt werden diese dort idR sehr detailliert geloggt und man kann dir schreiben wo du drehen musst, wenn du hier die auszüge des Logs postest ;)
Gruß Sven
 
#3
Danke für die Antwort, das Log ist in der Tat gut:

Zitat von /var/log/mail.log:
Mar 30 14:46:59 localhost postfix/smtpd[12095]: connect from dslb-{ip}[{ip}]
Mar 30 14:47:05 localhost postfix/smtpd[12095]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or dire$
Mar 30 14:47:05 localhost postfix/smtpd[12095]: warning: SASL authentication failure: Password verification failed
Mar 30 14:47:05 localhost postfix/smtpd[12095]: warning: dslb-{ip}[{ip}]: SASL PLAIN authentication faile$
Mar 30 14:47:05 localhost postfix/smtpd[12095]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or dire$
Mar 30 14:47:05 localhost postfix/smtpd[12095]: warning: dslb-{ip}[{ip}]: SASL LOGIN authentication faile$
Mar 30 14:47:09 localhost postfix/smtpd[12095]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or dire$
Mar 30 14:47:09 localhost postfix/smtpd[12095]: warning: SASL authentication failure: Password verification failed
Mar 30 14:47:09 localhost postfix/smtpd[12095]: warning: dslb-{ip}[{ip}]: SASL PLAIN authentication faile$
Mar 30 14:47:09 localhost postfix/smtpd[12095]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or dire$
Mar 30 14:47:09 localhost postfix/smtpd[12095]: warning: dslb-{ip}[{ip}]: SASL LOGIN authentication faile$
Mar 30 14:47:11 localhost postfix/smtpd[12095]: disconnect from dslb-{ip}[{ip}]
Er schafft es also offenbar nicht, sich zu authetifizieren, Username ist die volle E-Mail-Adresse und PW das vom Abrufen...

forgist
 
#4
Schaut aus als wäre bei sasl was im argen. Da du schreibst das du ISPconfig 3.0.1 nutzt ists eigentlich einfach das zu korrigieren.
Einfach mal in das install Verzeichnis von ispconfig gehen und ein php -q update.php ausführen, SQL pass eingeben und dienste reconfigurieren lassen.
Das ist der einfachste Weg der mir einfällt um eine evtl vorhandene Fehlconfig anzupassen.
Gruß Sven
 
#5
Hallo,

Danke für den Tipp :).
Das habe ich gemacht, er schreibt aber nach wie vor genau die gleichen Meldungen.
Was hat es mit dem SASL auf sich?

forgist
 
#6
Simple Authentication and Security Layer (SASL) dient dazu sich bei dem Server anzumelden.
Sind diese Pakete bei dir installiert? ->

libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libauthen-sasl-perl
 
#7
Ja :).

root@localhost:/# apt-get install libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libauthen-sasl-perl
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
libsasl2-2 ist schon die neueste Version.
libsasl2-modules ist schon die neueste Version.
libsasl2-modules-sql ist schon die neueste Version.
sasl2-bin ist schon die neueste Version.
libauthen-sasl-perl ist schon die neueste Version.
forgist
 
#8
Hm sorry dann bin ich auch erstmal überfragt, bzw müsste jetzt durchtesten der ganzen config mit dir machen. Evtl weiß ja Till direkt woran es liegt.
Gruß Sven
 
#11
SASL-Auth Problem...?!

Hallo!

Ich habe auf meinem vServer (s4y, Debian Etch, ISPC 3.0.1) das gleiche Problem. Sprich, es ist mir nicht möglich Mails zu versenden. Der Empfang von Mail funktioniert hingegen einwandfrei.

Hier ein Auszug aus meinem Mail-Warn Protokoll:
Mar 31 01:55:45 cp postfix/smtpd[1794]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Mar 31 01:55:45 cp postfix/smtpd[1794]: warning: SASL authentication failure: Password verification failed
Mar 31 01:55:45 cp postfix/smtpd[1794]: warning: p5495CAC5.dip.t-dialin.net[84.149.202.197]: SASL PLAIN authentication failed: generic failure
Das Mail-Err Protokoll sagt folgendes:
Mar 30 16:18:07 cp amavis[23783]: (23783-04) (!!) TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 40) line 217, line 5. at (eval 43) line 264, line 5.
Mar 30 16:18:07 cp postfix/smtp[3730]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
Mar 30 16:18:08 cp postfix/qmgr[3627]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem
Mar 30 16:18:09 cp postfix/trivial-rewrite[30359]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 30 16:18:11 cp postfix/trivial-rewrite[9897]: fatal: proxy:mysql:/etc/postfix/mysql-virtual_domains.cf(0,lock|fold_fix): table lookup problem
Mar 31 07:20:02 cp postfix/showq[19746]: fatal: file /etc/postfix/main.cf: parameter default_privs: unknown user name value: nobody
Mar 31 09:50:38 cp postfix/bounce[7680]: fatal: open bounce 82D0342C36D4: Too many open files in system
Das Log meines Mail-Programms sagt folgendes:
READ Mar 31 13:45:24.185 [kCFStreamSocketSecurityLevelNone] -- host:mail.meinedomain.tld -- port:25 -- socket:0x1d755410 -- thread:0x1e172290
535 5.7.0 Error: authentication failed: generic failure
Das "Problem" mit pure-ftp hab ich durch neu kompilieren (--without-capabilities) fixen können.

Wäre es am Ende ratsamer, sich doch einen "richtigen" Root-Server zu leisten? An sich bin ich ja ein Fan der vServer...
 
#14
Hi,

Ich bin auch wieder da von ISPcp, da ging noch viel weniger ;).
Suche gerade nach sinnvollen und passenden Forenbeiträgen, aber wirklich weiter bin ich noch nicht leider :(.

forgist
 

Till

Administrator
#16
DAS würde mich auch interessieren...

Ich hatte bei meinen Tests ein ähnliches Problem mit syscp... ich denke, ich werde mir das noch mal anschauen, vielleicht kann ich ja daraus ne Info für das SASL-Problem ziehen...
Der Fehlermeldung nach hast Du ein postfix ohne mysql unterstützung installiert. Bist du bei der Installation exact dem perfect setup guide für ISPconfig 3 für die entsprechende Linux Distribution gefolgt?
 
#17
Hi!

Das hier ist ja mein Thread :D. Das Problem ist immer noch das gleiche :).
Wo ich es gerade sehe: Die Übersetzung ins Deutsche scheint noch nicht komplett. Kann ich das schnell machen?

forgist
 
#19
Hallo,

Version 3.0.1.1 unter Debian Etch:

Language File Edit: /usr/local/ispconfig/interface/lib/login/lib/lang/de.lng

The password to your ISPConfig 3 control panel account has been reset. The new password is:
Username contains unallowed characters or is longer then 64 characters.
The password length is > 64 characters.

Weiter habe ich erst mal nicht geguckt ;).

forgist
 

Till

Administrator
#20
Zu Deinem Postfix Fehler: Schau mal welches postfix Paket Du installiert hast. Deines unterstützt kein mysql. Installier bitte alles exakt so wie in der ISPConfig Anleitung, dann funktioniert es einwandfrei. habe selbst meherer Debian Systeme mit ispconfig 3 hier.

Zu den language Files: ja, es kann sein dass da noch ein paar sachen Fehlen. ISPConfig hat zum übersetzen einen eingebauten language editor, die Dateien sollten nicht manuell geändert werden, da sie UTF-8 codiert sind und der eine oder andere editor da auch gerne mal die Unlaute zerstört.
 

Werbung