Mails werden nicht gesendet....

#1
Leider werden aus irgendeinem Grund keine e-Mails von PHP versendet - ich weiß nicht warum. Im Mail Protokoll von ISPConfig 3 steht dieses:
Code:
Apr 2 07:40:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
Apr 2 07:40:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Apr 2 07:40:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Apr 2 07:40:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Apr 2 07:40:01 server1 postfix/smtpd[8377]: connect from localhost.localdomain[127.0.0.1]
Apr 2 07:40:01 server1 postfix/smtpd[8377]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Apr 2 07:40:01 server1 postfix/smtpd[8377]: disconnect from localhost.localdomain[127.0.0.1]
Apr 2 07:42:40 server1 postfix/pickup[8072]: 3131E958508: uid=5004 from=
Apr 2 07:42:40 server1 postfix/cleanup[8530]: 3131E958508: message-id=<Jebmruwzdzquhjcfkqhvywfldkwzpcu7@www.meine-domain.asia>
Apr 2 07:42:40 server1 postfix/qmgr[25413]: 3131E958508: from=, size=1783, nrcpt=1 (queue active)
Apr 2 07:42:40 server1 postfix/smtpd[8537]: connect from localhost.localdomain[127.0.0.1]
Apr 2 07:42:40 server1 postfix/smtpd[8537]: AD4A8958507: client=localhost.localdomain[127.0.0.1]
Apr 2 07:42:40 server1 postfix/cleanup[8530]: AD4A8958507: message-id=<Jebmruwzdzquhjcfkqhvywfldkwzpcu7@www.meine-domain.asia>
Apr 2 07:42:40 server1 postfix/qmgr[25413]: AD4A8958507: from=, size=2258, nrcpt=1 (queue active)
Apr 2 07:42:40 server1 postfix/smtpd[8537]: disconnect from localhost.localdomain[127.0.0.1]
Apr 2 07:42:40 server1 amavis[25858]: (25858-02) Passed CLEAN, -> , Message-ID: <Jebmruwzdzquhjcfkqhvywfldkwzpcu7@www.meine-domain.asia>, mail_id: Q5dzJ0jUfX0s, Hits: 1.406, size: 1783, queued_as: AD4A8958507, 496 ms
Apr 2 07:42:40 server1 postfix/smtp[8534]: 3131E958508: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.54, delays=0.03/0.01/0/0.5, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=25858-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as AD4A8958507)
Apr 2 07:42:40 server1 postfix/qmgr[25413]: 3131E958508: removed
Apr 2 07:42:41 server1 postfix/smtp[8538]: AD4A8958507: to=, relay=empfänger.com[IP.Adresse.Entfernt]:25, delay=0.58, delays=0.01/0.01/0.36/0.2, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 2012C12BC6EE)
Apr 2 07:42:41 server1 postfix/qmgr[25413]: AD4A8958507: removed
localhost.localdomain[127.0.0.1] und 127.0.0.1 habe ich nicht ersetzt, das steht echt so im Log.

Ich denke der Fehler ist das in der /etc/hosts in der ersten Zeile das eingetragen ist:
Code:
127.0.0.1       localhost.localdomain   localhost
Bin mir aber nicht ganz sicher... bei meinen anderen steht das auch und Mails und alles geht.
Falls die /etc/hosts wirklich das Problem macht, was soll ich stattdessen eintragen?

Danke

PS. Mail Error Log ist leer.
 
Zuletzt bearbeitet:

Till

Administrator
#2
Laut Log wurde die Email korrekt beim Empfänger zugestellt. Stell im php script mal einen anderen Empfänger ein, einen der z.B. auf Deinem eigenen Servre liegt.

Vermutlich wurde die Email nur vom spamfilter des anderen Servers gelöscht.
 

Till

Administrator
#4
Stell den empfänger bitte mal auf ein Konto das auf dem lokalen Server liegt, sende dann eine mail über das php script und poste die Zeilen die dann im mail log erscheinen.
 

Till

Administrator
#6
Du kannst mit ispconfig 3 jedes webmail Paket verwenden, dass sich per pop3 oder imap mit dem Server verbinden kann. Schau auch mal mit postqueue -p nach, wie viele mails in der queue liegen.
 

Werbung