Mails werden nicht versenden

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ulise, 6. Juli 2011.

  1. ulise

    ulise New Member

    Mails werden nicht versendet

    Hallo,

    habe ein Problem, Mails werden nicht mehr versendet und beim Abrufen ( sollten welche da sein) kommt nichts rein!!

    aus der
    var/Log/mail.log
    Jul 6 17:09:34 ... postfix/smtpd[11458]: warning: SASL: Connect to private/auth failed: No such file or directory
    Jul 6 17:09:34 ... postfix/smtpd[11458]: fatal: no SASL authentication mechanisms
    Jul 6 17:09:34 ... postfix/smtpd[11460]: warning: SASL: Connect to private/auth failed: No such file or directory
    Jul 6 17:09:34 ... postfix/smtpd[11460]: fatal: no SASL authentication mechanisms
    Jul 6 17:09:35 ... postfix/master[10683]: warning: process /usr/lib/postfix/smtpd pid 11458 exit status 1
    Jul 6 17:09:35 ... postfix/master[10683]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    Jul 6 17:09:35 ... postfix/master[10683]: warning: process /usr/lib/postfix/smtpd pid 11460 exit status 1


    System Debian Lenny mit ISPConfig


    Habe auch schon versucht eine neue mail anzulegen, macht er aber immer noch altes problem.

    Vielen Dank

    Uli
     
    Zuletzt bearbeitet: 6. Juli 2011
  2. Till

    Till Administrator

    Welche ISPConfig Version?
     
  3. ulise

    ulise New Member

    die

    ISPConfig
    Version: 2.2.33


    Es lief alles vor 6 stunden noch!!
     
    Zuletzt bearbeitet: 6. Juli 2011
  4. ulise

    ulise New Member

    Habe APC installiert, aber da sollte es eigentlich keine Probleme geben, oder doch??
     
  5. ulise

    ulise New Member

    Jul 6 12:25:26 xxxxx dovecot: Killed with signal 15

    das habe ich in der syslog gefunden

    Jul 6 12:20:51 xxx postfix/anvil[21264]: statistics: max connection rate 1/60s for (smtp:95.134.149.64) at Jul 6 12:17:22
    Jul 6 12:20:51 xxx postfix/anvil[21264]: statistics: max connection count 1 for (smtp:95.134.149.64) at Jul 6 12:17:22
    Jul 6 12:20:51 xxx postfix/anvil[21264]: statistics: max cache size 1 at Jul 6 12:17:22
     
  6. ulise

    ulise New Member

    telnet localhost 25
    telnet: Unable to connect to remote host: Connection refused

    Also ich weiss jetzt nicht mehr weiter,

    habe mehrfach neu hoch gefahren,
     
  7. ulise

    ulise New Member

    meine main.cf datei:

    # Network/Connections
    myhostname = sofia149.x x x.de
    myorigin = /etc/mailname
    mydestination = sofia149.x x x.de, localhost.localdomain, sofia149, localhost
    relayhost =
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    inet_interfaces = all
    default_destination_concurrency_limit = 2

    # Databases
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases

    # SASL / SMTP authentication
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_path = private/auth
    smtpd_sasl_type = dovecot
    broken_sasl_auth_clients = yes

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # Security/Relay
    smtpd_delay_reject = yes
    smtpd_helo_restrictions = reject_invalid_hostname
    smtpd_sender_restrictions = reject_unknown_address
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination

    # Mailbox/Message
    home_mailbox = Maildir/
    mailbox_command =
    mailbox_size_limit = 0
    message_size_limit = 104857600
    unknown_local_recipient_reject_code = 550
    recipient_delimiter = +

    # misc
    biff = no
    allow_percent_hack = no
    append_at_myorigin = no
    append_dot_mydomain = no
    swap_bangpath = no
    readme_directory = no
    inet_protocols = ipv4
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom


    Wäre toll wenn mir jemand helfen könnte.

    Danke

    Uli
     
  8. Till

    Till Administrator

    Schau mal bitte nach, ob dovecot gestaret ist oder ob bei einem dovecot restart irgendwelche Fehler im Log audtauchen.

    Hast Du Betriebssystem Updates eingespielt oder auf einen neue OS Version aktualisiert?
     
  9. ulise

    ulise New Member

    ist gestartet auch keine log fehler!!
     
  10. Till

    Till Administrator

    Dann starte ihn mal neu und scahu dabei ins log. Beantworte bitte auch meine anderen Fragen, da wir sonst mit dem Problem nicht weiter kommen.
     
  11. ulise

    ulise New Member

    ich habe nun postfix deinstalliert und neu installiert!! Emails können jetzt versendet werden
    ABER man kann keine empfangen.
     
  12. Till

    Till Administrator

    Du hast damit wahrscheinlich die Konfiguration übeschrieben, so dass das Mailsystem jetzt neu konfigurirt werden muss. Schau bitte mal in das perfects etup Tutorial für ISPConfig 3 und wiederhole alle Konfigurationsschriite aus dem email Installationsteil.
     
  13. ulise

    ulise New Member

  14. Till

    Till Administrator

    Sorry, meinte ISPConfig 2.

    Das Tutorial ist aber für Courier und nicht für Dovecot. Laut Deiner main.cf verwendest Du aber dovecot und nicht courier.

    Überprüfe bitte mal, ob Du dovecot oder Courier als pop3 / imap Daemon verwendest.
     
  15. ulise

    ulise New Member

    wie mach ich das denn??
     
  16. Till

    Till Administrator

    Poste mal die Ausgabe von:

    netstat -tap | grep imap

    und

    netstat -tap | grep pop
     
  17. ulise

    ulise New Member

    xxxxxxx:~# netstat -tap | grep imap
    tcp 0 0 *:imaps *:* LISTEN 26125/couriertcpd
    tcp 0 0 *:imap2 *:* LISTEN 26020/couriertcpd




    xxxxxx:~# netstat -tap | grep pop
    tcp 0 0 *:pop3s *:* LISTEN 26147/couriertcpd
    tcp 0 0 *:pop3 *:* LISTEN 25955/couriertcpd
    xxxxxxxx:~#
     
  18. ulise

    ulise New Member

    Ich denke das habe ich wohl jetzt überschrieben. Aber ich komme nicht weiter!!
    Was kann ich denn tun??
     
  19. ulise

    ulise New Member

    Keiner da der Helfen kann ??
     
  20. Till

    Till Administrator

    Dein Setup wird jetzt ziemlich kaputt sein, wenn vorher Dovecot drauf war. Poste mal die aktuelle main.cf und die exakten Fehlermeldungen aus dem mail.log, die Du jetzt erhältst.
     

Diese Seite empfehlen