MailServer klappt nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von R3FL3xXx, 11. Jan. 2015.

  1. R3FL3xXx

    R3FL3xXx Member

    Der MailServer klappt nicht in der Log taucht das auf:


    Code:
    A4ED44174E 1868 Sun Jan 11 21:02:27 maxmustermann@mustermail.com
    (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    info@maxmustermann.de

    Bitte um Hilfe, Senden UND Versenden klappt nicht.

    Danke MFG
     
  2. nowayback

    nowayback Well-Known Member

    Code:
    /etc/init.d/amavis restart
     
  3. R3FL3xXx

    R3FL3xXx Member

    Danke schon mal, dann kommt folgende Meldung:

    Code:
    Stopping amavisd: (not running).
    Starting amavisd: hostname: Name or service not known
      The value of variable $myhostname is "", but should have been
      a fully qualified domain name; perhaps uname(3) did not provide such.
      You must explicitly assign a FQDN of this host to variable $myhostname
      in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
      network name!
    (failed).
     
  4. nowayback

    nowayback Well-Known Member

    dann hast du dich nicht an die anleitung gehalten. welche hast du benutzt?
     
  5. R3FL3xXx

    R3FL3xXx Member

  6. nowayback

    nowayback Well-Known Member

    dann poste mal bitte die ausgaben von
    Code:
    hostname
    und
    Code:
    hostname -f
     
  7. R3FL3xXx

    R3FL3xXx Member

    Code:
    root@server1:~# hostname
    server1.example.com
    root@server1:~# hostname -f
    hostname: Name or service not known
    root@server1:~#
    
     
  8. nowayback

    nowayback Well-Known Member

    Code:
    echo server1.example.com > /etc/hostname
    /etc/init.d/hostname.sh start
    ersetze bitte example.com durch deine domain und achte darauf auch entsprechende dns einträge für server1 zu setzen, sowie den ptr auf server1.example.com zu setzen.
     
  9. R3FL3xXx

    R3FL3xXx Member

    Code:
    BC36241877 1037 Wed Jan 14 04:39:01 root@gameroot.domainde
    (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    root@gameroot.domain.de
     
  10. Till

    Till Administrator

    amavis läuft nicht. Starte mal bitte amavis neu.
     
  11. R3FL3xXx

    R3FL3xXx Member

    senden klappt jetzt, aber empfang nicht: (danke schon mal soweit)

    Code:
    MailEnable: Message could not be delivered to some recipients.
    The following recipient(s) could not be reached:
    
        Recipient: [SMTP:info@domain.de]
        Reason: Remote SMTP Server Returned: 554 5.7.1 <info@domain.de>: Relay access denied
     
  12. Till

    Till Administrator

    Poste bitte mal den Inhalt der datei /etc/postfix/master.cf
     
  13. R3FL3xXx

    R3FL3xXx Member

    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #smtp      inet  n       -       -       -       1       postscreen
    #smtpd     pass  -       -       -       -       -       smtpd
    #dnsblog   unix  -       -       -       -       0       dnsblog
    #tlsproxy  unix  -       -       -       -       0       tlsproxy
    submission inet n       -       -       -       -       smtpd
      -o syslog_name=postfix/submission
      -o smtpd_tls_security_level=encrypt
      -o smtpd_sasl_auth_enable=yes
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    smtps     inet  n       -       -       -       -       smtpd
      -o syslog_name=postfix/smtps
      -o smtpd_tls_wrappermode=yes
      -o smtpd_sasl_auth_enable=yes
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    #628       inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       n       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    proxywrite unix -       -       n       -       1       proxymap
    smtp      unix  -       -       -       -       -       smtp
    relay     unix  -       -       -       -       -       smtp
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    retry     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
    #
    # ====================================================================
    #
    # Recent Cyrus versions can use the existing "lmtp" master.cf entry.
    #
    # Specify in cyrus.conf:
    #   lmtp    cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
    #
    # Specify in main.cf one or more of the following:
    #  mailbox_transport = lmtp:inet:localhost
    #  virtual_transport = lmtp:inet:localhost
    #
    # ====================================================================
    #
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    #
    #cyrus     unix  -       n       n       -       -       pipe
    #  user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # ====================================================================
    # Old example of delivery via Cyrus.
    #
    #old-cyrus unix  -       n       n       -       -       pipe
    #  flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
    #
    # ====================================================================
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix    -    n    n    -    2    pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    
    dovecot   unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${user}@${nexthop}
    amavis unix - - - - 2 smtp
            -o smtp_data_done_timeout=1200
            -o smtp_send_xforward_command=yes
    
    127.0.0.1:10025 inet n - - - - smtpd
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o mynetworks=127.0.0.0/8
            -o strict_rfc821_envelopes=yes
            -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    

    und jetzt kommt bei root mail noch folgende Meldung:

    Code:
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0

    die anleitung von euch, dazu hatte ich gefunden, den apache webserver auch neugestartet doch weiterhin diese meldung
     
    Zuletzt bearbeitet: 14. Jan. 2015
  14. Till

    Till Administrator

    Die php meldung ist nicht weiter schlimm, editiere einfach
    /etc/php5/cli/conf.d/ming.ini und erstze # mit ;

    master.cf ist ok. Und Du hast domain.de in ISPConfig als email domain (im mail modul) angelegt?
     
  15. R3FL3xXx

    R3FL3xXx Member

    das mit ersetzen hatte ich wie gesagt gemacht, meldung bleibt aber.

    ja die domain ist angelegt

    mitlerweile klappt das auch mit mailserver versand

    danke für eure hilfe!
     
  16. ramsys

    ramsys Member

    Hast Du Apache neu gestartet?
     
  17. R3FL3xXx

    R3FL3xXx Member

    natürlich, stand so in der anleitung
     
  18. Till

    Till Administrator

    Das ist nicht möglich dass der ming.ini Fehler bleibt wenn die Datei richtig geändert wurde. Poste bitte mal den vollständigen Inhalt von
    /etc/php5/cli/conf.d/ming.ini
     
  19. R3FL3xXx

    R3FL3xXx Member

    Code:
    extension=ming.so
    mehr ist da nicht drin
     
  20. Till

    Till Administrator

    Und da ist keine Zeile drüber? Bei meinem Debian steht in der Zeile drüber:

    # configuration for php MING module

    und dort musst Du # durch ; erstezne, also:

    ; configuration for php MING module
     

Diese Seite empfehlen