Mailserver

Dieses Thema im Forum "Allgemein" wurde erstellt von p.halberscheidt@gmx.de, 30. Nov. 2011.

  1. Hallo,

    Ich habe ISPConfig nach Anleitung Installiert von der Seite.
    Kann auch per WebMail E-Mails versenden, allerdings krieg ich beim Versand mit Outlook die Meldung : Relay access denied
     
    Zuletzt bearbeitet: 30. Nov. 2011
  2. Till

    Till Administrator

    In outlook muss smtp-auth aktiviert werden. user und Passwort sind identisch mit den pop3/ imap login Daten.
     
  3. Hallo,

    Das ist bereits der Fall, ich erhalte aber auch beim Versand an die E-Mail Adresse eine E-Mail zurück wo drinne steht


    <info@******.de>:
    78.46.**.**_does_not_like_recipient./Remote_host_said:_554_5.7.1_<info@*****.de>:_Relay_access_denied/Giving_up_on_78.46.**.**./
     
  4. Till

    Till Administrator

    Und was genau steht dazu im mail.log des Servers?
     
  5. Hier stehen einiges an Fehlermeldungen:

    Code:
    Dec  5 08:05:01 static postfix/cleanup[15818]: EDE4B15AE729: message-id=<20111205080501.EDE4B15AE729@static.12.59.*.*.clients.your-server.de>
    Dec  5 08:05:01 static postfix/qmgr[5019]: EDE4B15AE729: from=<root@mail.*.*.de>, size=779, nrcpt=1 (queue active)
    Dec  5 08:05:01 static postfix/local[15820]: EDE4B15AE729: to=<root@mail.*-*.de>, orig_to=<root>, relay=local, delay=0.03, delays=0.02/0/0/0, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
    Dec  5 08:05:01 static postfix/qmgr[5019]: EDE4B15AE729: removed
    
    Dec  4 23:11:39 static postfix/pickup[27898]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
    Dec  4 23:11:39 static postfix/qmgr[27897]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
    Dec  4 23:11:39 static postfix/smtpd[27899]: fatal: match_list_parse: open file /etc/postfix/local-host-names: No such file or directory
    
    Dec  4 22:38:07 static postfix/master[6171]: warning: process /usr/lib/postfix/qmgr pid 26121 exit status 1
    Dec  4 22:38:07 static postfix/master[6171]: warning: /usr/lib/postfix/qmgr: bad command startup -- throttling
    Dec  4 22:38:07 static postfix/master[6171]: warning: process /usr/lib/postfix/pickup pid 26123 exit status 1
    Dec  4 22:38:07 static postfix/master[6171]: warning: /usr/lib/postfix/pickup: bad command startup -- throttling
    Dec  4 22:38:07 static postfix/master[6171]: warning: process /usr/lib/postfix/smtpd pid 26122 exit status 1
    Dec  4 22:38:07 static postfix/master[6171]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
     
  6. Till

    Till Administrator

    Welche ISPConfig Version hast Du installiert und nach welcher Anleitung?
     
  7. Till

    Till Administrator

    Ok, das wundert mich etwas denn in einem ISPConfig 3 Setup kann die Datei /etc/postfix/local-host-names in der Postfix Konfigurationsdatei an sich nicht vorkommen, es handelt sich um eine Datei eines ISPConfig 2 setups. Hast Du vielleicht ein ISPConfig 2 Tutorial verwendet anstatt des ISPConfig 3 Turtorials?

    Poste bitte mal die ganze postfix main.cf Datei.
     
  8. Hallo,

    Bin mir eigentlich ziemlich Sicher, die Anleitung für das 3er genommen zu haben.

    Die Main.CF

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = static.12.59.*.*.clients.your-server.de
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = mail.******.de, static.12.59.*.*.clients.your-server.de, localhost.12.59.*.*.clients.your-server.de, localhost
    relayhost = 
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    
     
  9. nowayback

    nowayback Well-Known Member

    Moinsen,

    sorry, aber deine main.cf passt meiner Meinung nach nicht zu den oben geposteten Fehlermeldungen.

    Grüße
    nwb
     
  10. Hallo,

    Wo Soll ich die Main.CF denn sonst her haben? Ausgedacht? Das ist eine 1:1 Kopie der Datei /etc/postfix/main.cf
     
  11. nowayback

    nowayback Well-Known Member

    Moinsen,

    ich weiß ich bin manchmal gemein :D

    Was ich dir eigentlich damit sagen wollte, ist, dass du mal prüfen sollst woher er sich die Config holt

    Code:
    postconf | grep directory
    Ich geh mal davon aus, dass du Postfix bereits mal neu gestartet hast. Wenn nicht, dann tue das bitte auch nochmal.
     
  12. Till

    Till Administrator

    Die main.cf sieht mir arg kurz aus, kann es sein dass Du nicht die vollständige Datei gepostet hast?
     
  13. Hallo,

    Das ist die komplette Main.cf ... Vllt. postet ihr mal eure, damit ich es mit dieser probieren kann?


    :~# postconf | grep directory
    command_directory = /usr/sbin
    command_execution_directory =
    config_directory = /etc/postfix
    daemon_directory = /usr/lib/postfix
    data_directory = /var/lib/postfix
    execution_directory_expansion_filter = 1234567890!@%-_=+:,./abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ
    html_directory = /usr/share/doc/postfix/html
    mail_spool_directory = /var/mail
    manpage_directory = /usr/share/man
    process_id_directory = pid
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix
    require_home_directory = no
    sample_directory = /usr/share/doc/postfix/examples
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    tls_random_exchange_name = ${data_directory}/prng_exch
     
    Zuletzt bearbeitet: 6. Dez. 2011
  14. maffi

    maffi New Member

    Irgendwie sieht deine Config echt komisch aus. Wenn du ne eigene Domain hast, solltest du die erstmal bei myhostname rein schreiben und den vorgefertigten mist entfernen ;) Benutz am besten mal diese main.cf von Postfix und pass sie dir mal an: "/usr/share/postfix/main.cf.dist" Vergess den RDNS Eintrag, MX Settings und ggf. Domainkeys nicht!
     
  15. nowayback

    nowayback Well-Known Member

    Moinsen

    Wenn das dein Wunsch ist erfülle ich dir den gerne. Ich hab damals glaub ich nach diesem Tutorial installiert HowtoForge Linux Tutorials » Der Perfekte Server - Debian Squeeze (Debian 6.0) mit BIND & Dovecot [ISPConfig 3] jedoch ohne Postgrey und ohne jailkit.
    Als Ausgangskonfiguration hab ich damals das Hetzner Minimal Image genommen und es lief alles problemlos. Da du ja auch bei Hetzner bist, solltest es evtl. mal damit versuchen wenn du es nicht hinbekommst ;-)

    meine main.cf:
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    
    ## Nur als Info für dich: 
    ## srv1.t0mmynet.de ist der FQDN meines Servers
    
    myhostname = srv1.t0mmynet.de
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination = srv1.t0mmynet.de, localhost, localhost.localdomain
    relayhost = 
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains = 
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = dovecot
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    message_size_limit = 0
    smtpd_client_message_rate_limit = 100
    owner_request_special = no
    
     
  16. nowayback

    nowayback Well-Known Member

    Moinsen,

    manchmal lassen mir gewisse Dinge keine Ruhe ;)

    poste mal bitte die Log Datei der ISP Config Installation

    Code:
    /var/log/ispconfig_install.log
    Grüße
    nwb
     

Diese Seite empfehlen