Manuelle einstellungen im DNS

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von brave_snoopy, 14. Apr. 2008.

  1. brave_snoopy

    brave_snoopy New Member

    Hallo,

    ich hab ispconfig bei mir installiert.

    da ich den dns der dort installiert ist, ebenfalls als meinen dns in der firma nutzen möchte und eine weiterleitung auf den dns meines providers machen möchte, muss ich in der named.conf forwarders {}; eintragen.
    Allerdings wird die named.conf ständig überschrieben sobald ich in ispconfig was änder.

    wo kann ich dieses eintragen, damit es nicht ständig verschwindet ?

    desweiteren hab ich folgendes problem.
    Wenn ich ein web mit www.test.de angelegt hab. und per explorer drauf zugreifen möchte, lande ich nicht in dem virtuellen host für test.de sondern auf der hauptseite des apache wo dann it works steht. was könnte hier falsch laufen?

    Danke
     
  2. Till

    Till Administrator

    Kopier die Datei /root/ispconfig/isp/conf/named.conf.master nach /root/ispconfig/isp/conf/customized_templates/named.conf.master und füge dort Deine Änderungen ein.

    Stell sicher, dass Du die richtige IP beim web ausgewählt hast. In einem NAT Netzwerk musst Du die interne und nicht externe IP nehmen,
     
  3. brave_snoopy

    brave_snoopy New Member

    das mit der ip klappt, allerdingdings habe ich dann folgendes problem.
    ich nutze dns auf dem ispconfig installiert ist als öffentlichen dns. So dass andere clients die domains auflösen können, die auf meinem Server liegen.
    Daher muss ich ja die öffentliche IP angeben. Wenn ich nun im ispconfig beim web die interne ip angeben. Und müsste sobald ich ein web anlege und den dns record setzen lasse, jedesmal den dns eintrag manuell ändern. Gibt es hier nicht die möglichkeit, mit 2 IPs zu arbeiten? Im web die interne nehmen und das beim dns automatisch die öffentliche ip eingetragen wird ?
     
  4. brave_snoopy

    brave_snoopy New Member

    Nachtrag:

    Ich nutze kein NAT Netz.
    Mein Webserver der in der DMZ steht hat eine Feste IP die ich an der Firewall vergeben habe und komplett zum Webserver durchschleife.

    Mein Firmennetz hat nen NAT Netz mit einer anderen ip.
     
  5. Till

    Till Administrator

    Wenn Dein Rechner im DMZ steht, müsste es gehen wenn Du für die Webseite und den DNS die externe IP nimmst.
     
  6. brave_snoopy

    brave_snoopy New Member

    es geht ja leider nicht. das ist ja das problem.. es taucht dann immer die hauptseite des apache auf und nicht die vhost seite.
     
  7. Till

    Till Administrator

    Dann läuft bei Dir mit der DMZ etwas falsch oder Du hast die falsche IP ausgewählt. Wenn die Kombination aus IP-Adresse und Hostname zusammen passt, bekommst Du die Webseite, ansnsten nicht.

    D.h. Du greifst im Moment vermutlich über eine falsche IP zu.

    Sie außerdem nochmal nach, ob der Vhost korrekt in der datei /etc/apache2/vhosts/Vhost_ispconfig.conf drin steht.
     
  8. brave_snoopy

    brave_snoopy New Member

    also ich habe es mitlerweile hinbekommen.
    Allerdings hab ich noch folgendes merkwürdiges Problem.

    Habe bei allen Webseiten im DNS die öffentlcihe IP drin stehen. Auch in der vhost conf datei steht die öffentlich ip.

    Habe dann einen user für das web angelegt und mit admin rechten versehen. habe dann per ftp die seite hochgeladen.

    Allerdings kommt nun wieder die apache standardseite mit it works, statt die vhost seite. Obwohl ich auf die öffentliche ip zugreife und den dns namen eingeben habe und alles soweit auf anscheinend richtig ist.

    vor etwa einer halben stunde gingen alle vhost seiten auf eine einzige vhost seite.

    Noch ne idee was da schief laufen kann?

    Wie gesagt in der vhost vonf datei scheint alles ok zu sein.
     
  9. brave_snoopy

    brave_snoopy New Member

    so habe nun etwas weiter rumgebastelt.
    Wenn ich in der vhost config datei die interne ip des webservers eintrage und in der lokalen hosts datei einen eintrag mache

    test.de 10.10.0.210 dann lande ich auch wirklich auf dem vhost.

    trage ich aber wieder die öffentliche ip in der vhost config datei ein. und lösche den eintrag aus der hosts datei.
    so dass ich wieder über die öffentliche ip auf die domain bzw. den vhost zugreife. Allerdings lande ich dann wieder auf der hauptseite des apache mit it works.

    wieso um gottes willen landet er mit der domain dann nicht in dem vhost? ich greife ja jedesmal mit der domain auf den apache zu? :(
     
  10. Till

    Till Administrator

    Schau mal im Apache log nach, mit welcher IP Dein Zugriff im Log steht.
     
  11. brave_snoopy

    brave_snoopy New Member

    in der access_log steht folgendes

    Code:
    cat access_log
    192.168.0.53 - - [16/Apr/2008:11:13:05 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 1.1.4322; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)"
    
    
    meinst du dies? Oder eine andere Log Datei?
     
  12. Till

    Till Administrator

    Ok, dann musst Du für die Webseite die IP
    192.168.0.53

    nehmen.
     
  13. brave_snoopy

    brave_snoopy New Member

    aber die 192.168.0.53 ist doch die ip von meinem client ?!
    Mein Webserver hat die 10.10.0.210 in der dmz und die öffentliche ip 213.23.146....


    also muss ich doch die 213... eintragen únd ncih die 192....
     
  14. Till

    Till Administrator

    Ja, stimmt natürlich. Hatte nicht daran gedacht dass dort ja die Client Adresse geloggt wird.

    An Deiner Stelle würde ich mal versuchen, den Server nicht in die DMZ zu stellen sondern ins normale LAN und in Deinem Router einfach port 80 zu forwarden.
     
  15. brave_snoopy

    brave_snoopy New Member

    ich habe mir grad die vhost conf datei meines alten Webservers ohne ISP Config angesehen.

    dort habe ich nicht die IP eingetragen, sondern nur einen " * "

    Damit funktioniert es einwandfrei.

    Wie kann ich nun im ISP Config sagen, das im DNS die öffentliche IP Automatisch eingetragen wird, in der Vhost aber dann ein Sternchen oder die Interne IP, damit geht es nämlich auch. Nur eben im DNS muss die öffentliche IP stehen, da auf diesem die Domains registriert werden.
     
  16. Till

    Till Administrator

    ISPConfig kann keinen * eintragen, das ist auch nicht nötig, da der Stern nur ein Platzhalter für die richtige IP ist. Wenn man also die richtige IP in ISPConfig einträgt, funktioniert das alles einwandfrei.

    Die IP im DNS und vhost können unterschieldlich sein, einfach die ien IP im vhost und die andere IP im DNS-Manager eintragen.

    Das ganze funktioniert auf einigen zehntausend servern einwandfrei, sollte also auch bei Deinem Setup gehen.
     
  17. brave_snoopy

    brave_snoopy New Member

    ja, aber wie mache ich das automatisch? Sonst muss ich ja bei jeder Domain die IPs nachträglich ändern.
     
  18. Till

    Till Administrator

    Das geht nicht automatisch. Einfach keine DNS Checkbox beim erstellen der Webseite anhaken und den DNS-Record im DNS-Manager anlegen.
     

Diese Seite empfehlen