Mehrere Subnetze?!

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von OGroene, 3. Apr. 2012.

  1. OGroene

    OGroene New Member

    Hallo Kollegen...

    ich habe ein Problem:
    Ich habe eine neue 10MBit Standleitung bekommen. Bis die alte 2MBit abgeschaltet wird, möchte ich gerne beide Standleitungen parallel nutzen.

    Verkabelung:
    ESXi Server -> VM (Debian, ISPConfig, 1 virtuelle Netzwerkkarte)
    -> Switch -> 2 Standleitungen (mit verschiedenen Subnetzen)

    Ich habe darin eigentlich kein Problem gesehen:

    - 2. Netzwerkkarte für die VM im ESXi vergeben
    - /etc/network/interfaces anpassen

    Server rebooten und dann sollte ich schon beide IPs pingen können.
    Pustekuchen. Beide IPs sind nicht mehr erreichbar.

    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet static
            address 217.13.x.x
            netmask 255.255.255.240
            network 217.13.x.x
            broadcast 217.13.x.x
            gateway 217.13.x.1
    
    auto eth1
    iface eth1 inet static
            address 212.185.x.x
            netmask 255.255.255.248
            network 212.185.x.x
            broadcast 212.185.x.x
            gateway 212.185.x.x

    Haut mir hier ISPConfig (Firewall/Routing) dazwischen?
    Trage ich jeweils nur ein Interface ein klappt es.

    Mit einem Virtuellen Netzwerkadapter, was mir eigentlich besser gefallen würde, auf etc0 (also etc0:1), soll es ja angeblich nicht gehen mit zwei verschiedenen Subnetzen und IP-Tables.

    Zitat aus einem anderen Forum:

    iptables unterstützt kein Virtual IP Aliasing, darum geht das nicht. Traffic auf dem virtuellen Interface wird als Traffic auf dem Hauptinterface erkannt, da kannst du auch nicht wirklich was dagegen machen, eth0 und eth0:1 ist somit für iptables beides als eth0 zu verstehen.

    Hat einer eine Idee?
    Ich bin für jede Hilfe dankbar.

    Gruß

    Olli
     
  2. Till

    Till Administrator

    Nein. ISPConfig hat nur eine port based firewall, routing wird von ispconfig nicht konfiguriert. Du kannst ja einfach die ISPConfig Firewall auscchalten.
     
  3. OGroene

    OGroene New Member

    Hallo Till

    ich hatte die Firewall abgeschaltet, leider ohne Erfolg.
    Gleiches Problem. :-(
     
  4. OGroene

    OGroene New Member

    Nachtrag.
    Aktiviere ich beide Netzwerkkarten, ist immer nur die eth1 pingbar.
     
  5. nowayback

    nowayback Well-Known Member

    Moinsen,

    Das ist so nicht ohne weiteres möglich. Du kannst entweder eine Leitung einer Netzwerkkarte fest zuordnen oder du brauchst einen separaten Router der dir deine Clientnetze auf die Leitungen umbiegt. Du hast dann aber trotzdem keine 12 Mbit Leitung sondern eben nur maximal 10 ;)

    Grüße
    nwb
     
  6. OGroene

    OGroene New Member

    Hallo...

    Ich hatte natürlich nicht vor 12MBit zu realisieren ;-)
    Die Anbindung an beide Leitungen ist dafür gedacht,
    bei einem anstehenden Domainumzug (Standleitung 1 mit Domain -> Standleitung 2 mit Domain) Ausfallsicherheit zu garantieren.

    Das Zauberwort heißt "iproute2".
    Der Server hat bei meinem Konstrukt zwei default Gateways
    und das geht halt nicht.

    Hier ist ein Artikel, der genau das Problem geschreibt:

    Zwei Default Gateways in einem System

    Das Problem ist also dank meines Kollegen gelöst. :)

    Grüße

    Olli
     

Diese Seite empfehlen