Merkwürdigkeiten in ISPConfig Version: 3.1rc1

Dieses Thema im Forum "Entwicklerforum" wurde erstellt von deimos, 10. Aug. 2016.

  1. deimos

    deimos New Member

    Hallo ispconfig user eiss jemand Rat oder kann die nachfolgenden Probleme bestätigen?
    ISPConfig Version: 3.1rc1 (neu installiert -> kein update - testinstall) läuft in open vz + debian jessie (aktueller stand)
    Folgende Probleme / Auffälligkeiten sind vorhanden:
    - ftp (per file zilla) bringt folgende Meldung:
    Antwort: 150 Accepted data connection
    Fehler: Server sent unsorted certificate chain in violation of the TLS specifications
    Antwort: 226-Options: -a -l
    Antwort: 226 55 matches total
    Status: Anzeigen des Verzeichnisinhalts für "/web" abgeschlossen
    -> cert ist von comodo cert kette war eigentlich immer ok (vz war mit stable ispconfig + cert in Benutzung)

    - Immer wieder sporadisch Probleme mit update Anzeige in ispconfig (Updatestatus) Heute wird wieder folgendes nicht zum ersten mal angezeigt:
    Inst e2fslibs [1.42.12-1.1] (1.43-3~bpo8+1 ftp.debian.org [amd64]) [e2fsprogs:amd64 on e2fslibs:amd64] [e2fsprogs:amd64 ]
    Conf e2fslibs (1.43-3~bpo8+1 ftp.debian.org [amd64]) [e2fsprogs:amd64 ]
    Inst e2fsprogs [1.42.12-1.1] (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Conf e2fsprogs (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Inst libapparmor1 [2.9.0-3] (2.10.95-4~bpo8+2 ftp.debian.org [amd64])
    Conf libapparmor1 (2.10.95-4~bpo8+2 ftp.debian.org [amd64])
    Inst libseccomp2 (2.2.3-3~bpo8+1 ftp.debian.org [amd64])
    Conf libseccomp2 (2.2.3-3~bpo8+1 ftp.debian.org [amd64])
    Inst libsystemd0 [215-17+deb8u4] (230-7~bpo8+2 ftp.debian.org [amd64]) [systemd:amd64 ]
    Conf libsystemd0 (230-7~bpo8+2 ftp.debian.org [amd64]) [systemd:amd64 ]
    Inst libudev1 [215-17+deb8u4] (230-7~bpo8+2 ftp.debian.org [amd64]) [udev:amd64 systemd:amd64 ]
    Conf libudev1 (230-7~bpo8+2 ftp.debian.org [amd64]) [udev:amd64 systemd:amd64 ]
    Inst systemd [215-17+deb8u4] (230-7~bpo8+2 ftp.debian.org [amd64]) [systemd:amd64 on ifupdown:amd64] [systemd:amd64 on udev:amd64] [udev:amd64 systemd-sysv:amd64 ]
    Inst ifupdown [0.7.53.1] (0.8.13~bpo8+1 ftp.debian.org [amd64]) [systemd:amd64 on udev:amd64] [udev:amd64 systemd-sysv:amd64 ]
    Inst udev [215-17+deb8u4] (230-7~bpo8+2 ftp.debian.org [amd64]) [systemd-sysv:amd64 ]
    Conf systemd (230-7~bpo8+2 ftp.debian.org [amd64]) [systemd-sysv:amd64 ]
    Inst systemd-sysv [215-17+deb8u4] (230-7~bpo8+2 ftp.debian.org [amd64])
    Conf systemd-sysv (230-7~bpo8+2 ftp.debian.org [amd64])
    Inst comerr-dev [2.1-1.42.12-1.1] (2.1-1.43-3~bpo8+1 ftp.debian.org [amd64]) []
    Inst libcomerr2 [1.42.12-1.1] (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Conf libcomerr2 (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Inst libss2 [1.42.12-1.1] (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Conf libss2 (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Inst libssl-dev [1.0.1t-1+deb8u2] (1.0.2h-1~bpo8+1 ftp.debian.org [amd64]) []
    Inst libssl1.0.0 [1.0.1t-1+deb8u2] (1.0.2h-1~bpo8+1 ftp.debian.org [amd64])
    Inst libfuse2 (2.9.3-15+deb8u2 Debian:8.5/stable, Debian-Security:8/stable [amd64])
    Inst geoip-database [20150317-1] (20160504-1~bpo8+1 ftp.debian.org [all])
    Inst libgeoip1 [1.6.2-4] (1.6.7-2~bpo8+1 ftp.debian.org [amd64])
    Inst libglib2.0-0 [2.42.1-1+b1] (2.48.0-1~bpo8+1 ftp.debian.org [amd64])
    Inst libllvm3.5 [1:3.5-10] (1:3.5.2-3~bpo8+2 ftp.debian.org [amd64])
    Inst mysql-common [5.5.50-0+deb8u1] (5.6.30-1~bpo8+1 ftp.debian.org [all])
    Inst libmysqlclient18 [5.5.50-0+deb8u1] (5.6.30-1~bpo8+1 ftp.debian.org [amd64])
    Inst libstemmer0d (0+svn585-1 Debian:8.5/stable [amd64])
    Inst liblz4-1 (0.0~r122-2 Debian:8.5/stable [amd64])
    Inst dbconfig-common [1.8.47+nmu3+deb8u1] (2.0.4~bpo8+1 ftp.debian.org [all])
    Inst libfile-stripnondeterminism-perl (0.022-1~bpo8+1 ftp.debian.org [all])
    Inst dh-strip-nondeterminism (0.022-1~bpo8+1 ftp.debian.org [all])
    Inst dh-autoreconf (12~bpo8+1 ftp.debian.org [all])
    Inst debhelper [9.20150101+deb8u2] (9.20160403~bpo8+1 ftp.debian.org [all])
    Inst dh-python [1.20141111-2] (2.20160609~bpo8+1 ftp.debian.org [all])
    Inst dovecot-sieve [1:2.2.13-12~deb8u1] (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64]) []
    Inst dovecot-pop3d [1:2.2.13-12~deb8u1] (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64]) []
    Inst dovecot-mysql [1:2.2.13-12~deb8u1] (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64]) []
    Inst dovecot-lmtpd [1:2.2.13-12~deb8u1] (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64]) []
    Inst dovecot-imapd [1:2.2.13-12~deb8u1] (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64]) []
    Inst libexttextcat-data (3.4.4-1 Debian:8.5/stable [all]) []
    Inst libexttextcat-2.0-0 (3.4.4-1 Debian:8.5/stable [amd64]) []
    Inst openssl [1.0.1t-1+deb8u2] (1.0.2h-1~bpo8+1 ftp.debian.org [amd64]) []
    Inst dovecot-core [1:2.2.13-12~deb8u1] (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64])
    Inst fuse2fs (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Inst libglib2.0-data [2.42.1-1] (2.48.0-1~bpo8+1 ftp.debian.org [all])
    Inst libjs-jquery [1.7.2+dfsg-3.2] (1.11.3+dfsg-4~bpo8+1 ftp.debian.org [all])
    Inst libjs-sphinxdoc [1.2.3+dfsg-1] (1.3.6-2~bpo8+1 ftp.debian.org [all])
    Inst linux-libc-dev [3.16.7-ckt25-2+deb8u3] (4.6.3-1~bpo8+1 ftp.debian.org [amd64])
    Inst python-pkg-resources [5.5.1-1] (20.10.1-1.1~bpo8+1 ftp.debian.org [all])
    Inst python-pyinotify [0.9.4-1] (0.9.5-1~bpo8+1 ftp.debian.org [all])
    Inst python-six-whl [1.8.0-1] (1.9.0-3~bpo8+1 ftp.debian.org [all])
    Inst python-urllib3-whl [1.9.1-3] (1.12-1~bpo8+1 ftp.debian.org [all])
    Inst python-requests-whl [2.4.3-6] (2.8.1-1~bpo8+1 ftp.debian.org [all])
    Inst python3-pkg-resources [5.5.1-1] (20.10.1-1.1~bpo8+1 ftp.debian.org [all])
    Inst spamassassin [3.4.0-6] (3.4.1-3~bpo8+1 ftp.debian.org [all])
    Inst sa-compile [3.4.0-6] (3.4.1-3~bpo8+1 ftp.debian.org [all])
    Inst shared-mime-info [1.3-1] (1.5-2~bpo8+1 ftp.debian.org [amd64])
    Inst spamc [3.4.0-6] (3.4.1-3~bpo8+1 ftp.debian.org [amd64])
    Inst unhide [20121229-1+b1] (20130526-1~bpo8+1 ftp.debian.org [amd64])
    Conf udev (230-7~bpo8+2 ftp.debian.org [amd64])
    Conf ifupdown (0.8.13~bpo8+1 ftp.debian.org [amd64])
    Conf comerr-dev (2.1-1.43-3~bpo8+1 ftp.debian.org [amd64])
    Conf libssl1.0.0 (1.0.2h-1~bpo8+1 ftp.debian.org [amd64])
    Conf libssl-dev (1.0.2h-1~bpo8+1 ftp.debian.org [amd64])
    Conf libfuse2 (2.9.3-15+deb8u2 Debian:8.5/stable, Debian-Security:8/stable [amd64])
    Conf geoip-database (20160504-1~bpo8+1 ftp.debian.org [all])
    Conf libgeoip1 (1.6.7-2~bpo8+1 ftp.debian.org [amd64])
    Conf libglib2.0-0 (2.48.0-1~bpo8+1 ftp.debian.org [amd64])
    Conf libllvm3.5 (1:3.5.2-3~bpo8+2 ftp.debian.org [amd64])
    Conf mysql-common (5.6.30-1~bpo8+1 ftp.debian.org [all])
    Conf libmysqlclient18 (5.6.30-1~bpo8+1 ftp.debian.org [amd64])
    Conf libstemmer0d (0+svn585-1 Debian:8.5/stable [amd64])
    Conf liblz4-1 (0.0~r122-2 Debian:8.5/stable [amd64])
    Conf dbconfig-common (2.0.4~bpo8+1 ftp.debian.org [all])
    Conf libfile-stripnondeterminism-perl (0.022-1~bpo8+1 ftp.debian.org [all])
    Conf dh-strip-nondeterminism (0.022-1~bpo8+1 ftp.debian.org [all])
    Conf debhelper (9.20160403~bpo8+1 ftp.debian.org [all])
    Conf dh-autoreconf (12~bpo8+1 ftp.debian.org [all])
    Conf dh-python (2.20160609~bpo8+1 ftp.debian.org [all])
    Conf libexttextcat-data (3.4.4-1 Debian:8.5/stable [all])
    Conf libexttextcat-2.0-0 (3.4.4-1 Debian:8.5/stable [amd64])
    Conf openssl (1.0.2h-1~bpo8+1 ftp.debian.org [amd64])
    Conf dovecot-core (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64])
    Conf dovecot-sieve (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64])
    Conf dovecot-pop3d (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64])
    Conf dovecot-mysql (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64])
    Conf dovecot-lmtpd (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64])
    Conf dovecot-imapd (1:2.2.24-1~bpo8+1 ftp.debian.org [amd64])
    Conf fuse2fs (1.43-3~bpo8+1 ftp.debian.org [amd64])
    Conf libglib2.0-data (2.48.0-1~bpo8+1 ftp.debian.org [all])
    Conf libjs-jquery (1.11.3+dfsg-4~bpo8+1 ftp.debian.org [all])
    Conf libjs-sphinxdoc (1.3.6-2~bpo8+1 ftp.debian.org [all])
    Conf linux-libc-dev (4.6.3-1~bpo8+1 ftp.debian.org [amd64])
    Conf python-pkg-resources (20.10.1-1.1~bpo8+1 ftp.debian.org [all])
    Conf python-pyinotify (0.9.5-1~bpo8+1 ftp.debian.org [all])
    Conf python-six-whl (1.9.0-3~bpo8+1 ftp.debian.org [all])
    Conf python-urllib3-whl (1.12-1~bpo8+1 ftp.debian.org [all])
    Conf python-requests-whl (2.8.1-1~bpo8+1 ftp.debian.org [all])
    Conf python3-pkg-resources (20.10.1-1.1~bpo8+1 ftp.debian.org [all])
    Conf spamassassin (3.4.1-3~bpo8+1 ftp.debian.org [all])
    Conf sa-compile (3.4.1-3~bpo8+1 ftp.debian.org [all])
    Conf shared-mime-info (1.5-2~bpo8+1 ftp.debian.org [amd64])
    Conf spamc (3.4.1-3~bpo8+1 ftp.debian.org [amd64])
    Conf unhide (20130526-1~bpo8+1 ftp.debian.org [amd64])

    apt-get update + upgrade ergibt aber -> Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. ?
    Morgen ist das unter Umständen wieder weg und nächste woche wieder da??

    Letztes Problem Webseiten in ispconfig bearbeiten:
    -> klick auf webseiten -> klick auf z.b. id2 (paintattack.eu- testseite)
    -> im domainfeld wird die id1 (000default228.tld) angezeigt die ich als ip dummy angelegt habe wie im tipp von till angesagt.
    -> klicke ich jetzt auf einen anderen tab kommt eine warnung: Domain muss eindeutig sein!
    Fazit die Domains können nicht zuverlässig bearbeitet/eingestellt werden hatte schon plötzlich 3x 000default228.tld

    Ach so noch ein Darstellungsproblem bei den Datenbanken:
    Datenbank-Name
    ist immer abgeschnitten/gekürzt und nur durch klicken in die db sichtbarsieht dann so aus c1_db1_olimp_st... währe schön wenn die spalten sortiert/angepasst oder ausgeblendet werden könnten der db name ist mir als admin eigentlich am wichstigsten wenn ich was für einen kunden suche.

    Hoffe ihr könnt helfen
    Danke
     
  2. florian030

    florian030 Member

    1. Da hast Du eher einen Fehler bei der pureftpd-config. Das liegt nicht an ISPConfig.
    2. Hast Du mal auf das Datum / die Uhrzeit geschaut? Die Liste wird nicht permanent aktualisiert.
    3. Verstehe ich so gar nicht. Ich kann jede Webseite ganz normal bearbeiten.
    4. Das kommt auf die Länge des Namens an. ;) Gekürzt ist das halt in der der Übersicht. Irgendwo müssen ja die anderen Informationen auch stehen.
     
  3. Till

    Till Administrator

    Domain berabeiten geht einwandfrei hier. Vermutlich hast Du das Domain Limit modul eingeschaltet und die dummy domain dort nicht unter Kunden > domains angelegt.
     
  4. deimos

    deimos New Member

    Hallo Till und Florian,
    ja das Domain Limit modul ist eingeschaltet aber die dummy domain ist unter kunden angelegt?
    Egal auf welchen link man unter domains klick im feld domain steht immer die dummy domain + wechsel klappkarte:
    warnung: Domain muss eindeutig sein!

    debian update / upgrade -> time bringt das richtige datum + uhrzeit, zeitzone (auch in php) ist auch richtig konfiguriert

    ftp tls -> anscheinend läuft da einige nicht richtig auf dem eine rechner habe ich ein update von filezilla (dort wird der fehler angezeigt)
    im update protokol steht folgendes:
    Official binaries now link against a patched version of GnuTLS so that a better error message can be printed on broken servers that send malformed certificate chains
    auf dem lap die ältere version keine anzeige des tls fehlers
    Habe mal ein cert reissure angefordert und werde das comodo cert nochmal neu einfügen, Ergebniss ist abzuwarten!
     
  5. deimos

    deimos New Member

    Wie immer hat Till gute Hinweise um Fehler einzugrenzen ;-)
    Wenn ich das Domain Limit modul deaktiviere funktioniert die domain Bearbeitung einwandfrei!
    Liegt es vielleicht an der Progammierung, da ich bisher nur 1 Kunden angelegt habe?
     
  6. deimos

    deimos New Member

    ne ist egal 2. Kunden angelegt + domain zugewiesen aber mit aktiviertem Domain Limit modul funktioniert es nicht :-((
     
  7. deimos

    deimos New Member

    habe die mal den vzdump (vor install ispconfig 3.1) installiert was mir auch da auffällt ist das unter update
    (debian 8.5 installiert nach https://www.howtoforge.com/tutorial...4-jessie-apache-bind-dovecot-ispconfig-3-1/3/ )
    Immer das kommt:
    Inst libss2 (1.42.12-1.1 Debian:8.5/stable [amd64])
    Conf libss2 (1.42.12-1.1 Debian:8.5/stable [amd64])
    Inst e2fsprogs (1.42.12-1.1 Debian:8.5/stable [amd64])
    Conf e2fsprogs (1.42.12-1.1 Debian:8.5/stable [amd64])
    Inst init (1.22 Debian:8.5/stable [amd64])
    Conf init (1.22 Debian:8.5/stable [amd64])

    Ist das in der install vergessen worden oder woran liegt das?
     
  8. deimos

    deimos New Member

    Die ftp Warnung liegt übrigends an der pem Datei wenn ich eine eigene Neue erstelle ist der Error in filezilla weg gibt es einen sicheren weg eine eigene pem zu einem Comodo Cert zu erstellen?
     
  9. deimos

    deimos New Member

    hm zu antworten scheint niemand mehr, dabei ist zu der db ansicht auch noch zu sagen der kunden wird auch umgebrochen und ist somit ersichtlich.
    wenn ich was suche ist das nach kunden und db name aber so ist das ja nicht möglich. Im backup bereich währe auch noch template verbesserungen möglich.
     

Diese Seite empfehlen