missing '=' after attribute name:

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von teeshop, 18. März 2010.

  1. teeshop

    teeshop New Member

    Hallo Till,

    ich bekomme diese Meldung, wenn ich posfix restarte:

    Code:
    root@www:/home/backup# /etc/init.d/postfix restart
     * Stopping Postfix Mail Transport Agent postfix                                postfix: fatal: /etc/postfix/main.cf, line 64: missing '=' after attribute name: "$mynetworks $virtual_mailbox_limit_maps =' "
                                                                             [fail]
    root@www:/home/backup# 
    
    Im Forum habe ich nichts dazu gefunden. Ausprobiert hab ich schon jede Menge, aber der Fehler kommt immer wieder.

    Dies ist der ensprechende Part in der /etc/postfix/main.cf

    Code:
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps =' 
    $mynetworks $virtual_mailbox_limit_maps =' 
    
    Ich verstehe das nicht.Was mache ich hier falsch? Hilfe wäre sehr nett

    Gruß

    teeshop
     
  2. Till

    Till Administrator

    Da sind Dir wohl mehere Zeilen durcheinander gekommen. Welches Tutorial hast Du verwendet?
     
  3. teeshop

    teeshop New Member

  4. Till

    Till Administrator

    Einen Smarthost kannst Du ganz einfach in ISPConfig einrichten, Du musst Ihn nur unter System bei den Server Einstellungen eintragen.

    Um das Postfix setup wieder zu reparieren, lade bitte das aktuelle ispconfig 3.0.2 runter und rufe das update.php script auf. Dann wähle im Updater, dass die Dienste rekonfiguriert werden sollen.
     
  5. teeshop

    teeshop New Member

    Danke schön!
    Ich mache mich gleich dran.

    Gruß

    teeshop
     
  6. teeshop

    teeshop New Member

    Scheint so nicht zu wollen.

    Was kann ich tun?

    Code:
    >> Update  
    
    Please choose the update method. For production systems select 'stable'. 
    The update from svn is only for development systems and may break your current setup.
    
    Select update method (stable,svn) [stable]: 
    
    There are no updates available for ISPConfig 3.0.2
    root@www:/tmp/ispconfig3_install/install# 
    Gruß

    teeshop
     
  7. teeshop

    teeshop New Member

    Hi Till,

    Mailversand aus dem Shop heraus geht jetzt!

    Grosses "Danke" für die Hilfe.

    Scheint dann wohl nur die eine Zeile gewesen zu sein.

    Grüße

    teeshop
     
    Zuletzt bearbeitet: 18. März 2010
  8. teeshop

    teeshop New Member

    Hi Till,

    Folgendes ist mir durch den Sinn gegangen:

    Wenn ich nunmehr "dpkg-reconfigure postfix"aufrufen würde und wieder "Internetsite" statt "Smarthost mit Internet" auswähle, kann ich dann den Shmarthost anschließend aus ISPC heraus einrichten? Ist vielleicht besser so,oder? Oder bleibt es sich egal?

    Gruß

    teeshop
     
    Zuletzt bearbeitet: 18. März 2010
  9. Till

    Till Administrator

    Ja, mach das mal so. Aber unbedingt das update.php durchlaufen lassen, nachdem Du postfix rekonfiguriert hast.
     
  10. Till

    Till Administrator

    Das ist ja auch nicht das, was ich Dir gesagt habe. Du solltest ispconfig herunterladen und dann das update.php script aufrufen.
     
  11. teeshop

    teeshop New Member

    Das will er ja nicht machen. Was tun?

    >> Update

    Please choose the update method. For production systems select 'stable'.
    The update from svn is only for development systems and may break your current setup.

    Select update method (stable,svn) [stable]:

    There are no updates available for ISPConfig 3.0.2
    root@www:/tmp/ispconfig3_install/install#
     
  12. Till

    Till Administrator

    Die obige Ausgabe ist aber vom script ispconfig_update.sh und nicht vom script update.php. Du rufst da also was komplett anderes auf. Ein php script startet man so:

    php update.php
     
  13. teeshop

    teeshop New Member

    ähm, sorry.

    Bin wohl langsam etwas tüddelllütt.
    Werde erstmal an die frische Luft gehen.

    Danke für Deine Mühe

    Gruß

    teeshop
     
  14. Till

    Till Administrator

    Das ist bei dem schönen Wetter sowieso besser als am PC zu sitzen :)
     
  15. teeshop

    teeshop New Member

    Hallo Till,

    ich bin nun genauso vorgegangen, wie Du gesagt hast. Es gab auch keine Fehlermeldungen. Das Problem war, daß ich danach nur noch mit Phpmyadmin auf Mysql zugreifen konnte. Alles andere ging absolut nicht mehr. Kein Passwort passte noch, egal wo.
    Deshalb habe ich mit p -q uninstall.php ISPC wieder deinstalliert, die Datenbankbenutzer dbispconfig, c1florrinda.eu und roundcubemail gelöscht und auch die entsprechenden Datenbanken. Anschließend noch die vhosts im Apache.
    Dann wieder p -q install.php. Lief auch ohne Meldungen durch.
    Vor dem ganzen Durchgang, als ich rouncubemail installiert habe, hatte ich Squirrelmail mit ap-get remove entfernt, habe aber das --purge vergessen.
    Nach der Neuinstallation hab ich auch wieder roundcubemail installiert.
    Es läuft auch bestens. Ich bekomme es aber nicht hin, das der Mailbox-Link in ISPC mich auch zum Roudcube-Login führt.

    Rouncube liegt hier - http://www.frontgates.org/roundcubemail/- und wenn ich auf den besagten Link klicke, lande ich hie r- http://frontgates/webmail, mit der Meldung "Zugriff verweigert".

    Was ich möchte ist, daß ich beim Roundcube-Login lande.

    Könntest Du mir bitte helfen und sagen, wie ich vorgehen muss?

    Grüße

    teeshop
     
  16. Till

    Till Administrator

    Bei Dir steht der falsche Hostname in den Server Einstellungen in ISPConfig. Wenn Du den korrigierst, dann geht auch der webmail link.
     
  17. teeshop

    teeshop New Member

    Okay, habe ich jetzt geändert auf www.florrinda.eu


    Bekomme aber immer noch die Meldung: Zugriff verweigert



    Netzwerk Konfiguration


    IP Adresse: 127.0.0.1
    Netmask: 255.255.255.0
    Gateway: 192.168.0.1
    Hostname: www.florrinda.eu
    Nameserver: 192.168.0.1,192.168.0.2

    Gruß
    Ralph
     
  18. teeshop

    teeshop New Member

    hallo Till,
    ich habe nun das ganze System nochmal neu aufgesetzt -fresh install und jetzt läuft alles glatt, auch die Mailzustellungen intern und extern.

    Ich habe aber eine Benachrichtigung von rkhunter bekommen, die mir sagt daß etwas nicht in Ordnung ist. Kannst du mir vielleicht sagen, was ich tun muß, damit alles richtig läuft? Ich möchte nicht schon wieder einen Fehler machen, gerade bei so wichtigen Sachen.

    Code:
    Von:     root <ralph.walter@kabelmail.de>
    An:     root@frontgates.webhop.org
    Betreff:     [rkhunter] www.frontgates.org - Daily report
    Datum:     20.03.2010 08:43:27
    
    
    Warning: The file properties have changed:
             File: /usr/bin/awk
             Current inode: 9154    Stored inode: 1044
             Current file modification time: 1268698785
             Stored file modification time : 1268694368
    Warning: The file '/usr/bin/curl' exists on the system, but it is not present in the rkhunter.dat file.
    Warning: The file '/usr/bin/mail' exists on the system, but it is not present in the rkhunter.dat file.
    Warning: The file '/usr/bin/gawk' exists on the system, but it is not present in the rkhunter.dat file.
    Warning: The file '/usr/bin/bsd-mailx' exists on the system, but it is not present in the rkhunter.dat file.
    Warning: The file '/usr/sbin/inetd' exists on the system, but it is not present in the rkhunter.dat file.
    Warning: The file '/usr/sbin/unhide' exists on the system, but it is not present in the rkhunter.dat file.
    Warning: The file '/usr/sbin/unhide-linux26' exists on the system, but it is not present in the rkhunter.dat file.
    Warning: Users have been added to the passwd file:
             web2:x:5005:5006::/var/www/clients/client2/web2:/bin/false
    Warning: Groups have been added to the group file:
             sshusers:x:5002:web1,web2
             winbindd_priv:x:127:
             client2:x:5006:www-data
    Warning: Groups have been removed from the group file:
             sshusers:x:5002:web1
             winbindd_priv:x:127:
    Warning: The SSH and rkhunter configuration options should be the same:
             SSH configuration option 'PermitRootLogin': yes
             Rkhunter configuration option 'ALLOW_SSH_ROOT_USER': no
    Warning: Suspicious file types found in /dev:
             /dev/shm/pulse-shm-2163227399: data
             /dev/shm/pulse-shm-2433695879: data
             /dev/shm/pulse-shm-3893927176: data
             /dev/shm/pulse-shm-3055852799: data
    Warning: Hidden directory found: /dev/.udev
    Warning: Hidden directory found: /dev/.initramfs
    Warning: Application 'gpg', version '1.4.9', is out of date, and possibly a security risk.
    Warning: Application 'openssl', version '0.9.8g', is out of date, and possibly a security risk.
    Warning: Application 'php', version '5.2.10', is out of date, and possibly a security risk.
    Warning: Application 'sshd', version '5.1p1', is out of date, and possibly a security risk.
    
    One or more warnings have been found while checking the system.
    Please check the log file (/var/log/rkhunter.log)
    Gruß

    teeshop
     
  19. Till

    Till Administrator

    Ich denke das ist soweit OK. Du hast die Meldung bekommen, da das System neu ist.
     
  20. teeshop

    teeshop New Member

    Danke Dir.

    Gruß

    teeshop
     

Diese Seite empfehlen