mod_rewrite Modul einschalten

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von expert-center, 9. Mai 2009.

  1. expert-center

    expert-center New Member

    ich setzte ISPConfig 2.2.29 ein. Wie und wo kann ich das tun.
     
    Zuletzt bearbeitet: 9. Mai 2009
  2. Till

    Till Administrator

    Rewrite ist immer aktiv.
     
  3. expert-center

    expert-center New Member

    Danke für die schnelle Antwort.
     
  4. mrairbrush

    mrairbrush Member

    trotzdem scheint es das eine oder andere Problem zu geben. Habe eine Seite auf den Server gezogen die rewrite benutzt. Die Links gehen jetzt aber nicht mehr. Entweder erhalte ich einen 505 Fehler wenn htaccess aktiv ist oder bei den Links einen 404 Fehler wenn abgeschaltet. KAnn mir das nicht ganz erklären. Vermute das die Links net passen da auch sqiurell nur über sub.domain.de/webmail erreichbar ist und nicht unter domain.de/webmail

    Habe gesehen das isp extra error logs für die Webs erstellt. Darin habe ich .htaccess: Options not allowed here gefunden.
    Das ispconfig.log ist leer. Muss das so sein? Wo kann ich htaccess erlauben?
     
    Zuletzt bearbeitet: 21. Mai 2009
  5. Till

    Till Administrator

    Poste bitte immer die Exakte Fehlermeldung aus dem Log wenn Du möchtest dass wir Dir helfen.
     
  6. mrairbrush

    mrairbrush Member

    Also dann komplett, fehlt ja nur die Url
     
  7. Till

    Till Administrator

    Verschiebe mal die Zeile mit "Options ...." aus der .htaccess Datei ins apache Direktiven Feld der Webseite.
     
  8. mrairbrush

    mrairbrush Member

    Steh grad auf dem Schlauch. Wo soll ich wohin schieben? in der htaccess steht
    Options +FollowSymLinks

    Die Zeile habe ich in die etc/apache2/apache2.conf kopiert.
     
  9. mrairbrush

    mrairbrush Member

    Ok habs geschnallt. Mußte das in der htaccess noch ausklammern. Nun funktioniert es :)
    Danke,danke, danke....
     
  10. mrairbrush

    mrairbrush Member

    Noch eine Frage. HAbe in einer anderen htaccess noch die Flags
    php_flag eaccelerator.enable 0
    php_flag eaccelerator.optimizer 0
    php_flag mmcache.enable 0
    php_flag mmcache.optimizer 0

    Brint ebenfalls einen Servererror. Muss das da raus und in die php.ini?
     
  11. Till

    Till Administrator

    Das muss da auf jeden Fall raus. Wenn das erlaubt wäre könnte ja jeder User und Hacker alle Sicherheitsmechanismen auf dem Server auch selbst ausschalten. Du kannst es entweder in das apache directives Feld kopieren oder Du lässt es ganz weg.
     
  12. mrairbrush

    mrairbrush Member

    ist von einem vbulletin. Benutzt ihr ja auch hier :D
     
  13. Till

    Till Administrator

    Von welchem Script das kommt ist nicht wirklich relevant :) Also kopier es einfach rüber in das apache direktiven Feld.
     

Diese Seite empfehlen