Monitor ohne Einträge für weiteren Server

Dieses Thema im Forum "Allgemein" wurde erstellt von crazyiven, 24. Sep. 2011.

  1. crazyiven

    crazyiven New Member

    Hallo!

    Ich habe gestern folgende Konfiguration eigentlich vollkommen erfolgreich aufgesetzt:

    Server1 (Vollwertiger Server)
    - Alle Dienste
    - ISPConfig Hauptserver/Panel

    Server2 (Vollwertiger Server)
    - Alle Dienste (Bis auf DNS da selbes Netz wie Server1)

    Server 3 (vServer)
    - Nur DNS (Mirror Server 1)


    Ich sehe wunderbar alle Server und wenn ich einen DNS Eintrag auf Server1 anlege ist der auch auf Server3 abfragbar (dig bzw. nslookup), somit werden die Daten übertragen. Aber im Monitor sind zu Server3 alle Daten bzw Logs leer. Für Server2 sehe ich wunderbar die CPU Infos, Raid Status usw. usw.

    In der Übersicht sehe ich zu Server3 nur:
    Code:
    Server: server3.domain.de
     Status: ok (0 unbekannt, 0 Info, 0 Warnung, 0 kritisch, 0 Fehler)
    
    Mehr Informationen...
    Und auch wenn ich auf Mehr Informationen... klicke kommt nur
    Code:
    Server: server3.domain.de
     Status: ok (0 unbekannt, 0 Info, 0 Warnung, 0 kritisch, 0 Fehler)
    Woran kann das liegen? Oder ist das normal weil Dienste oder so fehlen? Ist ja schon ein wenig komisch finde ich?

    Danke & Gruß
    crazyiven
     
  2. crazyiven

    crazyiven New Member

    Tja richtig schauen ... auf dem vServer war cron nicht installiert und er hatte gar nichts übertragen ... ich hab beim nslookup bzw. dig den "falschen" server gefragt und deswegen die richtigen Ergebnisse gehabt ;)

    Da cron vor der ispconfig installation nicht installiert habe, habe ich nun die cron Einträge von server2 übernommen und kurz danach hatte ich auch Daten im Interface stehen.

    Muss ich sonst noch was beachten? Wird sonst noch was in die Cronjobs geschrieben durch ISPConfig?
     
  3. Till

    Till Administrator

    Du musst 2 cronjobs haben, die sind auf allen servern gleich.
     
  4. crazyiven

    crazyiven New Member

    Die habe ich ... muss ich sonst noch was nachpflegen wg. des fehlenden Crontabs? Wäre vielleicht nen kleiner Hinweis für die Server HowTos, dass man bei vServern auf seine Pakete achten sollte und man eine Liste erstellt was drauf sein sollte?
     
  5. Till

    Till Administrator

    Cron ist auf jedem standard minimal linux installiert und das ist auch die voraussetzung für ispconfig.
     
  6. crazyiven

    crazyiven New Member

    Ich weiss, aber in meinem vServer Image fehlte cron (ka wieso) ... war ja auch nur als Hinweis gedacht ... weiss ja nicht ob es vielleicht noch andere Anbieter neben meinem gibt der bei Custom Images für vServer sowas rauswirft (frag mich bitte aber nicht wieso, ich sehe keinen Sinn darin *g*)
     
  7. Till

    Till Administrator

    Ja, es gibt leider einige anbieter mit sehr schlechten images. Ohne cron läuft ja noch nichtmal logrotation etc. Ich kann ja mal sehen dass ich bei gelegenheit eine komplette paketliste des perfect setups erstelle.
     
  8. crazyiven

    crazyiven New Member

    Das wäre super ... dann kann man sicherstellen dass auf jedenfall alles drauf ist :). Ich werde jetzt noch ein wenig testen ... dann alle drei Server übers WI wieder auf 0 setzen und ein sauberes Produktivsystem erstellen :)

    Danke für die Hilfe und ich freue mich dass ich vlt. eine Anregung geben konnte die anderen helfen kan.. Ich hatte vorher immer ispCP (und auch vorher VHCS), doch ISPConfig steckt die beiden nicht nur wg. Multiserver in die Tasche ... wirklich saubere Arbeit :)

    Ein paar deutsche Texte sind noch ned sauber bzw. werden nicht angezeigt (hatte dazu was in den Bugtracker geschrieben), aber das ist vernachlässigbarer Kleinkram im Vergleich zu den Problemen die man mit den eben genannten Systemen hat bzw. haben kann ... frag nicht nach Sonnenschein sag ich da ;)

    Gruß
    crazyiven
     

Diese Seite empfehlen